aboutsummaryrefslogtreecommitdiffstats
path: root/audio/waveplay
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-06-09 13:53:58 +0800
committeritetcu <itetcu@FreeBSD.org>2006-06-09 13:53:58 +0800
commit492a9253a3e8a3b0d9378e5de645a496de02b694 (patch)
tree36c0bcc81bb5ad80c10dd6816efd2a70910d6198 /audio/waveplay
parent4b10ebb0944fb9ae37846fbfe87aefd862c291c3 (diff)
downloadfreebsd-ports-gnome-492a9253a3e8a3b0d9378e5de645a496de02b694.tar.gz
freebsd-ports-gnome-492a9253a3e8a3b0d9378e5de645a496de02b694.tar.zst
freebsd-ports-gnome-492a9253a3e8a3b0d9378e5de645a496de02b694.zip
Let waveplay display something on systems without sound device or wrong device
passed via -f. PR: ports/98638 Submitted by: maintainer Approved by: lawrance (mentor, implict)
Diffstat (limited to 'audio/waveplay')
-rw-r--r--audio/waveplay/Makefile3
-rw-r--r--audio/waveplay/files/patch-waveplay.c24
2 files changed, 26 insertions, 1 deletions
diff --git a/audio/waveplay/Makefile b/audio/waveplay/Makefile
index 0ac660823c00..fd5102c49d7a 100644
--- a/audio/waveplay/Makefile
+++ b/audio/waveplay/Makefile
@@ -7,8 +7,9 @@
PORTNAME= waveplay
PORTVERSION= 2001.09.24
+PORTREVISION= 1
CATEGORIES= audio
-MASTER_SITES= http://sore.totto.to/~ysonoda/FreeBSD/ports/
+MASTER_SITES= http://www.sokohiki.org/~yoshi/FreeBSD/ports/
DISTNAME= waveplay-20010924
MAINTAINER= yshd@na.rim.or.jp
diff --git a/audio/waveplay/files/patch-waveplay.c b/audio/waveplay/files/patch-waveplay.c
new file mode 100644
index 000000000000..ad6188db85f6
--- /dev/null
+++ b/audio/waveplay/files/patch-waveplay.c
@@ -0,0 +1,24 @@
+*** waveplay.c~ Mon Sep 24 16:38:40 2001
+--- waveplay.c Thu Jun 8 00:22:50 2006
+***************
+*** 286,293 ****
+ int status;
+ int arg;
+
+! if ((fd = open(devname, O_WRONLY)) == -1)
+ return fd;
+
+ /* �����ͥ�(STEREO or MONAURAL)������ */
+ arg = (int)(pwf->nChannels);
+--- 286,296 ----
+ int status;
+ int arg;
+
+! if ((fd = open(devname, O_WRONLY)) == -1) {
+! fprintf(stderr, "%s - ", devname);
+! perror("openDSP");
+ return fd;
++ }
+
+ /* �����ͥ�(STEREO or MONAURAL)������ */
+ arg = (int)(pwf->nChannels);
s'>+1 * - bump all port that indirectly depends on libjpeg and have not yet been bump...dinoex2009-07-311-0/+1 * Presenting GNOME 2.24 for FreeBSD.marcus2009-01-106-33/+331 * Pick up maintainership.kwm2009-01-011-1/+1 * Drop maintainershipalexbl2008-12-121-1/+1 * Conversion from (now defunct) autoconf-2.61 to autoconf-2.62ade2008-08-201-1/+1 * Only add the ffmpeg CPPFLAGS if not building with gstreamer.marcus2008-08-111-1/+4 * Fix the build now that ffmpeg installs libswscale.marcus2008-08-111-1/+1 * - update to 0.6.8alexbl2008-08-072-5/+4 * Bump portrevision due to upgrade of devel/gettext.edwin2008-06-061-0/+1 * - Update to version 0.6.6 (security update)brix2008-05-093-22/+8 * The FreeBSD GNOME team is proud to annunce the release of GNOME 2.22.0 formarcus2008-03-244-42/+68 * - Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORGmiwi2008-03-231-2/+1 * - Remove USE_GETOPT_LONG which is a no-op since March 2007pav2008-03-201-1/+0 * - add a missing + so that new libraries are appended instead ofalexbl2007-12-201-1/+1 * - enable ffmpeg and mad when not using gstreameralexbl2007-12-192-5/+4 * - update to 0.5.5alexbl2007-12-193-8/+16 * - add a missing file to the pllistalexbl2007-10-261-0/+1 * - update swfdec and swfdec-mozilla to 0.5.3alexbl2007-10-233-6/+10 * - update to 0.5.2alexbl2007-09-073-6/+13 * - bump LIBVERSION [1]alexbl2007-08-072-4/+7 * - remove unnecessary USE_GSTREAMERalexbl2007-08-071-1/+0 * - update to 0.5.1 which adds support for OSSalexbl2007-08-063-8/+20 * Update swfdec and swfdec-plugin to 0.5.0.anholt2007-07-143-17/+21 * Reset rainer.alves@gmail.com by request due to current lack of time tolinimon2007-06-301-1/+1 * Update to 0.4.5 and fix packaging.anholt2007-06-213-5/+20 * Add missing dependency on gnomevfs2.anholt2007-05-301-1/+1 * Update swfdec's dependencies for ffmpeg-devel -> ffmpeg merge.anholt2007-05-261-1/+1 * Update swfdec to 0.4.4.anholt2007-05-262-7/+6 * - Welcome X.org 7.2 \o/.flz2007-05-201-0/+1 * Unbreak from my previous update.anholt2007-03-102-3/+5 * BROKEN: Incomplete pkg-plistkris2007-02-271-0/+2 * Update to 0.4.2. This update improves correctness in many ways.anholt2007-02-144-67/+29 * Use gstreamer 0.10 instead of 0.8ahze2007-02-121-2/+2 * Chase the GNOME X11BASE to LOCALBASE move, and fix the build with themarcus2006-10-142-6/+6 * - Update devel/sdl12 to version 1.2.11. Now we employ stock SDL directorystas2006-09-201-1/+1 * - Update gstreamer to 0.10ahze2006-04-301-1/+2 * - Update to 0.3.6pav2006-04-155-32/+13 * Reset kwm due to no response about email.linimon2006-04-151-1/+1 * SHA256ifyedwin2006-01-221-0/+1 * Bump PORTREVISION to chase the glib20 shared library update.marcus2005-11-051-0/+1 * Update to 0.3.5.kwm2005-05-272-6/+6 * update to 0.3.4.kwm2005-03-212-3/+4 * Update to 0.3.3.kwm2005-03-213-5/+7 * Bump PORTREVISION to chase the glib20 shared lib version change.marcus2005-03-121-1/+1 * Correct gimp lib name.kwm2005-02-221-3/+10 * Fix plist en register optional gimp dependencie.kwm2005-02-152-7/+17 * fix plist, clean up some empty dirs.kwm2005-01-102-0/+6 * Update to version 0.3.2 [1].kwm2004-12-168-59/+58 * Bump PORTREVISIONS for all ports that depend on atk or pango to ease in themarcus2004-11-081-1/+1 * Apply a big libtool patch to allow porters to use the libtool installed bymarcus2004-07-101-1/+1 * Adjust the gtk20 path for modules, themes, and input methods to catch upmarcus2004-04-051-2/+2 * Use an appropriate GLib type which should fix the build on both 32 and 64-bitmarcus2004-04-031-3/+3 * Fix build on 64bit platformsarved2004-03-292-4/+11 * Chase library bump of libSDL-1.1 for all ports which were dependingedwin2004-03-161-1/+1 * BROKEN on !i386: Does not compilekris2004-03-131-1/+7 * Properly use SDL everywhere:edwin2004-03-081-1/+1 * Bump PORTREVISION on all ports that depend on gettext to aid with upgrading.marcus2004-02-041-1/+1 * SIZEify.trevor2004-01-291-0/+1 * Switch dependency mad -> libmad as more apropriate.bland2003-12-081-2/+2 * Chase the libmad/libid3tag shared lib version.marcus2003-12-071-1/+2 * USE_REINPLACE must be defined before REINPLACE_CMD may be used.trevor2003-11-171-0/+1 * update graphics/swfdec:daichi2003-07-311-7/+2 * Update to 0.2.2.petef2003-06-022-5/+4 * Fix a typo in the Makefile; this fixes the build on alpha 5.1.petef2003-06-011-1/+1 * - install .pc file to the correct placepetef2003-05-193-28/+17 * add missing dependenceijliao2003-04-121-2/+3