aboutsummaryrefslogtreecommitdiffstats
path: root/audio/wmtune
diff options
context:
space:
mode:
authorjedgar <jedgar@FreeBSD.org>2002-07-20 01:34:47 +0800
committerjedgar <jedgar@FreeBSD.org>2002-07-20 01:34:47 +0800
commite5476f6aae36533b45eda0ac9d550c6b43d72d06 (patch)
tree2ca3b28b5f100a245fee04d62965a990db06b911 /audio/wmtune
parentfb451ce9c55ddd69b1c8a85a9e7ecbb6e0624e4c (diff)
downloadfreebsd-ports-gnome-e5476f6aae36533b45eda0ac9d550c6b43d72d06.tar.gz
freebsd-ports-gnome-e5476f6aae36533b45eda0ac9d550c6b43d72d06.tar.zst
freebsd-ports-gnome-e5476f6aae36533b45eda0ac9d550c6b43d72d06.zip
o SED -> REINPLACE
o s|machine/soundcard.h|sys/soundcard.h|
Diffstat (limited to 'audio/wmtune')
-rw-r--r--audio/wmtune/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/audio/wmtune/Makefile b/audio/wmtune/Makefile
index 568c9913b695..e5fafab6aa62 100644
--- a/audio/wmtune/Makefile
+++ b/audio/wmtune/Makefile
@@ -20,6 +20,7 @@ MAINTAINER= jedgar@FreeBSD.org
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_XPM= yes
+USE_REINPLACE= yes
PATCH_ARGS =-p0 -d ${WRKDIR}
@@ -39,9 +40,10 @@ WMTUNE_DIFF= wmtune.radiotrack.diff.gz
post-patch:
@${GUNZIP_CMD} -c ${DISTDIR}/${WMTUNE_DIFF} | ${PATCH} ${PATCH_ARGS}
- @${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.orig
- @${SED} -e 's|-O2|${CFLAGS}|' -e 's|cc|${CC}|' \
- < ${WRKSRC}/Makefile.orig > ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|-O2|${CFLAGS}|' -e 's|cc|${CC}|' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|machine/soundcard.h|sys/soundcard.h|' \
+ ${WRKSRC}/src/wmtune.c
do-configure:
@${PERL} -pi.orig -e 's|/etc|${PREFIX}/etc|' ${WRKSRC}/src/wmtune.c