aboutsummaryrefslogtreecommitdiffstats
path: root/audio/wsoundprefs
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-04-11 00:35:23 +0800
committerpav <pav@FreeBSD.org>2005-04-11 00:35:23 +0800
commit7d7280f0626f28f66d66cc2c3269fce22b25b19b (patch)
treec65bbd8acf5bf7d03b68a113ffddb4238078a4d3 /audio/wsoundprefs
parent8a48f005056b07f4a1e0411f88e2684d68f42c8b (diff)
downloadfreebsd-ports-gnome-7d7280f0626f28f66d66cc2c3269fce22b25b19b.tar.gz
freebsd-ports-gnome-7d7280f0626f28f66d66cc2c3269fce22b25b19b.tar.zst
freebsd-ports-gnome-7d7280f0626f28f66d66cc2c3269fce22b25b19b.zip
- link against fontconfig [1] and libXft [2]
- misc WM api changes [1] and [2] - XClearArea -> XFillRectangle with gray [1] because XClearArea is for Window not Drawable (was causing X BadWindow error) [1] me [2] ports/75000 Serge Gagnon <ser_gagnon@sympatico.ca> If you hit "play" with a nonexistant file, the program dies - but apart from that it's now functional again. PR: ports/79746 Submitted by: Sam Lawrance <boris@brooknet.com.au>
Diffstat (limited to 'audio/wsoundprefs')
-rw-r--r--audio/wsoundprefs/Makefile4
-rw-r--r--audio/wsoundprefs/files/patch-ab13
-rw-r--r--audio/wsoundprefs/files/patch-ac45
-rw-r--r--audio/wsoundprefs/files/patch-src-WSoundPrefs.c20
-rw-r--r--audio/wsoundprefs/files/patch-src-main.c14
5 files changed, 77 insertions, 19 deletions
diff --git a/audio/wsoundprefs/Makefile b/audio/wsoundprefs/Makefile
index 63a015272d9c..949803bbdb57 100644
--- a/audio/wsoundprefs/Makefile
+++ b/audio/wsoundprefs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wsoundprefs
PORTVERSION= 1.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio windowmaker
MASTER_SITES= ${MASTER_SITE_NETBSD}
DISTNAME= WSoundPrefs-${PORTVERSION}
@@ -15,8 +15,6 @@ DISTNAME= WSoundPrefs-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A utility for configuring sounds to play for Window Maker events
-BROKEN= "Does not build with new version of windowmaker"
-
BUILD_DEPENDS= wmaker:${PORTSDIR}/x11-wm/windowmaker
LIB_DEPENDS= PropList.2:${PORTSDIR}/devel/libPropList \
wsound.1:${PORTSDIR}/audio/wsoundserver
diff --git a/audio/wsoundprefs/files/patch-ab b/audio/wsoundprefs/files/patch-ab
index 24bdbbf3d0bf..1f12b642e8cd 100644
--- a/audio/wsoundprefs/files/patch-ab
+++ b/audio/wsoundprefs/files/patch-ab
@@ -1,5 +1,5 @@
---- src/Imakefile.orig Mon Oct 18 17:35:58 1999
-+++ src/Imakefile Sun Dec 10 17:09:01 2000
+--- src/Imakefile.orig Mon Oct 18 18:35:58 1999
++++ src/Imakefile Sat Apr 9 17:20:36 2005
@@ -5,9 +5,9 @@
ICONS = WSoundPrefs.xpm WSoundPrefs.tiff
@@ -12,7 +12,7 @@
XCOMM EFENCELIB = -lefence
EFENCELIB =
-@@ -18,9 +18,9 @@
+@@ -18,19 +18,19 @@
WRASTERCFLAGS = `get-wraster-flags --cflags`
WRASTERLFLAGS = `get-wraster-flags --lflags`
WRASTERLIBS = `get-wraster-flags --libs`
@@ -24,8 +24,11 @@
+STD_INCLUDES = $(WRASTERCFLAGS) -I${LOCALBASE}/include -I${X11BASE}/include -I${X11BASE}/include/WINGs
DEPLIBS = $(DEPXLIB)
- LOCAL_LIBRARIES = $(XLIB) $(WINGSLIBS) $(WSOUNDLFLAGS) $(WSOUNDLIBS) $(WRASTERLFLAGS) $(WRASTERLIBS) $(EFENCELIB)
-@@ -30,7 +30,7 @@
+-LOCAL_LIBRARIES = $(XLIB) $(WINGSLIBS) $(WSOUNDLFLAGS) $(WSOUNDLIBS) $(WRASTERLFLAGS) $(WRASTERLIBS) $(EFENCELIB)
++LOCAL_LIBRARIES = $(XLIB) $(WINGSLIBS) $(WSOUNDLFLAGS) $(WSOUNDLIBS) $(WRASTERLFLAGS) $(WRASTERLIBS) $(EFENCELIB) $(FONTCONFIGLIB) $(XFTLIB) -lintl
+
+ LINTLIBS = $(LINTXLIB)
+
SRCS = PLFunctions.c SoundEvents.c SoundPaths.c SystemInfo.c WSoundPrefs.c main.c
OBJS = PLFunctions.o SoundEvents.o SoundPaths.o SystemInfo.o WSoundPrefs.o main.o
diff --git a/audio/wsoundprefs/files/patch-ac b/audio/wsoundprefs/files/patch-ac
index 3d64875eb10c..576de4c46b6f 100644
--- a/audio/wsoundprefs/files/patch-ac
+++ b/audio/wsoundprefs/files/patch-ac
@@ -1,6 +1,37 @@
---- src/SoundPaths.c.orig Sat Jun 19 02:08:04 1999
-+++ src/SoundPaths.c Sat Jun 19 23:23:41 1999
-@@ -71,6 +71,7 @@
+--- src/SoundPaths.c.orig Mon Jun 14 17:28:21 1999
++++ src/SoundPaths.c Sun Apr 10 21:41:00 2005
+@@ -42,7 +42,8 @@
+ Panel *panel = (Panel*)WMGetHangedData(lPtr);
+ WMScreen *scr = WMWidgetScreen(lPtr);
+ Display *dpy = WMScreenDisplay(scr);
+-
++ WMColor *gray = WMGrayColor(scr);
++
+ width = rect->size.width;
+ height = rect->size.height;
+ x = rect->pos.x;
+@@ -50,13 +51,16 @@
+
+ if (state & WLDSSelected)
+ XFillRectangle(dpy, d, WMColorGC(panel->white), x, y, width, height);
+- else
+- XClearArea(dpy, d, x, y, width, height, False);
++ else
++ XFillRectangle(dpy, d, WMColorGC(gray), x, y, width, height);
++
+
+ if (state & 1)
+- WMDrawString(scr, d, WMColorGC(panel->red), panel->font, x+4, y, text, strlen(text));
++ WMDrawString(scr, d, panel->red, panel->font, x+4, y, text, strlen(text));
+ else
+- WMDrawString(scr, d, WMColorGC(panel->black), panel->font, x+4, y,text, strlen(text));
++ WMDrawString(scr, d, panel->black, panel->font, x+4, y,text, strlen(text));
++
++ WMReleaseColor(gray);
+ }
+
+ void
+@@ -71,6 +75,7 @@
wwarning(_("bad value in option SoundPath. Using default path list"));
addPathToList(panel->sndL, -1, "~/GNUstep/Library/WindowMaker/Sounds");
addPathToList(panel->sndL, -1, "/usr/local/share/WindowMaker/Sounds");
@@ -8,11 +39,3 @@
} else {
for (i=0; i<PLGetNumberOfElements(array); i++) {
val = PLGetArrayElement(array, i);
-@@ -91,6 +92,7 @@
- wwarning(_("bad value in option SoundSetPath. Using default path list"));
- addPathToList(panel->sndsetL, -1, "~/GNUstep/Library/WindowMaker/SoundSets");
- addPathToList(panel->sndsetL, -1, "/usr/local/share/WindowMaker/SoundSets");
-+ addPathToList(panel->sndsetL, -1, "/usr/X11R6/share/WindowMaker/SoundSets");
- } else {
- for (i=0; i<PLGetNumberOfElements(array); i++) {
- val = PLGetArrayElement(array, i);
diff --git a/audio/wsoundprefs/files/patch-src-WSoundPrefs.c b/audio/wsoundprefs/files/patch-src-WSoundPrefs.c
new file mode 100644
index 000000000000..59c9216718c6
--- /dev/null
+++ b/audio/wsoundprefs/files/patch-src-WSoundPrefs.c
@@ -0,0 +1,20 @@
+--- src/WSoundPrefs.c.orig Sat Mar 4 21:46:11 2000
++++ src/WSoundPrefs.c Sun Apr 10 21:37:11 2005
+@@ -378,7 +378,7 @@
+ WMResizeWidget(panel->iconL, 72, 72);
+ WMMoveWidget(panel->iconL, 82, 10);
+ WMSetLabelImagePosition(panel->iconL, WIPImageOnly);
+- WMSetLabelImage(panel->iconL, WMGetApplicationIconImage(scr));
++ WMSetLabelImage(panel->iconL, WMGetApplicationIconPixmap(scr));
+
+ /* Title */
+ panel->titleL = WMCreateLabel(panel->aboutF);
+@@ -407,7 +407,7 @@
+ WMResizeWidget(panel->copyrightL, 448, 20);
+ WMMoveWidget(panel->copyrightL, 8, 178);
+ WMSetLabelTextAlignment(panel->copyrightL, WACenter);
+- font = WMCreateNormalFont(scr, "-*-helvetica-medium-r-normal-*-10-*-*-*-*-*-*-*");
++ font = WMCreateFont(scr, "-*-helvetica-medium-r-normal-*-10-*-*-*-*-*-*-*");
+ if (font)
+ WMSetLabelText(panel->copyrightL, "Copyright \xa9 1999 The Az\xe5rg-r\xfbh");
+ else {
diff --git a/audio/wsoundprefs/files/patch-src-main.c b/audio/wsoundprefs/files/patch-src-main.c
new file mode 100644
index 000000000000..bdf38adab6d9
--- /dev/null
+++ b/audio/wsoundprefs/files/patch-src-main.c
@@ -0,0 +1,14 @@
+--- src/main.c.orig Mon Jun 14 17:28:23 1999
++++ src/main.c Sun Apr 10 20:51:47 2005
+@@ -109,9 +109,9 @@
+ wwarning(_("could not load image file %s:%s"), path, RMessageForError(RErrorCode));
+ else {
+ icon = WMCreatePixmapFromRImage(scr, tmp, 0);
+- RDestroyImage(tmp);
++ RReleaseImage(tmp);
+ if (icon) {
+- WMSetApplicationIconImage(scr, icon);
++ WMSetApplicationIconPixmap(scr, icon);
+ WMReleasePixmap(icon);
+ }
+ }