aboutsummaryrefslogtreecommitdiffstats
path: root/audio/x11amp/Makefile
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-02-05 02:25:36 +0800
committersat <sat@FreeBSD.org>2007-02-05 02:25:36 +0800
commitd268f00848daacf22b96f921d3917b96013993cf (patch)
tree396ceac9638f155972d1ff259c0ffc48c83a69ef /audio/x11amp/Makefile
parenta5ce2174e90c953624c0eaa7fa1f7d767bae8f17 (diff)
downloadfreebsd-ports-gnome-d268f00848daacf22b96f921d3917b96013993cf.tar.gz
freebsd-ports-gnome-d268f00848daacf22b96f921d3917b96013993cf.tar.zst
freebsd-ports-gnome-d268f00848daacf22b96f921d3917b96013993cf.zip
- /objformat=/s|=.*|=elf| [1]
- Don't build static lib Reported by: pointyhat via kris [1] Approved by: Beech Rintoul <freebsd@alaskaparadise.com> (maintainer)
Diffstat (limited to 'audio/x11amp/Makefile')
-rw-r--r--audio/x11amp/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/audio/x11amp/Makefile b/audio/x11amp/Makefile
index ed3221c84211..6d41f9affe73 100644
--- a/audio/x11amp/Makefile
+++ b/audio/x11amp/Makefile
@@ -21,6 +21,7 @@ USE_XLIB= yes
USE_GNOME= gtk12 esound
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static
CONFIGURE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
@@ -30,4 +31,7 @@ post-extract:
@${CP} ${FILESDIR}/main.xpm ${WRKSRC}/x11amp/defskin
@${CHMOD} a+x ${WRKSRC}/ltconfig
+post-patch:
+ @${REINPLACE_CMD} -e '/objformat=/s|=.*|=elf|' ${WRKSRC}/ltconfig
+
.include <bsd.port.post.mk>