aboutsummaryrefslogtreecommitdiffstats
path: root/audio/x11amp
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-01-18 15:57:22 +0800
committermiwi <miwi@FreeBSD.org>2007-01-18 15:57:22 +0800
commit47cb27ca1b544487ec68250cd1351c9f0bce8f5c (patch)
treebca660952bf3361839adba2eae0d6c5879ce0aa3 /audio/x11amp
parentab1387532b5f80b498400e264d91087f9589287b (diff)
downloadfreebsd-ports-gnome-47cb27ca1b544487ec68250cd1351c9f0bce8f5c.tar.gz
freebsd-ports-gnome-47cb27ca1b544487ec68250cd1351c9f0bce8f5c.tar.zst
freebsd-ports-gnome-47cb27ca1b544487ec68250cd1351c9f0bce8f5c.zip
- Fix build with gcc4.X
PR: 108065 Submitted by: trasz Approved by: maintainer
Diffstat (limited to 'audio/x11amp')
-rw-r--r--audio/x11amp/Makefile2
-rw-r--r--audio/x11amp/files/patch-x11amp-input.c13
2 files changed, 14 insertions, 1 deletions
diff --git a/audio/x11amp/Makefile b/audio/x11amp/Makefile
index 4f2c32e520c3..ed3221c84211 100644
--- a/audio/x11amp/Makefile
+++ b/audio/x11amp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= x11amp
PORTVERSION= 0.9.b1.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= ftp://ftp.cs.tu-berlin.de/pub/misc/x11amp/0.9/ \
ftp://ftp.x11amp.bz.nu/x11amp/0.9/ \
diff --git a/audio/x11amp/files/patch-x11amp-input.c b/audio/x11amp/files/patch-x11amp-input.c
new file mode 100644
index 000000000000..ecbfd2e533fb
--- /dev/null
+++ b/audio/x11amp/files/patch-x11amp-input.c
@@ -0,0 +1,13 @@
+--- x11amp/input.c.orig Thu Jan 18 01:29:04 2007
++++ x11amp/input.c Thu Jan 18 01:30:03 2007
+@@ -650,8 +650,8 @@
+ #define LOG2_N_WAVE 10 /* log2(N_WAVE) */
+ #define N_LOUD 100 /* dimension of Loudampl[] */
+
+-extern fixed Sinewave[N_WAVE]; /* placed at end of this file for clarity */
+-extern fixed Loudampl[N_LOUD];
++static fixed Sinewave[N_WAVE]; /* placed at end of this file for clarity */
++static fixed Loudampl[N_LOUD];
+ static int db_from_ampl(fixed re, fixed im);
+ static fixed fix_mpy(fixed a, fixed b);
+