aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xanalyser
diff options
context:
space:
mode:
authorxride <xride@FreeBSD.org>2006-11-10 02:41:59 +0800
committerxride <xride@FreeBSD.org>2006-11-10 02:41:59 +0800
commitcc47ee286dc66b655eb7a313d21021d68ac2090a (patch)
tree2f79b7ad7d8ff4874fbbfdaf80cf6eb852e2a4e1 /audio/xanalyser
parent6bf432a205aaa8557c85501b88c090acef8ec913 (diff)
downloadfreebsd-ports-gnome-cc47ee286dc66b655eb7a313d21021d68ac2090a.tar.gz
freebsd-ports-gnome-cc47ee286dc66b655eb7a313d21021d68ac2090a.tar.zst
freebsd-ports-gnome-cc47ee286dc66b655eb7a313d21021d68ac2090a.zip
Add xanalyser 1.29
XAnalyser is a program to analyse a stereo audio signal. It has two displays: Frequency Spectrum Using Fast Fourier Transform, the time domain of the signal is transformed into the frequency domain, i.e. the amplitude (in logarithmic scale) of the audio signal is plotted versus the frequency. Either the sum of the left and right channel of the audio signal can be shown or both channels simultaneously. XY Scope Roughly speaking, the audio signal of left channel deflects a point horizontally and the right channel vertically (just as the beam of a CRT would do). Thus, an audio signal only present on the left channel produces a horizontal line, whereas an audio signal only present on the right channel produces a vertical line. A mono signal produces a 45 degree line. A stereo signal creates a wilde pattern (if the phase is correct, predominately in the same direction as a mono signal) or may even fill the entire scope. WWW: http://arvin.schnell-web.net/xanalyser/ PR: 105059 Submitted by: Diane Bruce <db@db.net> Approved by: tmclaugh (mentor)
Diffstat (limited to 'audio/xanalyser')
-rw-r--r--audio/xanalyser/Makefile27
-rw-r--r--audio/xanalyser/distinfo3
-rw-r--r--audio/xanalyser/files/patch-Makefile.in11
-rw-r--r--audio/xanalyser/files/patch-src_Sample.cc11
-rw-r--r--audio/xanalyser/files/patch-src_pcm-cdr.cc11
-rw-r--r--audio/xanalyser/files/patch-src_pcm-wav.cc11
-rw-r--r--audio/xanalyser/files/patch-src_pcm.cc47
-rw-r--r--audio/xanalyser/pkg-descr20
8 files changed, 141 insertions, 0 deletions
diff --git a/audio/xanalyser/Makefile b/audio/xanalyser/Makefile
new file mode 100644
index 000000000000..f468248e56d4
--- /dev/null
+++ b/audio/xanalyser/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: xanalyser
+# Date created: October 29 2006
+# Whom: Diane Bruce <db@db.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= xanalyser
+PORTVERSION= 1.29
+CATEGORIES= audio hamradio
+MASTER_SITES= http://arvin.schnell-web.net/xanalyser/
+
+MAINTAINER= db@db.net
+COMMENT= Spectrum analyser
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_XLIB= yes
+USE_MOTIF= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:15
+MAN1= xanalyser.1
+PLIST_FILES= bin/xanalyser \
+ lib/X11/app-defaults/XAnalyser
+
+.include <bsd.port.mk>
diff --git a/audio/xanalyser/distinfo b/audio/xanalyser/distinfo
new file mode 100644
index 000000000000..c876c04fd081
--- /dev/null
+++ b/audio/xanalyser/distinfo
@@ -0,0 +1,3 @@
+MD5 (xanalyser-1.29.tar.bz2) = 646ac3ac60fbf5d1be4637a50d37aebe
+SHA256 (xanalyser-1.29.tar.bz2) = 00887546dfa74068b7ac13d281a45bc4f042628092adffd72aa127baf49df676
+SIZE (xanalyser-1.29.tar.bz2) = 83145
diff --git a/audio/xanalyser/files/patch-Makefile.in b/audio/xanalyser/files/patch-Makefile.in
new file mode 100644
index 000000000000..39b608fe871d
--- /dev/null
+++ b/audio/xanalyser/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Sun Oct 29 21:51:38 2006
++++ src/Makefile.in Sun Oct 29 21:52:16 2006
+@@ -188,7 +188,7 @@
+ utils.cc utils.h \
+ Trans.h
+
+-xanalyser_LDADD = -lXext -lXm -lXt -lSM -lICE -lXmu -lXpm -lX11 \
++xanalyser_LDADD = -lXext ${MOTIFLIB} -lXt -lSM -lICE -lXmu -lXpm -lX11 \
+ $(FFTWLDADD) $(ALSALDADD)
+
+ EXTRA_DIST = XAnalyser.ad help.txt *.xpm
diff --git a/audio/xanalyser/files/patch-src_Sample.cc b/audio/xanalyser/files/patch-src_Sample.cc
new file mode 100644
index 000000000000..f8bee277cb5b
--- /dev/null
+++ b/audio/xanalyser/files/patch-src_Sample.cc
@@ -0,0 +1,11 @@
+--- src/Sample.cc.orig Sun Oct 29 20:53:54 2006
++++ src/Sample.cc Sun Oct 29 20:54:32 2006
+@@ -12,6 +12,8 @@
+ #include <errno.h>
+ #ifdef __NetBSD__
+ # include <machine/endian.h>
++#elif __FreeBSD__
++# include <sys/endian.h>
+ #else
+ # include <endian.h>
+ #endif
diff --git a/audio/xanalyser/files/patch-src_pcm-cdr.cc b/audio/xanalyser/files/patch-src_pcm-cdr.cc
new file mode 100644
index 000000000000..389655bcf624
--- /dev/null
+++ b/audio/xanalyser/files/patch-src_pcm-cdr.cc
@@ -0,0 +1,11 @@
+--- src/pcm-cdr.cc.orig Sun Oct 29 20:50:05 2006
++++ src/pcm-cdr.cc Sun Oct 29 20:50:43 2006
+@@ -12,6 +12,8 @@
+ #include <errno.h>
+ #include <string.h>
+ #include <iostream>
++#include <sys/types.h>
++#include <sys/stat.h>
+
+ using std::cerr;
+
diff --git a/audio/xanalyser/files/patch-src_pcm-wav.cc b/audio/xanalyser/files/patch-src_pcm-wav.cc
new file mode 100644
index 000000000000..76f1827b29dc
--- /dev/null
+++ b/audio/xanalyser/files/patch-src_pcm-wav.cc
@@ -0,0 +1,11 @@
+--- src/pcm-wav.cc.orig Sun Oct 29 20:52:28 2006
++++ src/pcm-wav.cc Sun Oct 29 20:52:38 2006
+@@ -12,6 +12,8 @@
+ #include <errno.h>
+ #include <string.h>
+ #include <iostream>
++#include <sys/types.h>
++#include <sys/stat.h>
+
+ using std::cerr;
+
diff --git a/audio/xanalyser/files/patch-src_pcm.cc b/audio/xanalyser/files/patch-src_pcm.cc
new file mode 100644
index 000000000000..80fb01fd985c
--- /dev/null
+++ b/audio/xanalyser/files/patch-src_pcm.cc
@@ -0,0 +1,47 @@
+--- src/pcm.cc.orig Sun Oct 29 20:39:22 2006
++++ src/pcm.cc Sun Oct 29 20:47:16 2006
+@@ -9,6 +9,8 @@
+ #include <stdlib.h>
+ #ifdef __NetBSD__
+ # include <machine/byte_swap.h>
++#elif __FreeBSD__
++# include <sys/endian.h>
+ #else
+ # include <byteswap.h>
+ #endif
+@@ -163,7 +165,7 @@
+ case S16: {
+ int16_t* tmp_buffer = (int16_t*) buffer;
+ for (size_t i = n; i != 0; i--) {
+-#ifdef __NetBSD__
++#if defined (__NetBSD__) || (__FreeBSD__)
+ *tmp_buffer = bswap16 (*tmp_buffer);
+ #else
+ *tmp_buffer = bswap_16 (*tmp_buffer);
+@@ -175,7 +177,7 @@
+ case S32: {
+ int32_t* tmp_buffer = (int32_t*) buffer;
+ for (size_t i = n; i != 0; i--) {
+-#ifdef __NetBSD__
++#if defined (__NetBSD__) || (__FreeBSD__)
+ *tmp_buffer = bswap32 (*tmp_buffer);
+ #else
+ *tmp_buffer = bswap_32 (*tmp_buffer);
+@@ -191,7 +193,7 @@
+ PCM::uint16_to_le (uint16_t i) const
+ {
+ #if __BYTE_ORDER == __BIG_ENDIAN
+-# ifdef __NetBSD__
++# if defined (__NetBSD__) || (__FreeBSD__)
+ return bswap16 (i);
+ # else
+ return bswap_16 (i);
+@@ -206,7 +208,7 @@
+ PCM::uint32_to_le (uint32_t i) const
+ {
+ #if __BYTE_ORDER == __BIG_ENDIAN
+-# ifdef __NetBSD__
++# if defined (__NetBSD__)||(__FreeBSD__)
+ return bswap32 (i);
+ # else
+ return bswap_32 (i);
diff --git a/audio/xanalyser/pkg-descr b/audio/xanalyser/pkg-descr
new file mode 100644
index 000000000000..e8ef130c6a7b
--- /dev/null
+++ b/audio/xanalyser/pkg-descr
@@ -0,0 +1,20 @@
+XAnalyser is a program to analyse a stereo audio signal. It has two displays:
+
+Frequency Spectrum
+Using Fast Fourier Transform, the time domain of the signal is transformed into
+the frequency domain, i.e. the amplitude (in logarithmic scale) of the
+audio signal is plotted versus the frequency. Either the sum of the
+left and right channel of the audio signal can be shown or both
+channels simultaneously.
+
+XY Scope
+Roughly speaking, the audio signal of left channel deflects a point
+horizontally and the right channel vertically (just as the beam of a CRT
+would do). Thus, an audio signal only present on the left channel produces
+a horizontal line, whereas an audio signal only present on the right channel
+produces a vertical line. A mono signal produces a 45 degree line.
+A stereo signal creates a wilde pattern (if the phase is correct,
+predominately in the same direction as a mono signal) or may even fill
+the entire scope.
+
+WWW: http://arvin.schnell-web.net/xanalyser/