aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xcd/files
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-12-08 02:38:36 +0800
committerdanilo <danilo@FreeBSD.org>2013-12-08 02:38:36 +0800
commit61a1e504abc31db726796a79e885afaa7fa5ca69 (patch)
tree4a9072d9d66ac005bc08016f7e301c6f05822be3 /audio/xcd/files
parentce36656c4278dc00366fb2912ebdaa8c3f3b3c93 (diff)
downloadfreebsd-ports-gnome-61a1e504abc31db726796a79e885afaa7fa5ca69.tar.gz
freebsd-ports-gnome-61a1e504abc31db726796a79e885afaa7fa5ca69.tar.zst
freebsd-ports-gnome-61a1e504abc31db726796a79e885afaa7fa5ca69.zip
- Fix build (remove BROKEN). Use CXX as compiler instead of CC.
- Add stage support
Diffstat (limited to 'audio/xcd/files')
-rw-r--r--audio/xcd/files/patch-Makefile36
1 files changed, 34 insertions, 2 deletions
diff --git a/audio/xcd/files/patch-Makefile b/audio/xcd/files/patch-Makefile
index 1b82d41ace8e..4ac12910accf 100644
--- a/audio/xcd/files/patch-Makefile
+++ b/audio/xcd/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 1998-10-27 01:14:26.000000000 +0100
-+++ Makefile 2013-09-23 14:57:00.000000000 +0200
+--- ./Makefile.orig 1998-10-26 22:14:26.000000000 -0200
++++ ./Makefile 2013-12-07 16:02:51.000000000 -0200
@@ -1,6 +1,6 @@
-BINDIR = /usr/local/bin
-CDDIR = /usr/local/lib/xcd
@@ -10,3 +10,35 @@
all: cdplayer xcd
xcd: xcd.in
+@@ -8,20 +8,20 @@
+ < xcd.in > $@
+ chmod ugo+x xcd
+ cdplayer: cdplayer.cc
+- $(CC) $(CFLAGS) -o $@ cdplayer.cc -lm
++ $(CXX) $(CFLAGS) -o $@ cdplayer.cc -lm
+
+ install: xcd cdplayer
+- mkdir -p $(BINDIR)
+- mkdir -p $(MANDIR)
+- mkdir -p $(CDDIR)
+- install -c -s cdplayer $(CDDIR)
+- install -c xcd $(BINDIR)
+- install -c xcd.1 $(MANDIR)
++ mkdir -p ${DESTDIR}$(BINDIR)
++ mkdir -p ${DESTDIR}$(MANDIR)
++ mkdir -p ${DESTDIR}$(CDDIR)
++ install -c -s cdplayer ${DESTDIR}$(CDDIR)
++ install -c xcd ${DESTDIR}$(BINDIR)
++ install -c xcd.1 ${DESTDIR}$(MANDIR)
+ for f in bitmaps/*.xbm ; do \
+- install -c $$f $(CDDIR); \
++ install -c $$f ${DESTDIR}$(CDDIR); \
+ done
+
+ install.prog: xcd cdplayer
+- mkdir -p $(BINDIR)
+- install -c -s cdplayer $(CDDIR)
+- install -c xcd $(BINDIR)
++ mkdir -p ${DESTDIR}$(BINDIR)
++ install -c -s cdplayer ${DESTDIR}$(CDDIR)
++ install -c xcd ${DESTDIR}$(BINDIR)