aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xfce4-mixer/Makefile
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2013-10-16 02:36:02 +0800
committerolivierd <olivierd@FreeBSD.org>2013-10-16 02:36:02 +0800
commitf19c5c760df49abb4957926e7ef1fcbfe2cd7a6d (patch)
tree86377d0e922207e753983679587f0d16a831ac7d /audio/xfce4-mixer/Makefile
parentf39e3ee356569bf4f0787f907b75b1bef051e5aa (diff)
downloadfreebsd-ports-gnome-f19c5c760df49abb4957926e7ef1fcbfe2cd7a6d.tar.gz
freebsd-ports-gnome-f19c5c760df49abb4957926e7ef1fcbfe2cd7a6d.tar.zst
freebsd-ports-gnome-f19c5c760df49abb4957926e7ef1fcbfe2cd7a6d.zip
- Support STAGEDIR
While I'm here - Switch to USES= gmake - Convert to new LIB_DEPENDS format - Enhance COMMENT entry (misc/xfce4-wm-themes) - Adjust Xfce dependencies, and bump PORTREVISION (sysutils/xfce4-power-manager)
Diffstat (limited to 'audio/xfce4-mixer/Makefile')
-rw-r--r--audio/xfce4-mixer/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/audio/xfce4-mixer/Makefile b/audio/xfce4-mixer/Makefile
index ec047054df84..7426f2722b78 100644
--- a/audio/xfce4-mixer/Makefile
+++ b/audio/xfce4-mixer/Makefile
@@ -12,13 +12,12 @@ DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
COMMENT= Volume control for the Xfce desktop
-LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
- unique-1:${PORTSDIR}/x11-toolkits/unique
+LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
+ libunique-1.0.so:${PORTSDIR}/x11-toolkits/unique
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USES= gmake pkgconfig gettext pathfix
-NO_STAGE= yes
USE_BZIP2= yes
USE_GNOME= glib20 gtk20 intltool intlhack
USE_XFCE= configenv libmenu libutil panel xfconf
@@ -30,12 +29,10 @@ OPTIONS_DEFINE= KEYBIND
KEYBIND_DESC= Multimedia keyboard shortcuts
-MAN1= xfce4-mixer.1
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MKEYBIND}
-LIB_DEPENDS+= keybinder:${PORTSDIR}/x11/keybinder
+LIB_DEPENDS+= libkeybinder.so:${PORTSDIR}/x11/keybinder
CONFIGURE_ARGS+=--enable-keybinder
.else
CONFIGURE_ARGS+=--disable-keybinder