aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xmms-infopipe
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2007-03-29 19:48:40 +0800
committerehaupt <ehaupt@FreeBSD.org>2007-03-29 19:48:40 +0800
commitc43a7ba631f983add3b9ae8610beebdaa9667733 (patch)
treea1b9cd02dc97cb993bd4f4a3e66a71d345d591fc /audio/xmms-infopipe
parent84d2385b3de7c21b0923bb0c60d1b22ac45a96b5 (diff)
downloadfreebsd-ports-gnome-c43a7ba631f983add3b9ae8610beebdaa9667733.tar.gz
freebsd-ports-gnome-c43a7ba631f983add3b9ae8610beebdaa9667733.tar.zst
freebsd-ports-gnome-c43a7ba631f983add3b9ae8610beebdaa9667733.zip
- Cleanup objformat-removal fallout
- Use USE_LDCONFIG instead of INSTALLS_SHLIB
Diffstat (limited to 'audio/xmms-infopipe')
-rw-r--r--audio/xmms-infopipe/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/audio/xmms-infopipe/Makefile b/audio/xmms-infopipe/Makefile
index 96eda33ba708..9177ff22f677 100644
--- a/audio/xmms-infopipe/Makefile
+++ b/audio/xmms-infopipe/Makefile
@@ -22,14 +22,17 @@ USE_X_PREFIX= yes
USE_GNOME= gtk12
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
LIBDIR?= ${PREFIX}/lib/xmms/General
SRCLIBDIR?= src/.libs
-INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%X11BASE%%/lib/xmms/General
PLIST_FILES= lib/xmms/General/libinfopipe.so
+post-patch:
+ @${REINPLACE_CMD} -e '/objformat=/s|=.*|=elf|' ${WRKSRC}/configure
+
do-install:
cd ${WRKSRC}/${SRCLIBDIR};\
${MKDIR} ${LIBDIR};\