aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xmms-modplug/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2006-01-08 21:08:55 +0800
committeredwin <edwin@FreeBSD.org>2006-01-08 21:08:55 +0800
commit313044bdeebf668398cf0ed33f8df3430e4aebe7 (patch)
treee5132fe4b00cc7248385c0d87ceff2314ce4223d /audio/xmms-modplug/Makefile
parentc30ce011f5b8479bbb1f6b3d98f09f31d054beec (diff)
downloadfreebsd-ports-gnome-313044bdeebf668398cf0ed33f8df3430e4aebe7.tar.gz
freebsd-ports-gnome-313044bdeebf668398cf0ed33f8df3430e4aebe7.tar.zst
freebsd-ports-gnome-313044bdeebf668398cf0ed33f8df3430e4aebe7.zip
New port: audio/xmms-modplug
This port is the ModPlug plugin for XMMS. ModPlug is arguably the best mod-like music rendering engine capable of playing 22 different module formats. This plugin can also handle zip, rar, gzip and bzip2 compressed mods (provided unzip, gunzip, unrar are installed). WWW: http://modplug-xmms.sourceforge.net/ PR: 91501 Submitted by: Andrew Pantyukhin <infofarmer@gmail.com>
Diffstat (limited to 'audio/xmms-modplug/Makefile')
-rw-r--r--audio/xmms-modplug/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/audio/xmms-modplug/Makefile b/audio/xmms-modplug/Makefile
new file mode 100644
index 000000000000..b7ba5e65ff9a
--- /dev/null
+++ b/audio/xmms-modplug/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: xmms-modplug
+# Date created: 8 January 2006
+# Whom: Andrew Pantyukhin <infofarmer@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= modplug
+PORTVERSION= 2.0.5
+CATEGORIES?= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}-${PKGNAMEPREFIX:S/-//}
+PKGNAMEPREFIX= xmms-
+DISTNAME= ${PORTNAME}${PKGNAMEPREFIX}2.05
+
+MAINTAINER= infofarmer@gmail.com
+COMMENT= A modplug-based plugin for XMMS
+
+LIB_DEPENDS?= xmms.4:${PORTSDIR}/multimedia/xmms
+LIB_DEPENDS+= modplug.0:${PORTSDIR}/audio/libmodplug
+
+USE_X_PREFIX= yes
+HAS_CONFIGURE= yes
+PLUGDIR?= lib/xmms/Input
+PLIST_FILES= ${PLUGDIR}/libmodplugxmms.so
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/modplugxmms/.libs/libmodplugxmms.so ${PREFIX}/${PLUGDIR}/
+
+.include <bsd.port.mk>