aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xmms-mp3cue/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-02-14 22:44:20 +0800
committerpav <pav@FreeBSD.org>2004-02-14 22:44:20 +0800
commit5b6cf5834b17ff4cd7e9e90f1e28105eb84297dc (patch)
tree7865d0f56cac9b8f2d401a7d636edabd332baf8c /audio/xmms-mp3cue/Makefile
parentc43dcbf760056b123f1a4fcd5cbe8f9a14629daa (diff)
downloadfreebsd-ports-gnome-5b6cf5834b17ff4cd7e9e90f1e28105eb84297dc.tar.gz
freebsd-ports-gnome-5b6cf5834b17ff4cd7e9e90f1e28105eb84297dc.tar.zst
freebsd-ports-gnome-5b6cf5834b17ff4cd7e9e90f1e28105eb84297dc.zip
Add xmms-mp3cue, a XMMS plugin that knows how to handle .cue files,
providing listener with playlist and ability to skip to given track. PR: ports/62736 Submitted by: Vaidas Zlotkus <r2@music.lt>
Diffstat (limited to 'audio/xmms-mp3cue/Makefile')
-rw-r--r--audio/xmms-mp3cue/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/audio/xmms-mp3cue/Makefile b/audio/xmms-mp3cue/Makefile
new file mode 100644
index 000000000000..9b1b74d27a06
--- /dev/null
+++ b/audio/xmms-mp3cue/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: XMMS-mp3cue
+# Date created: 12 February 2004
+# Whom: Vaidas Zlotkus <r2@music.lt>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmms-mp3cue
+PORTVERSION= 0.94
+CATEGORIES= audio
+MASTER_SITES= http://brianvictor.tripod.com/
+DISTNAME= XMMS-mp3cue-${PORTVERSION}
+
+MAINTAINER= r2@music.lt
+COMMENT= XMMS mp3cue adds cue file support to XMMS
+
+LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+
+PLIST_SUB= PORTDOCS=${DISTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/*.c
+
+.include <bsd.port.mk>