aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xmms-mp3cue
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-02-14 22:44:20 +0800
committerpav <pav@FreeBSD.org>2004-02-14 22:44:20 +0800
commit5b6cf5834b17ff4cd7e9e90f1e28105eb84297dc (patch)
tree7865d0f56cac9b8f2d401a7d636edabd332baf8c /audio/xmms-mp3cue
parentc43dcbf760056b123f1a4fcd5cbe8f9a14629daa (diff)
downloadfreebsd-ports-gnome-5b6cf5834b17ff4cd7e9e90f1e28105eb84297dc.tar.gz
freebsd-ports-gnome-5b6cf5834b17ff4cd7e9e90f1e28105eb84297dc.tar.zst
freebsd-ports-gnome-5b6cf5834b17ff4cd7e9e90f1e28105eb84297dc.zip
Add xmms-mp3cue, a XMMS plugin that knows how to handle .cue files,
providing listener with playlist and ability to skip to given track. PR: ports/62736 Submitted by: Vaidas Zlotkus <r2@music.lt>
Diffstat (limited to 'audio/xmms-mp3cue')
-rw-r--r--audio/xmms-mp3cue/Makefile29
-rw-r--r--audio/xmms-mp3cue/distinfo2
-rw-r--r--audio/xmms-mp3cue/pkg-descr14
-rw-r--r--audio/xmms-mp3cue/pkg-plist7
4 files changed, 52 insertions, 0 deletions
diff --git a/audio/xmms-mp3cue/Makefile b/audio/xmms-mp3cue/Makefile
new file mode 100644
index 000000000000..9b1b74d27a06
--- /dev/null
+++ b/audio/xmms-mp3cue/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: XMMS-mp3cue
+# Date created: 12 February 2004
+# Whom: Vaidas Zlotkus <r2@music.lt>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmms-mp3cue
+PORTVERSION= 0.94
+CATEGORIES= audio
+MASTER_SITES= http://brianvictor.tripod.com/
+DISTNAME= XMMS-mp3cue-${PORTVERSION}
+
+MAINTAINER= r2@music.lt
+COMMENT= XMMS mp3cue adds cue file support to XMMS
+
+LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+
+PLIST_SUB= PORTDOCS=${DISTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/*.c
+
+.include <bsd.port.mk>
diff --git a/audio/xmms-mp3cue/distinfo b/audio/xmms-mp3cue/distinfo
new file mode 100644
index 000000000000..a67d5f877d85
--- /dev/null
+++ b/audio/xmms-mp3cue/distinfo
@@ -0,0 +1,2 @@
+MD5 (XMMS-mp3cue-0.94.tar.gz) = d6f93194a60a2d9e8985e3939777c1c6
+SIZE (XMMS-mp3cue-0.94.tar.gz) = 38962
diff --git a/audio/xmms-mp3cue/pkg-descr b/audio/xmms-mp3cue/pkg-descr
new file mode 100644
index 000000000000..6283c5756da1
--- /dev/null
+++ b/audio/xmms-mp3cue/pkg-descr
@@ -0,0 +1,14 @@
+XMMS mp3cue adds cue file support to XMMS. Cue files store
+information (Artist, Title, Time) describing smaller tracks
+within a large audio file. mp3cue allows you to easily manipulate
+these cue files; and more importantly, it presents you with a
+separate playlist composed from the cue information which you can
+use to easily navigate to any of the smaller tracks in the audio
+file, just like a normal playlist. You can also save this cue
+information within an ID3v2 tag (if the audio file is an mp3),
+eliminating the need for an external cue file.
+
+WWW: http://brianvictor.tripod.com/
+
+- muanton
+r2@music.lt
diff --git a/audio/xmms-mp3cue/pkg-plist b/audio/xmms-mp3cue/pkg-plist
new file mode 100644
index 000000000000..c3d5a9b19132
--- /dev/null
+++ b/audio/xmms-mp3cue/pkg-plist
@@ -0,0 +1,7 @@
+share/doc/%%PORTDOCS%%/INSTALL
+share/doc/%%PORTDOCS%%/TODO
+share/doc/%%PORTDOCS%%/COPYING
+share/doc/%%PORTDOCS%%/Changelog
+share/doc/%%PORTDOCS%%/README
+@dirrm share/doc/%%PORTDOCS%%
+lib/xmms/General/libmp3cue.so