aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xmms-pipe/Makefile
diff options
context:
space:
mode:
authoralane <alane@FreeBSD.org>2002-08-26 18:30:10 +0800
committeralane <alane@FreeBSD.org>2002-08-26 18:30:10 +0800
commitb4359dd0d35e99bad984918ddb690ea3e72a9dad (patch)
treee684929a43d309a0805a335ae8e4fa7d1813a95e /audio/xmms-pipe/Makefile
parentab5dde136f95749c8eac15a41fa49b20e7ac207e (diff)
downloadfreebsd-ports-gnome-b4359dd0d35e99bad984918ddb690ea3e72a9dad.tar.gz
freebsd-ports-gnome-b4359dd0d35e99bad984918ddb690ea3e72a9dad.tar.zst
freebsd-ports-gnome-b4359dd0d35e99bad984918ddb690ea3e72a9dad.zip
Moved xmms-pipe to audio from misc, since all other xmms-related ports live
in audio. Reviewed by: Trevor Johnson <trevor@jpj.net>
Diffstat (limited to 'audio/xmms-pipe/Makefile')
-rw-r--r--audio/xmms-pipe/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/audio/xmms-pipe/Makefile b/audio/xmms-pipe/Makefile
new file mode 100644
index 000000000000..97738f832339
--- /dev/null
+++ b/audio/xmms-pipe/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: xmms-pipe
+# Date created: 23 Aug 2002
+# Whom: David Yeske <dyeske@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmms-pipe
+PORTVERSION= 0.4.5
+CATEGORIES= audio
+MASTER_SITES= http://rooster.stanford.edu/~ben/xmmspipe/
+DISTNAME= xmmspipe-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dyeske@yahoo.com
+
+BUILD_DEPENDS= xmms-config:${PORTSDIR}/audio/xmms
+RUN_DEPENDS= xmms:${PORTSDIR}/audio/xmms
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+DOC_FILES= HISTORY README LICENSE
+
+post-patch:
+ @${REINPLACE_CMD} -E -e 's|gcc|${CC}|; \
+ s|^(COPT=).+$$|\1${CFLAGS} ${PTHREAD_CFLAGS} ${PTHREAD_LIBS}|' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/xmmspipe.so \
+ ${PREFIX}/lib/xmms/Effect/
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>