aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xmms-sapplug
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2012-09-08 23:56:49 +0800
committerehaupt <ehaupt@FreeBSD.org>2012-09-08 23:56:49 +0800
commita45a74b2ef0b9b3c03524d98b0a3104d679a50a1 (patch)
tree4157f6a26329af3f86fca3b0db32342b0c7ace5d /audio/xmms-sapplug
parenta670172b131a7659c28d743026522f7c197d3773 (diff)
downloadfreebsd-ports-gnome-a45a74b2ef0b9b3c03524d98b0a3104d679a50a1.tar.gz
freebsd-ports-gnome-a45a74b2ef0b9b3c03524d98b0a3104d679a50a1.tar.zst
freebsd-ports-gnome-a45a74b2ef0b9b3c03524d98b0a3104d679a50a1.zip
- Use OPTIONSng
- Remove deprecated header information
Diffstat (limited to 'audio/xmms-sapplug')
-rw-r--r--audio/xmms-sapplug/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/audio/xmms-sapplug/Makefile b/audio/xmms-sapplug/Makefile
index 373d47331ae4..595e404b50c3 100644
--- a/audio/xmms-sapplug/Makefile
+++ b/audio/xmms-sapplug/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: xmms-sapplug
-# Date created: 14 Jul 2005
-# Whom: Emanuel Haupt <ehaupt@critical.ch>
-#
# $FreeBSD$
-#
PORTNAME= xmms-sapplug
DISTVERSION= 0.3f
@@ -29,20 +24,21 @@ WRKSRC= ${WRKDIR}/sapplug-${DISTVERSION}
PLIST_FILES= lib/xmms/Input/libsap.so
-OPTIONS= OPTIMIZED_CXXFLAGS "use optimized C++ flags" on \
- OPTIMIZED_CFLAGS "use optimized C flags" on
+OPTIONS_DEFINE= OPTIMIZED_CFLAGS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${CXX:T} != "clang++"
CXXFLAGS+= --no-exceptions
.endif
-.if defined(WITH_OPTIMIZED_CXXFLAGS)
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+CFLAGS+= -fpic -DPIC
+.endif
+
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
CXXFLAGS+= -fPIC -fpic -funroll-all-loops -fno-strength-reduce \
-finline-functions -fomit-frame-pointer
-.endif
-.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -fPIC -fpic -funroll-all-loops -fomit-frame-pointer \
-fno-strength-reduce
.endif
@@ -59,4 +55,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>