aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xmms-sexypsf/Makefile
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2013-11-13 00:07:24 +0800
committerehaupt <ehaupt@FreeBSD.org>2013-11-13 00:07:24 +0800
commit5396c0677cf94c997bf697ce8769d2db0440e811 (patch)
tree542a79bb99b581e5f8c5350257a5895918250e13 /audio/xmms-sexypsf/Makefile
parentec779c3a54c428cfee1b814987831444ce6011c2 (diff)
downloadfreebsd-ports-gnome-5396c0677cf94c997bf697ce8769d2db0440e811.tar.gz
freebsd-ports-gnome-5396c0677cf94c997bf697ce8769d2db0440e811.tar.zst
freebsd-ports-gnome-5396c0677cf94c997bf697ce8769d2db0440e811.zip
Support staging.
Diffstat (limited to 'audio/xmms-sexypsf/Makefile')
-rw-r--r--audio/xmms-sexypsf/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/audio/xmms-sexypsf/Makefile b/audio/xmms-sexypsf/Makefile
index 574607399dfa..caba06928272 100644
--- a/audio/xmms-sexypsf/Makefile
+++ b/audio/xmms-sexypsf/Makefile
@@ -16,7 +16,6 @@ BUILD_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_BZIP2= yes
-NO_STAGE= yes
USE_GNOME= gtk12
USE_LDCONFIG= yes
@@ -42,16 +41,15 @@ do-build:
-o ${WRKSRC}/libsexypsf.so -shared -lz
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/libsexypsf.so ${PREFIX}/lib/xmms/Input/libsexypsf.so
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/xmms/Input
+ ${INSTALL_PROGRAM} ${WRKSRC}/libsexypsf.so \
+ ${STAGEDIR}${PREFIX}/lib/xmms/Input/libsexypsf.so
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/Docs/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Docs/${f} ${STAGEDIR}${DOCSDIR}
.endfor
.endif
-post-install:
- @${CAT} pkg-message
-
.include <bsd.port.mk>