aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xmms-sndfile
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2008-01-10 07:50:31 +0800
committerbeech <beech@FreeBSD.org>2008-01-10 07:50:31 +0800
commit8fe13a22bda7a22bc157fac6539852db4642505e (patch)
treebc3b225c9f8b5a8a9a2daadb1f145b13ff28b0c5 /audio/xmms-sndfile
parent8e83b4f8ad77d0a9356b82ec6c5075d68b1fd8b6 (diff)
downloadfreebsd-ports-gnome-8fe13a22bda7a22bc157fac6539852db4642505e.tar.gz
freebsd-ports-gnome-8fe13a22bda7a22bc157fac6539852db4642505e.tar.zst
freebsd-ports-gnome-8fe13a22bda7a22bc157fac6539852db4642505e.zip
- Unbreak on 7.x up
- Bump portrevision. Submitted by: David Yeske <dyeske@gmail.com> (maintainer) Approved by: linimon (mentor)
Diffstat (limited to 'audio/xmms-sndfile')
-rw-r--r--audio/xmms-sndfile/Makefile22
-rw-r--r--audio/xmms-sndfile/files/patch-ltmain.sh25
2 files changed, 11 insertions, 36 deletions
diff --git a/audio/xmms-sndfile/Makefile b/audio/xmms-sndfile/Makefile
index c186c43d2498..a01624901c6c 100644
--- a/audio/xmms-sndfile/Makefile
+++ b/audio/xmms-sndfile/Makefile
@@ -5,11 +5,12 @@
# $FreeBSD$
#
-PORTNAME= xmms-sndfile
+PORTNAME= xmms
PORTVERSION= 1.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= http://www.mega-nerd.com/xmms_sndfile/
+PKGNAMESUFFIX= -sndfile
DISTNAME= xmms_sndfile-${PORTVERSION}
MAINTAINER= dyeske@gmail.com
@@ -20,15 +21,14 @@ LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile \
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
-PLIST_FILES= lib/xmms/Input/libxmms_sndfile.so
+PLIST_FILES= lib/xmms/Input/libxmms_sndfile.so \
+ lib/xmms/Input/libxmms_sndfile.a \
+ lib/xmms/Input/libxmms_sndfile.la
+
USE_GNOME= gtk12
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
-USE_X_PREFIX= yes
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700029
-BROKEN= Incorrect pkg-plist (broken objformat handling)
-.endif
+USE_XORG= x11 xext xmu xi
+USE_LDCONFIG= yes
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/xmms-sndfile/files/patch-ltmain.sh b/audio/xmms-sndfile/files/patch-ltmain.sh
deleted file mode 100644
index 2ac052749556..000000000000
--- a/audio/xmms-sndfile/files/patch-ltmain.sh
+++ /dev/null
@@ -1,25 +0,0 @@
---- ltmain.sh 2001/08/27 09:51:26 1.1
-+++ ltmain.sh 2001/08/27 09:51:42
-@@ -2408,6 +2408,9 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test "$build_libtool_need_lc" = "yes"; then
-@@ -4175,10 +4178,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"