aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xmms-wma/Makefile
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2005-10-21 22:49:00 +0800
committernovel <novel@FreeBSD.org>2005-10-21 22:49:00 +0800
commitfa2fd6be23b26d94359bae22744ddc3ef80d63a6 (patch)
tree57171bcb96c1f4dbe753a2f6ea01458910c3e4e7 /audio/xmms-wma/Makefile
parent358eda163a08f1c76d1e19f1c6cf6ea6dc8098e3 (diff)
downloadfreebsd-ports-gnome-fa2fd6be23b26d94359bae22744ddc3ef80d63a6.tar.gz
freebsd-ports-gnome-fa2fd6be23b26d94359bae22744ddc3ef80d63a6.tar.zst
freebsd-ports-gnome-fa2fd6be23b26d94359bae22744ddc3ef80d63a6.zip
An attempt to fix build on 64 bit arches.
Submitted by: Vladimir Kushnir <vkushnir@i.kiev.ua>
Diffstat (limited to 'audio/xmms-wma/Makefile')
-rw-r--r--audio/xmms-wma/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/audio/xmms-wma/Makefile b/audio/xmms-wma/Makefile
index 42244cd213fe..8f294663f8ff 100644
--- a/audio/xmms-wma/Makefile
+++ b/audio/xmms-wma/Makefile
@@ -20,8 +20,9 @@ USE_REINPLACE= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
+CFLAGS+= -fpic -DPIC
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 amd64
PLIST_FILES= lib/xmms/Input/libwma.so
@@ -40,5 +41,6 @@ pre-everything::
post-extract:
@${REINPLACE_CMD} -e 's|gcc|${CC}|g' ${WRKSRC}/Makefile.inc
@${REINPLACE_CMD} -e 's|gcc|${CC}|g' ${WRKSRC}/ffmpeg-strip-wma/config.mak
+ @${REINPLACE_CMD} -e 's|CFLAGS :=|CFLAGS := ${CFLAGS}|g' ${WRKSRC}/Makefile.inc
.include <bsd.port.mk>