aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xmms-wma
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2004-07-14 19:08:29 +0800
committervs <vs@FreeBSD.org>2004-07-14 19:08:29 +0800
commit5f912555e474020ad7091bf3fcd0f4384e43b5ae (patch)
tree92343635386c7b8fa8bd6059defa52d5f0abd581 /audio/xmms-wma
parent66df87f889f07188e84ecd6f677867b8847026ed (diff)
downloadfreebsd-ports-gnome-5f912555e474020ad7091bf3fcd0f4384e43b5ae.tar.gz
freebsd-ports-gnome-5f912555e474020ad7091bf3fcd0f4384e43b5ae.tar.zst
freebsd-ports-gnome-5f912555e474020ad7091bf3fcd0f4384e43b5ae.zip
Respect CC
PR: ports/69044 Submitted by: Roman Bogorodskiy (maintainer) Requested by: me
Diffstat (limited to 'audio/xmms-wma')
-rw-r--r--audio/xmms-wma/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/audio/xmms-wma/Makefile b/audio/xmms-wma/Makefile
index 1ee44708bf86..63a3f19089f3 100644
--- a/audio/xmms-wma/Makefile
+++ b/audio/xmms-wma/Makefile
@@ -16,6 +16,7 @@ COMMENT= WMA plugin for xmms
LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms
+USE_REINPLACE= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
@@ -24,4 +25,8 @@ ONLY_FOR_ARCHS= i386
PLIST_FILES= lib/xmms/Input/libwma.so
+post-extract:
+ @${REINPLACE_CMD} -e 's|gcc|${CC}|g' ${WRKSRC}/Makefile.inc
+ @${REINPLACE_CMD} -e 's|gcc|${CC}|g' ${WRKSRC}/ffmpeg-strip-wma/config.mak
+
.include <bsd.port.mk>