aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xmms/Makefile
diff options
context:
space:
mode:
authorcpiazza <cpiazza@FreeBSD.org>1999-07-04 03:37:30 +0800
committercpiazza <cpiazza@FreeBSD.org>1999-07-04 03:37:30 +0800
commit9e6a5693ea394d8c0ab43486f0b7356134fc0811 (patch)
treee3de02f4486411878daa837aa0ec710a20ccc90f /audio/xmms/Makefile
parent14fa1ed80fdf7496706460b734fdb6b7a09c51c4 (diff)
downloadfreebsd-ports-gnome-9e6a5693ea394d8c0ab43486f0b7356134fc0811.tar.gz
freebsd-ports-gnome-9e6a5693ea394d8c0ab43486f0b7356134fc0811.tar.zst
freebsd-ports-gnome-9e6a5693ea394d8c0ab43486f0b7356134fc0811.zip
Xmms: the X Multimedia System. XMMS is a multimedia player based on
the look of Winamp. Note: this port can be extended to include libmikmod support etc, but this is a good start and at least it plays mp3s. PR: 12498 Submitted by: Espen Skoglund <espensk@stud.cs.uit.no>
Diffstat (limited to 'audio/xmms/Makefile')
-rw-r--r--audio/xmms/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/audio/xmms/Makefile b/audio/xmms/Makefile
new file mode 100644
index 000000000000..e13e5e155a8e
--- /dev/null
+++ b/audio/xmms/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: xmms
+# Version required: 0.9.1
+# Date created: 3 July 1999
+# Whom: Espen Skoglund <espensk@stud.cs.uit.no>
+#
+# $Id:$
+#
+
+DISTNAME= xmms-0.9.1
+CATEGORIES= audio
+MASTER_SITES= ftp://ftp.xmms.org/xmms/0.9/
+
+MAINTAINER= espensk@stud.cs.uit.no
+
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
+ glib12.2:${PORTSDIR}/devel/glib12
+
+USE_LIBTOOL= yes
+CONFIGURE_ENV= GTK_CONFIG=${X11BASE}/bin/gtk12-config \
+ GLIB_CONFIG=${LOCALBASE}/bin/glib12-config
+
+.include <bsd.port.mk>