aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xmms2-scrobbler/Makefile
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2006-08-28 00:25:00 +0800
committernovel <novel@FreeBSD.org>2006-08-28 00:25:00 +0800
commitba51fac6df8c5c915298faf450fe9d5e8148114c (patch)
tree7db4049f2a7dde3c2daca73f2af72cc09edade25 /audio/xmms2-scrobbler/Makefile
parent1ebf0125574ecf2e6a937deb074cd170199c2d2f (diff)
downloadfreebsd-ports-gnome-ba51fac6df8c5c915298faf450fe9d5e8148114c.tar.gz
freebsd-ports-gnome-ba51fac6df8c5c915298faf450fe9d5e8148114c.tar.zst
freebsd-ports-gnome-ba51fac6df8c5c915298faf450fe9d5e8148114c.zip
XMMS2-Scrobbler is a client for XMMS2 that feeds information about the songs
you played to last.fm, formerly known as AudioScrobbler. WWW: http://code-monkey.de/pages/xmms2-scrobbler PR: ports/102511 Submitted by: Alexander Botero-Lowry <alex at foxybanana.com>
Diffstat (limited to 'audio/xmms2-scrobbler/Makefile')
-rw-r--r--audio/xmms2-scrobbler/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/audio/xmms2-scrobbler/Makefile b/audio/xmms2-scrobbler/Makefile
new file mode 100644
index 000000000000..f8076f894692
--- /dev/null
+++ b/audio/xmms2-scrobbler/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: snett
+# Date created: 06 Apr 2006
+# Whom: Alexander Botero-Lowry <alex@foxybanana.com>
+#
+# $FreeBSD$
+
+PORTNAME= xmms2-scrobbler
+PORTVERSION= 0.1.1
+CATEGORIES= audio ruby
+MASTER_SITES= ftp://ftp.code-monkey.de/pub/xmms2-scrobbler/
+
+MAINTAINER= alex@foxybanana.com
+COMMENT= A last.fm submission client for XMMS2
+
+BUILD_DEPENDS= ${RUBY_SITEARCHLIBDIR}/xmmsclient.so:${PORTSDIR}/audio/ruby-xmms2 \
+ ${LOCALBASE}/lib/ruby/gems/${RUBY_VER}/gems/event-loop-0.2/gemspec.rb:${PORTSDIR}/devel/rubygem-event-loop \
+ ${LOCALBASE}/bin/rake:${PORTSDIR}/devel/rubygem-rake
+RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/xmmsclient.so:${PORTSDIR}/audio/ruby-xmms2 \
+ ${LOCALBASE}/lib/ruby/gems/${RUBY_VER}/gems/event-loop-0.2/gemspec.rb:${PORTSDIR}/devel/rubygem-event-loop
+
+USE_RUBY= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/xmms2-scrobbler
+
+SUB_FILES= pkg-message
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile on FreeBSD 4.x
+.endif
+
+do-install:
+ @cd ${WRKSRC} && ${LOCALBASE}/bin/rake PREFIX=${PREFIX}/ ${INSTALL_TARGET}
+
+post-install:
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+.include <bsd.port.post.mk>