aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xmms2/Makefile
diff options
context:
space:
mode:
authoralexbl <alexbl@FreeBSD.org>2006-12-03 12:10:25 +0800
committeralexbl <alexbl@FreeBSD.org>2006-12-03 12:10:25 +0800
commitebf03a51a395a28d2dca49e077d6e5e5f5655ad9 (patch)
treef460801c7411b52bb7b4e8238e02e865f5dd604e /audio/xmms2/Makefile
parent25a3ee654cb2d60fd23fc26deb88a8e1470ae49f (diff)
downloadfreebsd-ports-gnome-ebf03a51a395a28d2dca49e077d6e5e5f5655ad9.tar.gz
freebsd-ports-gnome-ebf03a51a395a28d2dca49e077d6e5e5f5655ad9.tar.zst
freebsd-ports-gnome-ebf03a51a395a28d2dca49e077d6e5e5f5655ad9.zip
- update to 0.2DrHouse
- Complete changes for DrHouse available at: http://wiki.xmms2.xmms.se/index.php/Release:DrHouse
Diffstat (limited to 'audio/xmms2/Makefile')
-rw-r--r--audio/xmms2/Makefile38
1 files changed, 33 insertions, 5 deletions
diff --git a/audio/xmms2/Makefile b/audio/xmms2/Makefile
index 4c2364bfe0a7..ff2f3e5dad12 100644
--- a/audio/xmms2/Makefile
+++ b/audio/xmms2/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME?= xmms2
-PORTVERSION= 0.2.d.7
+PORTVERSION= 0.2.d.8
+DISTVERSION= 0.2DrHouse
CATEGORIES?= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTVERSION= 0.2DrGonzo
DISTNAME= ${PORTNAME}-${DISTVERSION}
MAINTAINER= alexbl@FreeBSD.org
@@ -33,8 +33,7 @@ USE_LDCONFIG= yes
.endif
.if !defined(XMMS2_SLAVE)
-MAN1= xmms2.1 xmms2-et.1
-MAN8= xmms2d.8 xmms2-launcher.8 xmms2-mdns-avahi.8
+MAN1= xmms2.1 xmms2-et.1 xmms2d.1 xmms2-launcher.1 xmms2-mdns-avahi.1
MANCOMPRESSED= yes
OPTIONS= FAAD "Support to playback AAC files" on \
@@ -45,6 +44,7 @@ OPTIONS= FAAD "Support to playback AAC files" on \
WMA "Support to playback WMA files" off \
APE "Support to playback Monkey's Audio files" off \
CURL "Support to playback files via HTTP" on \
+ LASTFM "Support to playback audio via Last.fm radio" on \
GNOMEVFS "Support to playback files via GnomeVFS" off \
MMS "Support to playback streams via MMS" off \
SAMBA "Support to playback files via SMB" off \
@@ -53,7 +53,9 @@ OPTIONS= FAAD "Support to playback AAC files" on \
MDNS_AVAHI "Support to announce XMMS2d via mDNS (Avahi)" off \
MDNS_APPLE "Support to announce XMMS2d via mDNS (Apple)" on \
ICES "Support to playback files to an icecast server" off \
- JACK "Support to output via the Jack output server" off #\
+ JACK "Support to output via the Jack output server" off \
+ AO "Support to output via libao" off \
+ VOCODER "Phase Vocoder effect plugin" off #\
# SDL "Support for visualization" on
.endif
@@ -82,6 +84,16 @@ EXCLUDE+= curl
PLIST_SUB+= CURL="@comment "
.endif
+.if !defined(WITHOUT_LASTFM)
+.if defined(WITHOUT_CURL)
+LIB_DEPENDS+= curl.3:${PORTSDIR}/ftp/curl
+.endif
+PLIST_SUB+= LASTFM=""
+.else
+EXCLUDE+= lastfm lastfmeta
+PLIST_SUB+= LASTMFM="@comment "
+.endif
+
.if defined(WITH_SID)
LIB_DEPENDS+= sidplay2.[0-9]:${PORTSDIR}/audio/libsidplay2
PLIST_SUB+= SID=""
@@ -208,6 +220,14 @@ EXCLUDE+= ices
PLIST_SUB+= ICES="@comment "
.endif
+.if defined(WITH_AO)
+LIB_DEPENDS+= ao.3:${PORTSDIR}/audio/libao
+PLIST_SUB+= AO=""
+.else
+EXCLUDE+= ao
+PLIST_SUB+= AO="@comment "
+.endif
+
.if defined(WITH_MDNS_AVAHI)
LIB_DEPENDS+= avahi-core:${PORTSDIR}/net/avahi
PLIST_SUB+= MDNS_AVAHI=""
@@ -225,6 +245,14 @@ PLIST_SUB+= MDNS_APPLE="@comment "
.endif
.endif
+.if defined(WITH_VOCODER)
+LIB_DEPENDS+= fftw3f.4:${PORTSDIR}/math/fftw3-float
+PLIST_SUB+= VOCODER=""
+.else
+EXCLUDE+= vocoder
+PLIST_SUB+= VOCODER="@comment "
+.endif
+
.if defined(XMMS2_SLAVE) && ${XMMS2_SLAVE} != "java"
.if ${OSVERSION} < 500000
IGNORE= broken on FreeBSD 4.x