aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xmp/files
diff options
context:
space:
mode:
authorcpiazza <cpiazza@FreeBSD.org>1999-09-19 04:46:21 +0800
committercpiazza <cpiazza@FreeBSD.org>1999-09-19 04:46:21 +0800
commit3ac15f1d28dbd9d2049acccf6aa27c83a26112ba (patch)
tree241b7e8309cc33fcc9263ca76dc850ba96137ced /audio/xmp/files
parentde187397942afb9bc4161f7014f1038e8b9c1e9f (diff)
downloadfreebsd-ports-gnome-3ac15f1d28dbd9d2049acccf6aa27c83a26112ba.tar.gz
freebsd-ports-gnome-3ac15f1d28dbd9d2049acccf6aa27c83a26112ba.tar.zst
freebsd-ports-gnome-3ac15f1d28dbd9d2049acccf6aa27c83a26112ba.zip
Import of xmp.
Xmp is the "eXtended Module Player". It supports many of the Amiga and PC module formats -- currently 47 of them and runs with little system load. PR: 13805 Submitted by: Anders Nordby <anders@fix.no>
Diffstat (limited to 'audio/xmp/files')
-rw-r--r--audio/xmp/files/patch-aa20
-rw-r--r--audio/xmp/files/patch-ab19
-rw-r--r--audio/xmp/files/patch-ac21
3 files changed, 60 insertions, 0 deletions
diff --git a/audio/xmp/files/patch-aa b/audio/xmp/files/patch-aa
new file mode 100644
index 000000000000..dec5f80919be
--- /dev/null
+++ b/audio/xmp/files/patch-aa
@@ -0,0 +1,20 @@
+--- src/player/readrc.c.orig Sat Jul 3 17:13:04 1999
++++ src/player/readrc.c Sat Sep 18 13:11:48 1999
+@@ -49,7 +49,7 @@
+
+ if ((rc = fopen (myrc2, "r")) == NULL) {
+ if ((rc = fopen (myrc, "r")) == NULL) {
+- if ((rc = fopen ("/etc/xmp.conf", "r")) == NULL) {
++ if ((rc = fopen ("/usr/local/etc/xmp.conf", "r")) == NULL) {
+ free (myrc);
+ return -1;
+ }
+@@ -191,7 +191,7 @@
+
+ myrc = malloc ((home ? strlen (home) : 0) + 20);
+ sprintf (myrc, "%s/.xmp/modules.conf", home);
+- parse_modconf (ctl, "/etc/xmp-modules.conf", crc, size);
++ parse_modconf (ctl, "/usr/local/etc/xmp-modules.conf", crc, size);
+ parse_modconf (ctl, myrc, crc, size);
+ free (myrc);
+ }
diff --git a/audio/xmp/files/patch-ab b/audio/xmp/files/patch-ab
new file mode 100644
index 000000000000..1b63134be24d
--- /dev/null
+++ b/audio/xmp/files/patch-ab
@@ -0,0 +1,19 @@
+*** etc/Makefile.orig Sat Sep 18 14:29:28 1999
+--- etc/Makefile Sat Sep 18 14:29:39 1999
+***************
+*** 21,27 ****
+ @if [ -f /etc/xmp-modules.conf]; then \
+ mv -f /etc/xmp-modules.conf /etc/xmp-modules.conf.old; \
+ fi
+! $(INSTALL) -m644 xmp.conf xmp-modules.conf /etc
+
+ xmp.spec: xmp.spec.in ../Makefile.rules
+ cat $@.in | sed 's/@VERSION@/$(VERSION)/g' > $@
+--- 21,27 ----
+ @if [ -f /etc/xmp-modules.conf]; then \
+ mv -f /etc/xmp-modules.conf /etc/xmp-modules.conf.old; \
+ fi
+! $(INSTALL) -m644 xmp.conf xmp-modules.conf $(PREFIX)/etc
+
+ xmp.spec: xmp.spec.in ../Makefile.rules
+ cat $@.in | sed 's/@VERSION@/$(VERSION)/g' > $@
diff --git a/audio/xmp/files/patch-ac b/audio/xmp/files/patch-ac
new file mode 100644
index 000000000000..12789321356e
--- /dev/null
+++ b/audio/xmp/files/patch-ac
@@ -0,0 +1,21 @@
+*** Makefile.orig Sat Sep 18 15:34:54 1999
+--- Makefile Sat Sep 18 15:35:29 1999
+***************
+*** 39,46 ****
+
+ install::
+ @echo
+! @echo " Installation complete. To customize, copy /etc/xmp.conf to"
+! @echo " \$$HOME/.xmp/xmp.conf and /etc/xmp-modules.conf to \$$HOME/.xmp/modules.conf"
+ @echo
+
+ uninstall:
+--- 39,46 ----
+
+ install::
+ @echo
+! @echo " Installation complete. To customize, copy ${PREFIX}/etc/xmp.conf to"
+! @echo " \$$HOME/.xmp/xmp.conf and ${PREFIX}/etc/xmp-modules.conf to \$$HOME/.xmp/modules.conf"
+ @echo
+
+ uninstall: