aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xsidplay/Makefile
diff options
context:
space:
mode:
authorcpiazza <cpiazza@FreeBSD.org>2000-06-12 03:06:58 +0800
committercpiazza <cpiazza@FreeBSD.org>2000-06-12 03:06:58 +0800
commitf3a5d468822fe7f1a26ea63c8c345529fc8992a0 (patch)
tree22b25060cea1805a6e17dd550c9dfe846096ad9f /audio/xsidplay/Makefile
parentaa4ee20670872c5f93e9c27c9d6562439eec5a61 (diff)
downloadfreebsd-ports-gnome-f3a5d468822fe7f1a26ea63c8c345529fc8992a0.tar.gz
freebsd-ports-gnome-f3a5d468822fe7f1a26ea63c8c345529fc8992a0.tar.zst
freebsd-ports-gnome-f3a5d468822fe7f1a26ea63c8c345529fc8992a0.zip
Add xsidplay.
A graphical frontend to libsidplay. This port doesn't currently build with gcc >= 2.8.1 PR: 15147 Submitted by: Anders Nordby <anders@fix.no>
Diffstat (limited to 'audio/xsidplay/Makefile')
-rw-r--r--audio/xsidplay/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/audio/xsidplay/Makefile b/audio/xsidplay/Makefile
new file mode 100644
index 000000000000..ae80e585bcf0
--- /dev/null
+++ b/audio/xsidplay/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: xsidplay
+# Date created: 28 November 1999
+# Whom: Anders Nordby <anders@fix.no>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xsidplay
+PORTVERSION= 1.3.8
+CATEGORIES= audio emulators
+MASTER_SITES= http://www.geocities.com/SiliconValley/Lakes/5147/sidplay/packages/ \
+ http://www.freenix.no/~anders/
+DISTNAME= ${PORTNAME}-1_3_8
+EXTRACT_SUFX= _tar.gz
+
+MAINTAINER= anders@fix.no
+
+BUILD_DEPENDS= sidplay:${PORTSDIR}/audio/sidplay
+
+GNU_CONFIGURE= YES
+USE_GMAKE= YES
+USE_QT= YES
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include \
+ -I${LOCALBASE}/include/sidplay" \
+ LDFLAGS=-L${LOCALBASE}/lib
+
+WRKSRC= ${WRKDIR}/${PKGNAME}
+
+.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 400000
+BROKEN= "Doesn't build with gcc >= 2.8.1"
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/xsidplay ${PREFIX}/bin
+
+.include <bsd.port.post.mk>