aboutsummaryrefslogtreecommitdiffstats
path: root/audio/yell
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2013-10-02 21:43:29 +0800
committerehaupt <ehaupt@FreeBSD.org>2013-10-02 21:43:29 +0800
commitd469baaec365588aaa972e5cb69e84b59443b139 (patch)
treed73079a15baefea7e57bcfbdcac2b2d1386bb694 /audio/yell
parent83af83e14743bf646fe1f8af0ba82b205646219e (diff)
downloadfreebsd-ports-gnome-d469baaec365588aaa972e5cb69e84b59443b139.tar.gz
freebsd-ports-gnome-d469baaec365588aaa972e5cb69e84b59443b139.tar.zst
freebsd-ports-gnome-d469baaec365588aaa972e5cb69e84b59443b139.zip
Use staging
Diffstat (limited to 'audio/yell')
-rw-r--r--audio/yell/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/audio/yell/Makefile b/audio/yell/Makefile
index 56975e91a975..14f77d1d6278 100644
--- a/audio/yell/Makefile
+++ b/audio/yell/Makefile
@@ -12,7 +12,6 @@ COMMENT= Command-line pc speaker bell
PLIST_FILES= bin/yell
ONLY_FOR_ARCHS= i386 amd64
-NO_STAGE= yes
OPTIONS_DEFINE= SUID
SUID_DESC= Use suid to allow execution as non root
@@ -24,9 +23,11 @@ do-build:
do-install:
.if ${PORT_OPTIONS:MSUID}
- ${INSTALL_PROGRAM} -m 4110 ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} -m 4110 ${WRKSRC}/${PORTNAME} \
+ ${STAGEDIR}/${PREFIX}/bin
.else
- ${INSTALL_PROGRAM} -m 0100 ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} -m 0100 ${WRKSRC}/${PORTNAME} \
+ ${STAGEDIR}/${PREFIX}/bin
.endif
.include <bsd.port.mk>