aboutsummaryrefslogtreecommitdiffstats
path: root/audio/zinf/Makefile
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-02-03 08:46:44 +0800
committerjbeich <jbeich@FreeBSD.org>2017-02-03 08:46:44 +0800
commit3b03b61221647ae4c5277f9d1fcc127f9964142b (patch)
tree5907ce0b16c53ec088332d363bbcab0582d8b8cb /audio/zinf/Makefile
parent915f3134e4fa91a6696513d9bf80cf1b34028b1c (diff)
downloadfreebsd-ports-gnome-3b03b61221647ae4c5277f9d1fcc127f9964142b.tar.gz
freebsd-ports-gnome-3b03b61221647ae4c5277f9d1fcc127f9964142b.tar.zst
freebsd-ports-gnome-3b03b61221647ae4c5277f9d1fcc127f9964142b.zip
audio/zinf: unbreak with libc++ 3.9
src/Http.cpp:771:11: error: cannot initialize a variable of type 'char *' with an rvalue of type 'const char *' char* cp = strstr(buffer, "Content-Length:"); ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ src/downloadmanager.cpp:401:15: error: cannot initialize a variable of type 'char *' with an rvalue of type 'const char *' char* extension = strrchr(url, '.'); ^ ~~~~~~~~~~~~~~~~~ src/downloadmanager.cpp:561:11: error: cannot initialize a variable of type 'char *' with an rvalue of type 'const char *' char* cp = strstr(buffer, "Content-Length:"); ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ src/downloadmanager.cpp:575:11: error: cannot initialize a variable of type 'char *' with an rvalue of type 'const char *' char* cp = strstr(buffer, "Last-Modified:"); ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ src/downloadmanager.cpp:799:24: error: assigning to 'char *' from incompatible type 'const char *' file = strchr(item->SourceURL().c_str() + 7, '/'); ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ src/player.cpp:552:21: error: assigning to 'char *' from incompatible type 'const char *' extension = strrchr(url.c_str(), '.'); ^~~~~~~~~~~~~~~~~~~~~~~~~ src/player.cpp:1109:17: error: assigning to 'char *' from incompatible type 'const char *' temp_proto = strstr(title, "://"); ^~~~~~~~~~~~~~~~~~~~ src/player.cpp:1129:15: error: assigning to 'char *' from incompatible type 'const char *' temp_ext = strrchr(title, '.'); ^~~~~~~~~~~~~~~~~~~ src/player.cpp:1964:14: error: cannot initialize a variable of type 'char *' with an rvalue of type 'const char *' char *port = strchr(buffer.c_str(),':'); ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~ src/playlist.cpp:1964:15: error: cannot initialize a variable of type 'char *' with an rvalue of type 'const char *' char* extension = strrchr(url, '.'); ^ ~~~~~~~~~~~~~~~~~ src/playlist.cpp:2045:15: error: cannot initialize a variable of type 'char *' with an rvalue of type 'const char *' char* extension = strrchr(url, '.'); ^ ~~~~~~~~~~~~~~~~~ src/ThemeZip.cpp:150:15: error: assigning to 'char *' from incompatible type 'const char *' pPtr = strrchr(oFile.c_str(), DIR_MARKER); ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ src/wavoutpmo.cpp:127:10: error: cannot initialize a variable of type 'char *' with an rvalue of type 'const char *' char *pPtr = strrchr(GetUrl().c_str(), DIR_MARKER); ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ src/ZinfTheme.cpp:1768:26: error: assigning to 'char *' from incompatible type 'const char *' pExtension = strrchr((*i).c_str(), '.'); ^~~~~~~~~~~~~~~~~~~~~~~~~~ pPtr = strrchr(m_oPath.c_str(), '/'); ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~ unix/src/cdpmo.cpp:116:10: error: cannot initialize a variable of type 'char *' with an rvalue of type 'const char *' char *tracknumber = strrchr(url, '/'); ^ ~~~~~~~~~~~~~~~~~ unix/src/GTKPreferenceWindow.cpp:1755:20: error: cannot initialize a variable of type 'char *' with an rvalue of type 'const char *' char *name = strrchr((*i).second.c_str(), '/'); ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ unix/src/gtkmusicbrowser.cpp:1206:11: error: cannot initialize a variable of type 'char *' with an rvalue of type 'const char *' char *ext = strrchr(m_currentListName.c_str(), '.'); ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ misc.cpp:109:14: error: assigning to 'char *' from incompatible type 'const char *' cp = strrchr(url, '.'); ^~~~~~~~~~~~~~~~~ id3lib.cpp:366:11: error: cannot initialize a variable of type 'char *' with an rvalue of type 'const char *' char *ptr = strrchr(url, '.'); ^ ~~~~~~~~~~~~~~~~~ id3lib.cpp:426:11: error: assigning to 'char *' from incompatible type 'const char *' ptr = strrchr(url, '.'); ^~~~~~~~~~~~~~~~~ id3lib.cpp:488:11: error: cannot initialize a variable of type 'char *' with an rvalue of type 'const char *' char *ptr = strrchr(url.c_str(), '.'); ^ ~~~~~~~~~~~~~~~~~~~~~~~~~ vorbis.cpp:151:11: error: assigning to 'char *' from incompatible type 'const char *' ptr = strrchr(url, '.'); ^~~~~~~~~~~~~~~~~ Reported by: pkg-fallout
Diffstat (limited to 'audio/zinf/Makefile')
-rw-r--r--audio/zinf/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/audio/zinf/Makefile b/audio/zinf/Makefile
index dac7d9f7d6f7..ff6f0f60fa7f 100644
--- a/audio/zinf/Makefile
+++ b/audio/zinf/Makefile
@@ -3,7 +3,7 @@
PORTNAME= zinf
PORTVERSION= 2.2.5
-PORTREVISION= 20
+PORTREVISION= 21
CATEGORIES= audio ipv6
MASTER_SITES= SF