aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-01-11 14:50:45 +0800
committermarcus <marcus@FreeBSD.org>2006-01-11 14:50:45 +0800
commit6bb8a7bf6e7e668828ab9c3e2671cea3fee380aa (patch)
tree374e02a3d42eac329700dc16df64f17a17baecd5 /audio
parent11260d0e11a179dbb883ec92c4d50156f5111b60 (diff)
downloadfreebsd-ports-gnome-6bb8a7bf6e7e668828ab9c3e2671cea3fee380aa.tar.gz
freebsd-ports-gnome-6bb8a7bf6e7e668828ab9c3e2671cea3fee380aa.tar.zst
freebsd-ports-gnome-6bb8a7bf6e7e668828ab9c3e2671cea3fee380aa.zip
Fix a crash when playing certain types of files. See
http://mail.gnome.org/archives/rhythmbox-devel/2005-December/msg00022.html for more details. PR: 91413 Obtained from: Rhythmbox CVS
Diffstat (limited to 'audio')
-rw-r--r--audio/rhythmbox-devel/Makefile2
-rw-r--r--audio/rhythmbox-devel/files/patch-player_rb-player-gst.c16
-rw-r--r--audio/rhythmbox/Makefile2
-rw-r--r--audio/rhythmbox/files/patch-player_rb-player-gst.c16
4 files changed, 34 insertions, 2 deletions
diff --git a/audio/rhythmbox-devel/Makefile b/audio/rhythmbox-devel/Makefile
index 2f5a4962f742..3d93e2a85bcd 100644
--- a/audio/rhythmbox-devel/Makefile
+++ b/audio/rhythmbox-devel/Makefile
@@ -8,7 +8,7 @@
PORTNAME= rhythmbox
PORTVERSION= 0.9.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.9
diff --git a/audio/rhythmbox-devel/files/patch-player_rb-player-gst.c b/audio/rhythmbox-devel/files/patch-player_rb-player-gst.c
new file mode 100644
index 000000000000..c4f14a9f81cc
--- /dev/null
+++ b/audio/rhythmbox-devel/files/patch-player_rb-player-gst.c
@@ -0,0 +1,16 @@
+===================================================================
+RCS file: /cvs/gnome/rhythmbox/player/rb-player-gst.c,v
+retrieving revision 1.51
+retrieving revision 1.52
+diff -u -r1.51 -r1.52
+--- player/rb-player-gst.c 2005/11/30 08:47:21 1.51
++++ player/rb-player-gst.c 2005/12/03 10:56:42 1.52
+@@ -782,7 +782,7 @@
+
+ if (mp->priv->playbin != NULL) {
+ GParamSpec *volume_pspec;
+- GValue val;
++ GValue val = {0,};
+
+ volume_pspec = g_object_class_find_property (G_OBJECT_GET_CLASS (mp->priv->playbin),
+ "volume");
diff --git a/audio/rhythmbox/Makefile b/audio/rhythmbox/Makefile
index 2f5a4962f742..3d93e2a85bcd 100644
--- a/audio/rhythmbox/Makefile
+++ b/audio/rhythmbox/Makefile
@@ -8,7 +8,7 @@
PORTNAME= rhythmbox
PORTVERSION= 0.9.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.9
diff --git a/audio/rhythmbox/files/patch-player_rb-player-gst.c b/audio/rhythmbox/files/patch-player_rb-player-gst.c
new file mode 100644
index 000000000000..c4f14a9f81cc
--- /dev/null
+++ b/audio/rhythmbox/files/patch-player_rb-player-gst.c
@@ -0,0 +1,16 @@
+===================================================================
+RCS file: /cvs/gnome/rhythmbox/player/rb-player-gst.c,v
+retrieving revision 1.51
+retrieving revision 1.52
+diff -u -r1.51 -r1.52
+--- player/rb-player-gst.c 2005/11/30 08:47:21 1.51
++++ player/rb-player-gst.c 2005/12/03 10:56:42 1.52
+@@ -782,7 +782,7 @@
+
+ if (mp->priv->playbin != NULL) {
+ GParamSpec *volume_pspec;
+- GValue val;
++ GValue val = {0,};
+
+ volume_pspec = g_object_class_find_property (G_OBJECT_GET_CLASS (mp->priv->playbin),
+ "volume");