aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2003-01-11 16:37:29 +0800
committerknu <knu@FreeBSD.org>2003-01-11 16:37:29 +0800
commit028b3a36bd7ae2687b6539c63d63cb5f424c8d01 (patch)
tree91d13b45bf81c2900282984c825eb8e0b69e5a13 /audio
parentdf216235ee11f6a51da77683463490ed1f3b7aa3 (diff)
downloadfreebsd-ports-gnome-028b3a36bd7ae2687b6539c63d63cb5f424c8d01.tar.gz
freebsd-ports-gnome-028b3a36bd7ae2687b6539c63d63cb5f424c8d01.tar.zst
freebsd-ports-gnome-028b3a36bd7ae2687b6539c63d63cb5f424c8d01.zip
linuxthreads' shlib major is 3 on FreeBSD 5 or later.
Diffstat (limited to 'audio')
-rw-r--r--audio/gogo/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/audio/gogo/Makefile b/audio/gogo/Makefile
index 05bf0b2e2acf..1e7ce33b34e3 100644
--- a/audio/gogo/Makefile
+++ b/audio/gogo/Makefile
@@ -27,6 +27,8 @@ ONLY_FOR_ARCHS= i386
# Recommended ONLY for benchmarks.
# CFLAGS=-march=pentiumpro -O6 -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -foptimize-register-move -ffast-math -fdefer-pop -mfancy-math-387
+.include <bsd.port.pre.mk>
+
pre-fetch:
.if !defined(WITH_THREADS)
@${ECHO_MSG} "set WITH_THREADS to compile with linuxthreads."
@@ -34,8 +36,12 @@ pre-fetch:
MAKE_ENV+= "USE_MT=no"
.else
MAKE_ENV+= "USE_MT=yes"
+.if ${OSVERSION} >= 500035
+LIB_DEPENDS= lthread.3:${PORTSDIR}/devel/linuxthreads
+.else
LIB_DEPENDS= lthread.2:${PORTSDIR}/devel/linuxthreads
.endif
+.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gogo ${PREFIX}/bin
@@ -49,4 +55,4 @@ do-install:
${PREFIX}/share/doc/gogo/cdda2mp3.gogo.ja
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>