aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-01-17 20:14:00 +0800
committeredwin <edwin@FreeBSD.org>2003-01-17 20:14:00 +0800
commit09b7d77178cef03f8f2e198e6939dce52737a097 (patch)
treea92abeb98a3e325cc547e8084a1621c997f2dc38 /audio
parent3d05e0eb035bf8a5500bc36c8c8f3c0e906430fe (diff)
downloadfreebsd-ports-gnome-09b7d77178cef03f8f2e198e6939dce52737a097.tar.gz
freebsd-ports-gnome-09b7d77178cef03f8f2e198e6939dce52737a097.tar.zst
freebsd-ports-gnome-09b7d77178cef03f8f2e198e6939dce52737a097.zip
Unbreak audio/id3lib for -current
Submitted by: "Simon 'corecode' Schubert" <corecode@corecode.ath.cx> Approved by: Roman Shterenzon <roman@xpert.com> (maintainer)
Diffstat (limited to 'audio')
-rw-r--r--audio/id3lib/Makefile20
1 files changed, 16 insertions, 4 deletions
diff --git a/audio/id3lib/Makefile b/audio/id3lib/Makefile
index a85f492e3817..5502b5487047 100644
--- a/audio/id3lib/Makefile
+++ b/audio/id3lib/Makefile
@@ -16,14 +16,26 @@ MAINTAINER= roman@xpert.com
LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
INSTALLS_SHLIB= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS}"
+
+LDFLAGS= -L${LOCALBASE}/lib
+
+.if ${CC} == cc || ${CC} == gcc
+COMPILER?= gcc
+.else
+COMPILER?= ${CC}
+.endif
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500000
-BROKEN= "Doesn't link properly, std::char_traits<wchar_t> thingie"
+RUN_DEPENDS= ${LOCALBASE}/lib/libstlport_${COMPILER}.so:${PORTSDIR}/devel/stlport${COMPILER:C/^/-/:S/-gcc//}
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+LDFLAGS+= -lstlport_${COMPILER}
+CPPFLAGS+= -I${LOCALBASE}/include/stlport
.endif
post-extract: