aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2006-08-31 20:12:05 +0800
committerehaupt <ehaupt@FreeBSD.org>2006-08-31 20:12:05 +0800
commit0a8f1f85c01730a12b2b7d29ca810c75b0172b38 (patch)
treed232a8ba6d9d48ae595d1ef87961b995f2cdea0b /audio
parente6a7d65f48f5fc64c765c05e2ff0a87d1654bf08 (diff)
downloadfreebsd-ports-gnome-0a8f1f85c01730a12b2b7d29ca810c75b0172b38.tar.gz
freebsd-ports-gnome-0a8f1f85c01730a12b2b7d29ca810c75b0172b38.tar.zst
freebsd-ports-gnome-0a8f1f85c01730a12b2b7d29ca810c75b0172b38.zip
Update to 0.3
PR: 102273 Submitted by: Ed Schouten <ed@fxq.nl> (maintainer)
Diffstat (limited to 'audio')
-rw-r--r--audio/herrie/Makefile35
-rw-r--r--audio/herrie/distinfo6
-rw-r--r--audio/herrie/pkg-descr3
3 files changed, 32 insertions, 12 deletions
diff --git a/audio/herrie/Makefile b/audio/herrie/Makefile
index 43fd15d84fbf..f2f787a64e62 100644
--- a/audio/herrie/Makefile
+++ b/audio/herrie/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= herrie
-PORTVERSION= 0.1
+PORTVERSION= 0.3
CATEGORIES= audio
MASTER_SITES= http://www.il.fontys.nl/~ed/projects/herrie/distfiles/ \
http://www.stack.nl/~ed/projects/herrie/distfiles/
@@ -14,19 +14,38 @@ MASTER_SITES= http://www.il.fontys.nl/~ed/projects/herrie/distfiles/ \
MAINTAINER= ed@fxq.nl
COMMENT= A small command line interface music player
-LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis \
- mad.2:${PORTSDIR}/audio/mad \
- sndfile.1:${PORTSDIR}/audio/libsndfile
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
-GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+USE_OPENSSL= yes
+USE_GNOME= glib20
+USE_GMAKE= yes
+MAKEFILE= GNUmakefile
+ALL_TARGET= herrie
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+
+OPTIONS= MAD "MAD MP3 support" on \
+ VORBIS "Ogg Vorbis support" on \
+ SNDFILE "libsndfile support" off
PLIST_FILES= bin/herrie
+MAN1= herrie.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-IGNORE= doesn't like 4.x thread libs
+.if !defined(WITHOUT_MAD)
+LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/mad
+.else
+MAKE_ENV+= NO_MP3=yes
+.endif
+.if !defined(WITHOUT_VORBIS)
+LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
+.else
+MAKE_ENV+= NO_VORBIS=yes
+.endif
+.if !defined(WITHOUT_SNDFILE)
+LIB_DEPENDS+= sndfile.1:${PORTSDIR}/audio/libsndfile
+.else
+MAKE_ENV+= NO_SNDFILE=yes
.endif
.include <bsd.port.post.mk>
diff --git a/audio/herrie/distinfo b/audio/herrie/distinfo
index 471c705869db..9af32e873f8f 100644
--- a/audio/herrie/distinfo
+++ b/audio/herrie/distinfo
@@ -1,3 +1,3 @@
-MD5 (herrie-0.1.tar.gz) = 895e18c071d41beef6b9806bfb7c97c7
-SHA256 (herrie-0.1.tar.gz) = b0858b939575155bb6b6da8160b27459099aa11d002564f40520edf106a8965e
-SIZE (herrie-0.1.tar.gz) = 128954
+MD5 (herrie-0.3.tar.gz) = b12c8552922ec9ef3dc66b4dacfc48a9
+SHA256 (herrie-0.3.tar.gz) = e95714bf136b46f3ff593e3e33c21a99d078fe0465a92fd2555a88173e4f4d69
+SIZE (herrie-0.3.tar.gz) = 37967
diff --git a/audio/herrie/pkg-descr b/audio/herrie/pkg-descr
index 5e9383e03178..f724ffb0f634 100644
--- a/audio/herrie/pkg-descr
+++ b/audio/herrie/pkg-descr
@@ -1,5 +1,6 @@
Herrie is a small command line music player. It has vim-like controls
and has some unique features, like chroot()'ing and dropping privileges.
-This makes it an ideal application for low-end jukeboxes.
+It also supports submission of songs to AudioScrobbler. This makes it an
+ideal application for low-end jukeboxes.
WWW: http://g-rave.nl/projects/herrie/