aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2007-09-08 14:21:15 +0800
committeredwin <edwin@FreeBSD.org>2007-09-08 14:21:15 +0800
commit102d7d259d1d5d42addf114434e1638c8aea5861 (patch)
tree96ac92b3782f815a74a64d12209f6a13157a41c4 /audio
parentf03aafda57809d23ed334f805b78e5c44c6b27f0 (diff)
downloadfreebsd-ports-gnome-102d7d259d1d5d42addf114434e1638c8aea5861.tar.gz
freebsd-ports-gnome-102d7d259d1d5d42addf114434e1638c8aea5861.tar.zst
freebsd-ports-gnome-102d7d259d1d5d42addf114434e1638c8aea5861.zip
New port: audio/ecamegapedal realtime audio processor
Ecamegapedal is a real-time effect processor software with a graphical user interface for controlling the effect parameters. It is meant to be used as a virtual guitar-fx or studio effect box. In addition to real-time operation, Ecamegapedal also supports reading from and writing to audio files. All audio object and effect plugin types provided by the Ecasound libraries are supported. This includes ALSA, JACK, OSS, aRts, over 20 file formats, over 30 effect types, LADSPA plugins and multi-operator effect presets. Ecamegapedal's implementation is based on Ecasound and Qt libraries. WWW: http://www.wakkanet.fi/~kaiv/ecamegapedal/ PR: ports/115460 Submitted by: dk <lazyklimm@gmail.com>
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/ecamegapedal/Makefile43
-rw-r--r--audio/ecamegapedal/distinfo3
-rw-r--r--audio/ecamegapedal/pkg-descr10
-rw-r--r--audio/ecamegapedal/pkg-plist9
5 files changed, 66 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 8c787f480a75..4b88b82b5cc2 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -117,6 +117,7 @@
SUBDIR += easytag-devel
SUBDIR += eawpats
SUBDIR += eawplus
+ SUBDIR += ecamegapedal
SUBDIR += ecasound
SUBDIR += ecawave
SUBDIR += emms
diff --git a/audio/ecamegapedal/Makefile b/audio/ecamegapedal/Makefile
new file mode 100644
index 000000000000..88da24e4c020
--- /dev/null
+++ b/audio/ecamegapedal/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: ecamegapedal
+# Date created: 13 aug 2007
+# Whom: lazyklimm <lazyklimm@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ecamegapedal
+PORTVERSION= 0.4.4
+PORTREVISION= 1
+CATEGORIES= audio
+MASTER_SITES= http://ecasound.seul.org/download/
+
+MAINTAINER= lazyklimm@gmail.com
+COMMENT= Realtime audio processor
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libecasound.a:${PORTSDIR}/audio/ecasound
+
+JACKDIR= ${LOCALBASE}/include/jack
+USE_QT_VER= 3
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+CFLAGS+= ${PTHREAD_CFLAGS:S/"//g}
+LDFLAGS+= ${PTHREAD_LIBS:S/"//g}
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib ${LDFLAGS}" \
+ CFLAGS="-I${LOCALBASE}/include ${CFLAGS}" \
+ CXXFLAGS="-I${LOCALBASE}/include ${CXXFLAGS}"
+
+MAN1= ecamegapedal.1
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_JACK)
+CONFIGURE_ARGS+= --with-jack=${JACK_DIR}
+LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
+.else
+CONFIGURE_ARGS+= --disable-jack
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/ecamegapedal/distinfo b/audio/ecamegapedal/distinfo
new file mode 100644
index 000000000000..44e9e051d80a
--- /dev/null
+++ b/audio/ecamegapedal/distinfo
@@ -0,0 +1,3 @@
+MD5 (ecamegapedal-0.4.4.tar.gz) = 35ae90b8b01e163d4ec0d6c824fbb8c6
+SHA256 (ecamegapedal-0.4.4.tar.gz) = 662ddeb1298870375e3c796a2c344d26e8bbe60ad1c4e8b7c70abc4079a7935b
+SIZE (ecamegapedal-0.4.4.tar.gz) = 254928
diff --git a/audio/ecamegapedal/pkg-descr b/audio/ecamegapedal/pkg-descr
new file mode 100644
index 000000000000..e0bc7dae1055
--- /dev/null
+++ b/audio/ecamegapedal/pkg-descr
@@ -0,0 +1,10 @@
+Ecamegapedal is a real-time effect processor software with a graphical user
+interface for controlling the effect parameters. It is meant to be used as
+a virtual guitar-fx or studio effect box. In addition to real-time operation,
+Ecamegapedal also supports reading from and writing to audio files.
+All audio object and effect plugin types provided by the Ecasound libraries
+are supported. This includes ALSA, JACK, OSS, aRts, over 20 file formats,
+over 30 effect types, LADSPA plugins and multi-operator effect presets.
+Ecamegapedal's implementation is based on Ecasound and Qt libraries.
+
+WWW: http://www.wakkanet.fi/~kaiv/ecamegapedal/
diff --git a/audio/ecamegapedal/pkg-plist b/audio/ecamegapedal/pkg-plist
new file mode 100644
index 000000000000..e0ddc1e90ea8
--- /dev/null
+++ b/audio/ecamegapedal/pkg-plist
@@ -0,0 +1,9 @@
+bin/ecamegapedal
+share/ecamegapedal/pixmaps/forward_idx.png
+share/ecamegapedal/pixmaps/rewind_idx.png
+share/ecamegapedal/pixmaps/quit_idx.png
+share/ecamegapedal/pixmaps/begin_idx.png
+share/ecamegapedal/pixmaps/start_idx.png
+share/ecamegapedal/pixmaps/stop_idx.png
+@dirrm share/ecamegapedal/pixmaps
+@dirrm share/ecamegapedal