aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-08-03 00:17:31 +0800
committermiwi <miwi@FreeBSD.org>2007-08-03 00:17:31 +0800
commit16b8eb0463d59ab0811ca1a853378542135e5bc0 (patch)
tree664a91136d7871aae15bfb0bc17faf54a29da0ec /audio
parent6010ed8bdc659d7cf08578271a53a921d2881304 (diff)
downloadfreebsd-ports-gnome-16b8eb0463d59ab0811ca1a853378542135e5bc0.tar.gz
freebsd-ports-gnome-16b8eb0463d59ab0811ca1a853378542135e5bc0.tar.zst
freebsd-ports-gnome-16b8eb0463d59ab0811ca1a853378542135e5bc0.zip
- Add ffmpeg knop
- Pass maintainership to submitter PR: 115062 Submitted by: Herbert J. Skuhra <h.skuhra@gmail.com> Approved by: maintainer
Diffstat (limited to 'audio')
-rw-r--r--audio/cmus/Makefile13
-rw-r--r--audio/cmus/pkg-plist1
2 files changed, 13 insertions, 1 deletions
diff --git a/audio/cmus/Makefile b/audio/cmus/Makefile
index d8723b350e77..303b7fda3433 100644
--- a/audio/cmus/Makefile
+++ b/audio/cmus/Makefile
@@ -7,11 +7,12 @@
PORTNAME= cmus
PORTVERSION= 2.2.0
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://onion.dynserv.net/~timo/files/ \
http://mirror.greaterscope.net/cmus/
-MAINTAINER= simon@olofsson.de
+MAINTAINER= h.skuhra@gmail.com
COMMENT= Console-based music player with really cool features
USE_BZIP2= yes
@@ -33,6 +34,7 @@ OPTIONS= FLAC "FLAC (Free Lossless Audio Codec) support" Off \
MP4 "MPEG-4 AAC support" Off \
AAC "AAC support" Off \
WAVPACK "Wavpack support" Off \
+ FFMPEG "FFMPEG support" Off \
LIBAO "Libao cross-platform audio library" Off \
ARTS "ARTS support" Off
@@ -128,6 +130,15 @@ CONFIGURE_ARGS+=CONFIG_WAVPACK=n
PLIST_SUB+= WAVPACK="@comment "
.endif
+.if defined(WITH_FFMPEG)
+LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
+CONFIGURE_ARGS+=CONFIG_FFMPEG=y
+PLIST_SUB+= FFMPEG=""
+.else
+CONFIGURE_ARGS+=CONFIG_FFMPEG=n
+PLIST_SUB+= FFMPEG="@comment "
+.endif
+
.if defined(WITH_LIBAO)
LIB_DEPENDS+= ao:${PORTSDIR}/audio/libao
CONFIGURE_ARGS+=CONFIG_AO=y
diff --git a/audio/cmus/pkg-plist b/audio/cmus/pkg-plist
index 2623c65221c9..a120c32cbb06 100644
--- a/audio/cmus/pkg-plist
+++ b/audio/cmus/pkg-plist
@@ -10,6 +10,7 @@ lib/cmus/ip/wav.so
%%MP4%%lib/cmus/ip/mp4.so
%%AAC%%lib/cmus/ip/aac.so
%%WAVPACK%%lib/cmus/ip/wavpack.so
+%%FFMPEG%%lib/cmus/ip/ffmpeg.so
lib/cmus/op/oss.so
%%AO%%lib/cmus/op/ao.so
%%ARTS%%lib/cmus/op/arts.so