aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2007-09-16 00:02:19 +0800
committermezz <mezz@FreeBSD.org>2007-09-16 00:02:19 +0800
commit19792b7ab9324f424663603d84e5f8bbb158a91e (patch)
treec73312212b817a2555f629dfd42a89e975918ac8 /audio
parentca3bf44398f1e896dd0d06f54e3a80a00bd213c0 (diff)
downloadfreebsd-ports-gnome-19792b7ab9324f424663603d84e5f8bbb158a91e.tar.gz
freebsd-ports-gnome-19792b7ab9324f424663603d84e5f8bbb158a91e.tar.zst
freebsd-ports-gnome-19792b7ab9324f424663603d84e5f8bbb158a91e.zip
- Fix the build when audio/oss is installed by force to search for
sys/soundcard.h in /usr/include first rather than oss's header. [1] - While I am here, fix the flac option. The autocheck is not need when it is enable by default and add --disable-flac to make WITHOUT_FLAC works. PR: ports/116268 [1] Reported by: Volker <heizraum@freenet.de> [1]
Diffstat (limited to 'audio')
-rw-r--r--audio/libsndfile/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/audio/libsndfile/Makefile b/audio/libsndfile/Makefile
index fce92d46f306..63c36479b71a 100644
--- a/audio/libsndfile/Makefile
+++ b/audio/libsndfile/Makefile
@@ -19,7 +19,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-justsrc \
--disable-gcc-pipe \
--disable-sqlite
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-isystem /usr/include -isystem ${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
USE_LDCONFIG= yes
@@ -29,8 +29,11 @@ OPTIONS= FLAC "Enable flac support" On
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_FLAC) || exists(${LOCALBASE}/lib/libFLAC.a)
+.if !defined(WITHOUT_FLAC)
LIB_DEPENDS+= FLAC.7:${PORTSDIR}/audio/flac
+CONFIGURE_ARGS+=--enable-flac
+.else
+CONFIGURE_ARGS+=--disable-flac
.endif
post-patch: