aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-07-14 06:28:17 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-07-14 06:28:17 +0800
commit2b25d5fdcc27c381b60dce62417a979829ad8ee8 (patch)
tree5ddcd14bc75aaede33225e1cbefab96d769fe465 /audio
parentbe36d9f89ba448aaa90f98a7eac575c73b3822cd (diff)
downloadfreebsd-ports-gnome-2b25d5fdcc27c381b60dce62417a979829ad8ee8.tar.gz
freebsd-ports-gnome-2b25d5fdcc27c381b60dce62417a979829ad8ee8.tar.zst
freebsd-ports-gnome-2b25d5fdcc27c381b60dce62417a979829ad8ee8.zip
On most systems, the default Python bsddb module is Python's module. On
FreeBSD, we build one based on the bsddb in base and make Python's a seperate port. Our default works with Exaile, but causes a bit of oddness, such as file paths inexplicably relocating. This oddness may cause further unseen consequences, so instead we will rely on databases/py-bsddb to keep in sync with expected behaviors. If users decide that potentially broken behavior is good enough for them and they do not want this extra dependency, I have left the rope on the chandelier for them. ~/.local/share/exail/music.db.db This file should really have only one db extension, and this artifact is tied to some differenence in behavior between the the two flavors of bsddb modules. PR: ports/136481 Submitted by "Joseph S. Atkinson" <jsa@wickedmachine.net> (maintainer)
Diffstat (limited to 'audio')
-rw-r--r--audio/exaile-devel/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/audio/exaile-devel/Makefile b/audio/exaile-devel/Makefile
index 2c0cf4f47a5d..1d64ae285ec6 100644
--- a/audio/exaile-devel/Makefile
+++ b/audio/exaile-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= exaile
DISTVERSION= 0.2.99.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://www.exaile.org/files/ \
http://wickedmachine.net/~jsa/FreeBSD/distfiles/
@@ -29,7 +29,8 @@ CONFLICTS= exaile-0.2.[0-9][0-8]* exaile-0.3.*
# The reality with these options is that they all will be autodetected and used
# if already installed. These just force Exaile to bring them in as well.
-OPTIONS= BAD "Install bad gstreamer plugins" On\
+OPTIONS= BAD "Install bad GStreamer plugins" On \
+ BDB "Install Python Berkley DB module" On \
CDDB "Lookup CD information within Exaile" On \
DBUS "Rely on Python D-Bus bindings" On \
HAL "Force depend on HAL" On \
@@ -41,6 +42,10 @@ OPTIONS= BAD "Install bad gstreamer plugins" On\
USE_GSTREAMER+= bad
.endif
+.if !defined(WITHOUT_BDB)
+RUN_DEPENDS+= py*-bsddb>=2.5:${PORTSDIR}/databases/py-bsddb
+.endif
+
.if !defined(WITHOUT_CDDB)
RUN_DEPENDS+= py*-cddb>=1.4:${PORTSDIR}/audio/py-cddb
.endif