aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-06-09 13:53:58 +0800
committeritetcu <itetcu@FreeBSD.org>2006-06-09 13:53:58 +0800
commit492a9253a3e8a3b0d9378e5de645a496de02b694 (patch)
tree36c0bcc81bb5ad80c10dd6816efd2a70910d6198 /audio
parent4b10ebb0944fb9ae37846fbfe87aefd862c291c3 (diff)
downloadfreebsd-ports-gnome-492a9253a3e8a3b0d9378e5de645a496de02b694.tar.gz
freebsd-ports-gnome-492a9253a3e8a3b0d9378e5de645a496de02b694.tar.zst
freebsd-ports-gnome-492a9253a3e8a3b0d9378e5de645a496de02b694.zip
Let waveplay display something on systems without sound device or wrong device
passed via -f. PR: ports/98638 Submitted by: maintainer Approved by: lawrance (mentor, implict)
Diffstat (limited to 'audio')
-rw-r--r--audio/waveplay/Makefile3
-rw-r--r--audio/waveplay/files/patch-waveplay.c24
2 files changed, 26 insertions, 1 deletions
diff --git a/audio/waveplay/Makefile b/audio/waveplay/Makefile
index 0ac660823c00..fd5102c49d7a 100644
--- a/audio/waveplay/Makefile
+++ b/audio/waveplay/Makefile
@@ -7,8 +7,9 @@
PORTNAME= waveplay
PORTVERSION= 2001.09.24
+PORTREVISION= 1
CATEGORIES= audio
-MASTER_SITES= http://sore.totto.to/~ysonoda/FreeBSD/ports/
+MASTER_SITES= http://www.sokohiki.org/~yoshi/FreeBSD/ports/
DISTNAME= waveplay-20010924
MAINTAINER= yshd@na.rim.or.jp
diff --git a/audio/waveplay/files/patch-waveplay.c b/audio/waveplay/files/patch-waveplay.c
new file mode 100644
index 000000000000..ad6188db85f6
--- /dev/null
+++ b/audio/waveplay/files/patch-waveplay.c
@@ -0,0 +1,24 @@
+*** waveplay.c~ Mon Sep 24 16:38:40 2001
+--- waveplay.c Thu Jun 8 00:22:50 2006
+***************
+*** 286,293 ****
+ int status;
+ int arg;
+
+! if ((fd = open(devname, O_WRONLY)) == -1)
+ return fd;
+
+ /* チャンネル(STEREO or MONAURAL)を設定 */
+ arg = (int)(pwf->nChannels);
+--- 286,296 ----
+ int status;
+ int arg;
+
+! if ((fd = open(devname, O_WRONLY)) == -1) {
+! fprintf(stderr, "%s - ", devname);
+! perror("openDSP");
+ return fd;
++ }
+
+ /* チャンネル(STEREO or MONAURAL)を設定 */
+ arg = (int)(pwf->nChannels);