aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2007-01-28 17:07:47 +0800
committerkris <kris@FreeBSD.org>2007-01-28 17:07:47 +0800
commit62aa7fe94673789fb863494cfaf642ffdcff0b5d (patch)
treedadff634ddd561962b249aea07d4cfb45982ed98 /audio
parent6f9d2cc492dfb48ff79f2a18bb35ea9fd095eac6 (diff)
downloadfreebsd-ports-gnome-62aa7fe94673789fb863494cfaf642ffdcff0b5d.tar.gz
freebsd-ports-gnome-62aa7fe94673789fb863494cfaf642ffdcff0b5d.tar.zst
freebsd-ports-gnome-62aa7fe94673789fb863494cfaf642ffdcff0b5d.zip
Use libtool port instead of included one to avoid objformat a.out botch
Diffstat (limited to 'audio')
-rw-r--r--audio/ccaudio/Makefile1
-rw-r--r--audio/ccaudio2/Makefile1
-rw-r--r--audio/libadplug/Makefile1
-rw-r--r--audio/libao/Makefile1
-rw-r--r--audio/libao/pkg-plist5
-rw-r--r--audio/libaudiofile/Makefile1
-rw-r--r--audio/libaudiofile/pkg-plist1
-rw-r--r--audio/libcdaudio/Makefile1
-rw-r--r--audio/libmad/Makefile1
-rw-r--r--audio/libofa/Makefile1
-rw-r--r--audio/liboggz/Makefile1
-rw-r--r--audio/libsamplerate/Makefile1
-rw-r--r--audio/mac/Makefile1
-rw-r--r--audio/mac/pkg-plist1
-rw-r--r--audio/openal/Makefile1
-rw-r--r--audio/py-taglib/Makefile1
-rw-r--r--audio/py-taglib/pkg-plist1
17 files changed, 21 insertions, 0 deletions
diff --git a/audio/ccaudio/Makefile b/audio/ccaudio/Makefile
index 6cd1c57da2a9..7d6f5b68e2bd 100644
--- a/audio/ccaudio/Makefile
+++ b/audio/ccaudio/Makefile
@@ -16,6 +16,7 @@ COMMENT= C++ class framework for manipulating audio files
LIB_DEPENDS= ccgnu2:${PORTSDIR}/devel/commoncpp
+USE_AUTOTOOLS= libtool:15
USE_GNOME= gnometarget
GNU_CONFIGURE= yes
USE_GCC= 3.4+
diff --git a/audio/ccaudio2/Makefile b/audio/ccaudio2/Makefile
index 6cd1c57da2a9..7d6f5b68e2bd 100644
--- a/audio/ccaudio2/Makefile
+++ b/audio/ccaudio2/Makefile
@@ -16,6 +16,7 @@ COMMENT= C++ class framework for manipulating audio files
LIB_DEPENDS= ccgnu2:${PORTSDIR}/devel/commoncpp
+USE_AUTOTOOLS= libtool:15
USE_GNOME= gnometarget
GNU_CONFIGURE= yes
USE_GCC= 3.4+
diff --git a/audio/libadplug/Makefile b/audio/libadplug/Makefile
index 1c2cc3432b66..d9142aca4ea5 100644
--- a/audio/libadplug/Makefile
+++ b/audio/libadplug/Makefile
@@ -17,6 +17,7 @@ COMMENT= AdLib emulator library supporting many formats
LIB_DEPENDS= binio.1:${PORTSDIR}/devel/libbinio
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GCC= 3.4+
diff --git a/audio/libao/Makefile b/audio/libao/Makefile
index 0d0f04a723a3..fb5e60c5080b 100644
--- a/audio/libao/Makefile
+++ b/audio/libao/Makefile
@@ -14,6 +14,7 @@ MASTER_SITES= http://www.xiph.org/ao/src/
MAINTAINER= naddy@FreeBSD.org
COMMENT= Portable audio output library
+USE_AUTOTOOLS= libtool:15
WANT_GNOME= yes
USE_GNOME= gnomehack pkgconfig
GNU_CONFIGURE= yes
diff --git a/audio/libao/pkg-plist b/audio/libao/pkg-plist
index 679dfc3fce13..482dd5fbc671 100644
--- a/audio/libao/pkg-plist
+++ b/audio/libao/pkg-plist
@@ -2,15 +2,20 @@
include/ao/ao.h
include/ao/os_types.h
include/ao/plugin.h
+lib/libao.a
lib/libao.la
lib/libao.so
lib/libao.so.3
+%%ARTS%%lib/ao/plugins-2/libarts.a
%%ARTS%%lib/ao/plugins-2/libarts.la
%%ARTS%%lib/ao/plugins-2/libarts.so
+lib/ao/plugins-2/liboss.a
lib/ao/plugins-2/liboss.la
lib/ao/plugins-2/liboss.so
+%%ESOUND%%lib/ao/plugins-2/libesd.a
%%ESOUND%%lib/ao/plugins-2/libesd.la
%%ESOUND%%lib/ao/plugins-2/libesd.so
+%%NAS%%lib/ao/plugins-2/libnas.a
%%NAS%%lib/ao/plugins-2/libnas.la
%%NAS%%lib/ao/plugins-2/libnas.so
libdata/pkgconfig/ao.pc
diff --git a/audio/libaudiofile/Makefile b/audio/libaudiofile/Makefile
index dc1051adcec3..d4ea974fa8cc 100644
--- a/audio/libaudiofile/Makefile
+++ b/audio/libaudiofile/Makefile
@@ -17,6 +17,7 @@ DISTNAME= audiofile-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
COMMENT= A sound library for SGI audio file
+USE_AUTOTOOLS= libtool:15
USE_GNOME= gnomehack gnometarget pkgconfig
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/audio/libaudiofile/pkg-plist b/audio/libaudiofile/pkg-plist
index 827dbdb974db..87f2dcebcb9a 100644
--- a/audio/libaudiofile/pkg-plist
+++ b/audio/libaudiofile/pkg-plist
@@ -5,6 +5,7 @@ include/af_vfs.h
include/audiofile.h
include/aupvlist.h
lib/libaudiofile.a
+lib/libaudiofile.la
lib/libaudiofile.so
lib/libaudiofile.so.0
libdata/pkgconfig/audiofile.pc
diff --git a/audio/libcdaudio/Makefile b/audio/libcdaudio/Makefile
index 4f70f183f4ff..d175f5df5622 100644
--- a/audio/libcdaudio/Makefile
+++ b/audio/libcdaudio/Makefile
@@ -15,6 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= novel@FreeBSD.org
COMMENT= A library for playing audio CDs
+USE_AUTOTOOLS= libtool:15
USE_GNOME= gnomehack gnometarget pkgconfig
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
diff --git a/audio/libmad/Makefile b/audio/libmad/Makefile
index d94ec3a3584a..3f0a9374f533 100644
--- a/audio/libmad/Makefile
+++ b/audio/libmad/Makefile
@@ -16,6 +16,7 @@ MASTER_SITE_SUBDIR= mad
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Libmad library (part of MAD project)
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
USE_GNOME= pkgconfig
USE_LDCONFIG= yes
diff --git a/audio/libofa/Makefile b/audio/libofa/Makefile
index 5543abe4a1cf..cc0fb7ff50f6 100644
--- a/audio/libofa/Makefile
+++ b/audio/libofa/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= fftw3.4:${PORTSDIR}/math/fftw3 \
expat.6:${PORTSDIR}/textproc/expat2 \
curl.4:${PORTSDIR}/ftp/curl
+USE_AUTOTOOLS= libtool:15
USE_GNOME= pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/audio/liboggz/Makefile b/audio/liboggz/Makefile
index e022ed3d7db9..273a33abb4e2 100644
--- a/audio/liboggz/Makefile
+++ b/audio/liboggz/Makefile
@@ -15,6 +15,7 @@ COMMENT= Simple Ogg API
LIB_DEPENDS= ogg.5:${PORTSDIR}/audio/libogg
+USE_AUTOTOOLS= libtool:15
USE_GNOME= pkgconfig
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/audio/libsamplerate/Makefile b/audio/libsamplerate/Makefile
index 41c77baae6b4..81274673a6c4 100644
--- a/audio/libsamplerate/Makefile
+++ b/audio/libsamplerate/Makefile
@@ -17,6 +17,7 @@ COMMENT= Secret Rabbit Code: a Sample Rate Converter for audio
LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile \
fftw3.4:${PORTSDIR}/math/fftw3
+USE_AUTOTOOLS= libtool:15
USE_GNOME= gnomehack gnometarget pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/audio/mac/Makefile b/audio/mac/Makefile
index 090ed0c29c29..04ae75f460ac 100644
--- a/audio/mac/Makefile
+++ b/audio/mac/Makefile
@@ -16,6 +16,7 @@ COMMENT= Monkey's Audio lossless codec
BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm
+USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-static
diff --git a/audio/mac/pkg-plist b/audio/mac/pkg-plist
index b3363aa02651..d937cf104581 100644
--- a/audio/mac/pkg-plist
+++ b/audio/mac/pkg-plist
@@ -20,6 +20,7 @@ include/mac/NoWindows.h
include/mac/SmartPtr.h
include/mac/StdLibFileIO.h
include/mac/config.h
+lib/libmac.a
lib/libmac.la
lib/libmac.so
lib/libmac.so.2
diff --git a/audio/openal/Makefile b/audio/openal/Makefile
index c77713687b3a..4b17c85e5d05 100644
--- a/audio/openal/Makefile
+++ b/audio/openal/Makefile
@@ -15,6 +15,7 @@ DISTVERSION= 0.0.8
MAINTAINER= erik@smluc.org
COMMENT= A 3D positional spatialized sound library
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/audio/py-taglib/Makefile b/audio/py-taglib/Makefile
index 0046ecffc649..712d151d6c7b 100644
--- a/audio/py-taglib/Makefile
+++ b/audio/py-taglib/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= tag.5:${PORTSDIR}/audio/taglib
WRKSRC= ${WRKDIR}/python-taglib-${PORTVERSION}
+USE_AUTOTOOLS= libtool:15
USE_PYTHON= yes
USE_PYTHON_PREFIX= yes
GNU_CONFIGURE= yes
diff --git a/audio/py-taglib/pkg-plist b/audio/py-taglib/pkg-plist
index f99655b3e072..aca9825884af 100644
--- a/audio/py-taglib/pkg-plist
+++ b/audio/py-taglib/pkg-plist
@@ -4,3 +4,4 @@
%%PYTHON_SITELIBDIR%%/_TagLib.so
lib/libpython_taglib.so
lib/libpython_taglib.la
+lib/libpython_taglib.a