aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-02-09 06:36:42 +0800
committermiwi <miwi@FreeBSD.org>2007-02-09 06:36:42 +0800
commit64a36b6087e4e2d5af4960f9b0989f2f0b64f5ec (patch)
tree2832834d9232f190122e8358776c29576c264f4d /audio
parent8a763157e46f247a29790b41314bc48ef5d216d2 (diff)
downloadfreebsd-ports-gnome-64a36b6087e4e2d5af4960f9b0989f2f0b64f5ec.tar.gz
freebsd-ports-gnome-64a36b6087e4e2d5af4960f9b0989f2f0b64f5ec.tar.zst
freebsd-ports-gnome-64a36b6087e4e2d5af4960f9b0989f2f0b64f5ec.zip
This suite of modules provides routines for reading, composing, modifying, and
writing MIDI files. WWW: http://search.cpan.org/dist/MIDI-Perl/ PR: ports/108876 Submitted by: Alexandr Kovalenko <never at nevermind.kiev.ua>
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/p5-MIDI/Makefile31
-rw-r--r--audio/p5-MIDI/distinfo3
-rw-r--r--audio/p5-MIDI/pkg-descr4
-rw-r--r--audio/p5-MIDI/pkg-plist10
5 files changed, 49 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index bdb9cdd6655e..68ed28393986 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -452,6 +452,7 @@
SUBDIR += p5-CDDB-File
SUBDIR += p5-CDDB_get
SUBDIR += p5-Filesys-Virtual-DAAP
+ SUBDIR += p5-MIDI
SUBDIR += p5-MP3-Find
SUBDIR += p5-MP3-ID3v1Tag
SUBDIR += p5-MP3-Info
diff --git a/audio/p5-MIDI/Makefile b/audio/p5-MIDI/Makefile
new file mode 100644
index 000000000000..f711865a711e
--- /dev/null
+++ b/audio/p5-MIDI/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-MIDI
+# Date created: February 07 2007
+# Whom: Alexandr Kovalenko <never@nevermind.kiev.ua>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MIDI
+PORTVERSION= 0.81
+CATEGORIES= audio perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= MIDI
+PKGNAMEPREFIX= p5-
+DISTNAME= MIDI-Perl-${PORTVERSION}
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl5 module for handling MIDI files
+
+PERL_CONFIGURE= YES
+
+MAN3= MIDI.3 MIDI::Event.3 MIDI::Filespec.3 MIDI::Opus.3 MIDI::Score.3 \
+ MIDI::Simple.3 MIDI::Track.3
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GD)
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/p5-MIDI/distinfo b/audio/p5-MIDI/distinfo
new file mode 100644
index 000000000000..a0477ec48f56
--- /dev/null
+++ b/audio/p5-MIDI/distinfo
@@ -0,0 +1,3 @@
+MD5 (MIDI-Perl-0.81.tar.gz) = dcda1f179bedefe3c86d994c393b55a6
+SHA256 (MIDI-Perl-0.81.tar.gz) = 43ba9594fb02f0970ab16587d960db4acfeb62df9af29cb1aa889a4ee4696dad
+SIZE (MIDI-Perl-0.81.tar.gz) = 63073
diff --git a/audio/p5-MIDI/pkg-descr b/audio/p5-MIDI/pkg-descr
new file mode 100644
index 000000000000..6bd8f943c31e
--- /dev/null
+++ b/audio/p5-MIDI/pkg-descr
@@ -0,0 +1,4 @@
+This suite of modules provides routines for reading, composing, modifying, and
+writing MIDI files.
+
+WWW: http://search.cpan.org/dist/MIDI-Perl/
diff --git a/audio/p5-MIDI/pkg-plist b/audio/p5-MIDI/pkg-plist
new file mode 100644
index 000000000000..b09cf4370b7e
--- /dev/null
+++ b/audio/p5-MIDI/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/MIDI.pm
+%%SITE_PERL%%/MIDI/Event.pm
+%%SITE_PERL%%/MIDI/Filespec.pod
+%%SITE_PERL%%/MIDI/Opus.pm
+%%SITE_PERL%%/MIDI/Score.pm
+%%SITE_PERL%%/MIDI/Simple.pm
+%%SITE_PERL%%/MIDI/Track.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MIDI-Perl/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/MIDI-Perl
+@dirrmtry %%SITE_PERL%%/MIDI