aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2010-05-11 05:19:08 +0800
committerkwm <kwm@FreeBSD.org>2010-05-11 05:19:08 +0800
commit6a2a890c5cd397f9f0287409c2aa0244d50f3573 (patch)
treefc02bcba8bfa155b5cf452d6bafe1cb06aca4848 /audio
parent0e415a93a0424a4b284c88c39b19d93d80b66c8a (diff)
downloadfreebsd-ports-gnome-6a2a890c5cd397f9f0287409c2aa0244d50f3573.tar.gz
freebsd-ports-gnome-6a2a890c5cd397f9f0287409c2aa0244d50f3573.tar.zst
freebsd-ports-gnome-6a2a890c5cd397f9f0287409c2aa0244d50f3573.zip
Presenting GNOME 2.30.1 for FreeBSD. The offical release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.30/ . This release brings initial PackageKit support, Upower (replaces power management part of hal), cuse4bsd integration with HAL and cheese, and a faster Evolution. Sadly GNOME 2.30.x will be the last release with FreeBSD 6.X support. This will also be the last of the 2.x releases. The next release will be the highly-anticipated GNOME 3.0 which will bring with it a new UI experience. Currently, there are a few bugs with GNOME 2.30 that may be of note for our users. Be sure to consult the UPGRADING note or the 2.30 upgrade FAQ at http://www.freebsd.org/gnome/docs/faq230.html for specific upgrading instructions, and the up-to-date list of known issues. This release features commits by avl, ahze, bland, marcus, mezz, and myself. The FreeBSD GNOME Team would like to thank Anders F Bjorklund for doing the initual packagekit porting. And the following contributors & testers for there help with this release: Eric L. Chen Vladimir Grebenschikov Sergio de Almeida Lenzi DomiX walder crsd Kevin Oberman Michal Varga Pavel Plesov Bapt kevin and ITetcu for two exp-run PR: ports/143852 ports/145347 ports/144980 ports/145830 ports/145511
Diffstat (limited to 'audio')
-rw-r--r--audio/beast/files/patch-birnet_birnetthreadimpl.cc17
-rw-r--r--audio/gnome-media/Makefile12
-rw-r--r--audio/gnome-media/distinfo6
-rw-r--r--audio/gnome-media/pkg-plist31
-rw-r--r--audio/istream/Makefile4
-rw-r--r--audio/libcanberra/Makefile4
-rw-r--r--audio/libcanberra/distinfo6
-rw-r--r--audio/libcanberra/files/patch-src_oss.c14
-rw-r--r--audio/rhythmbox/Makefile7
-rw-r--r--audio/rhythmbox/distinfo6
-rw-r--r--audio/rhythmbox/pkg-plist40
-rw-r--r--audio/sound-juicer/Makefile5
-rw-r--r--audio/sound-juicer/distinfo6
-rw-r--r--audio/sound-juicer/pkg-plist3
14 files changed, 112 insertions, 49 deletions
diff --git a/audio/beast/files/patch-birnet_birnetthreadimpl.cc b/audio/beast/files/patch-birnet_birnetthreadimpl.cc
new file mode 100644
index 000000000000..5e4968b1eef2
--- /dev/null
+++ b/audio/beast/files/patch-birnet_birnetthreadimpl.cc
@@ -0,0 +1,17 @@
+Description: Correct signature for the g_atomic_pointer_get() function.
+Author: Jakub Wilk <ubanus@users.sf.net>
+Bug-Debian: http://bugs.debian.org/540681
+
+Index: beast-0.7.1/birnet/birnetthreadimpl.cc
+===================================================================
+--- birnet/birnetthreadimpl.cc.orig 2009-12-16 20:21:24.000000000 +0100
++++ birnet/birnetthreadimpl.cc 2009-12-16 20:26:16.000000000 +0100
+@@ -1491,7 +1491,7 @@
+
+ #ifdef g_atomic_pointer_get
+ static void*
+-(g_atomic_pointer_get) (volatile void **atomic)
++(g_atomic_pointer_get) (void * volatile *atomic)
+ {
+ return (void*) g_atomic_pointer_get (atomic);
+ }
diff --git a/audio/gnome-media/Makefile b/audio/gnome-media/Makefile
index dc0e894f18e8..526ae780718a 100644
--- a/audio/gnome-media/Makefile
+++ b/audio/gnome-media/Makefile
@@ -3,12 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/audio/gnome-media/Makefile,v 1.147 2009/11/26 06:20:13 marcus Exp $
+# $MCom: ports/audio/gnome-media/Makefile,v 1.151 2010/04/02 01:29:55 avl Exp $
#
PORTNAME= gnome-media
-PORTVERSION= 2.28.5
-PORTREVISION= 2
+PORTVERSION= 2.30.0
CATEGORIES= audio gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -29,8 +28,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
GNOME_DESKTOP_VERSION=2
-USE_GNOME= gnomeprefix gnomehack intlhack gtk20 libxml2 libglade2 \
- gconf2
+USE_GNOME= gnomeprefix gnomehack intlhack gtk20 libxml2 gconf2
USE_GSTREAMER= gconf good
CONFIGURE_ARGS= --disable-gstmix
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -39,4 +37,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GCONF_SCHEMAS= gnome-audio-profiles.schemas \
gnome-sound-recorder.schemas
+post-patch:
+ @${REINPLACE_CMD} -e 's|have_gladeui=true|have_gladeui=false|g' \
+ ${WRKSRC}/configure
+
.include <bsd.port.mk>
diff --git a/audio/gnome-media/distinfo b/audio/gnome-media/distinfo
index a754d2d8b8ec..5a2389c24a4b 100644
--- a/audio/gnome-media/distinfo
+++ b/audio/gnome-media/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-media-2.28.5.tar.bz2) = 8dbdd10388f1557da209d8aef7b85f0d
-SHA256 (gnome2/gnome-media-2.28.5.tar.bz2) = 1d6a34b54aa01e811ac32ed7d24432b3beaffffc2c6278de412c7931f5488153
-SIZE (gnome2/gnome-media-2.28.5.tar.bz2) = 2604259
+MD5 (gnome2/gnome-media-2.30.0.tar.bz2) = 027b11fb8b126ab1b25def6b9e121bd3
+SHA256 (gnome2/gnome-media-2.30.0.tar.bz2) = 994cd9b88ff22e4815585629b14efc828a95284900809b0b4f8ebcde0c6e2926
+SIZE (gnome2/gnome-media-2.30.0.tar.bz2) = 2707711
diff --git a/audio/gnome-media/pkg-plist b/audio/gnome-media/pkg-plist
index ea15b8a6b211..dd6d9a556d36 100644
--- a/audio/gnome-media/pkg-plist
+++ b/audio/gnome-media/pkg-plist
@@ -9,9 +9,6 @@ include/gnome-media/profiles/audio-profile-edit.h
include/gnome-media/profiles/audio-profile.h
include/gnome-media/profiles/audio-profiles-edit.h
include/gnome-media/profiles/gnome-media-profiles.h
-lib/libglade/2.0/libgnome-media-profiles.a
-lib/libglade/2.0/libgnome-media-profiles.la
-lib/libglade/2.0/libgnome-media-profiles.so
lib/libgnome-media-profiles.a
lib/libgnome-media-profiles.la
lib/libgnome-media-profiles.so
@@ -20,7 +17,8 @@ libdata/pkgconfig/gnome-media-profiles.pc
share/applications/gnome-sound-recorder.desktop
share/applications/gnome-volume-control.desktop
share/applications/gstreamer-properties.desktop
-%%DATADIR%%/glade/gnome-audio-profiles.glade2
+%%DATADIR%%/gnome-audio-profile-edit.ui
+%%DATADIR%%/gnome-audio-profile-new.ui
%%DATADIR%%/icons/hicolor/16x16/status/audio-input-microphone-high.png
%%DATADIR%%/icons/hicolor/16x16/status/audio-input-microphone-low.png
%%DATADIR%%/icons/hicolor/16x16/status/audio-input-microphone-medium.png
@@ -51,10 +49,22 @@ share/gnome/help/gnome-audio-profiles/de/figures/gnome-audio-profiles-profile-wi
share/gnome/help/gnome-audio-profiles/de/figures/gnome-audio-profiles-profiles-window.png
share/gnome/help/gnome-audio-profiles/de/gnome-audio-profiles.xml
share/gnome/help/gnome-audio-profiles/de/legal.xml
+share/gnome/help/gnome-audio-profiles/el/figures/gnome-audio-profiles-profile-window.png
+share/gnome/help/gnome-audio-profiles/el/figures/gnome-audio-profiles-profiles-window.png
+share/gnome/help/gnome-audio-profiles/el/gnome-audio-profiles.xml
+share/gnome/help/gnome-audio-profiles/el/legal.xml
share/gnome/help/gnome-audio-profiles/es/figures/gnome-audio-profiles-profile-window.png
share/gnome/help/gnome-audio-profiles/es/figures/gnome-audio-profiles-profiles-window.png
share/gnome/help/gnome-audio-profiles/es/gnome-audio-profiles.xml
share/gnome/help/gnome-audio-profiles/es/legal.xml
+share/gnome/help/gnome-audio-profiles/fr/figures/gnome-audio-profiles-profile-window.png
+share/gnome/help/gnome-audio-profiles/fr/figures/gnome-audio-profiles-profiles-window.png
+share/gnome/help/gnome-audio-profiles/fr/gnome-audio-profiles.xml
+share/gnome/help/gnome-audio-profiles/fr/legal.xml
+share/gnome/help/gnome-audio-profiles/sv/figures/gnome-audio-profiles-profile-window.png
+share/gnome/help/gnome-audio-profiles/sv/figures/gnome-audio-profiles-profiles-window.png
+share/gnome/help/gnome-audio-profiles/sv/gnome-audio-profiles.xml
+share/gnome/help/gnome-audio-profiles/sv/legal.xml
share/gnome/help/gnome-sound-recorder/C/figures/grecord_window.png
share/gnome/help/gnome-sound-recorder/C/gnome-sound-recorder.xml
share/gnome/help/gnome-sound-recorder/C/legal.xml
@@ -137,6 +147,7 @@ share/icons/hicolor/48x48/apps/gnome-volume-control.png
share/icons/hicolor/48x48/apps/gstreamer-properties.png
share/icons/hicolor/scalable/apps/gnome-sound-recorder.svg
share/icons/hicolor/scalable/apps/gnome-volume-control.svg
+share/locale/af/LC_MESSAGES/gnome-media-2.0.mo
share/locale/am/LC_MESSAGES/gnome-media-2.0.mo
share/locale/ar/LC_MESSAGES/gnome-media-2.0.mo
share/locale/as/LC_MESSAGES/gnome-media-2.0.mo
@@ -224,7 +235,10 @@ share/locale/zh_HK/LC_MESSAGES/gnome-media-2.0.mo
share/locale/zh_TW/LC_MESSAGES/gnome-media-2.0.mo
share/omf/gnome-audio-profiles/gnome-audio-profiles-C.omf
share/omf/gnome-audio-profiles/gnome-audio-profiles-de.omf
+share/omf/gnome-audio-profiles/gnome-audio-profiles-el.omf
share/omf/gnome-audio-profiles/gnome-audio-profiles-es.omf
+share/omf/gnome-audio-profiles/gnome-audio-profiles-fr.omf
+share/omf/gnome-audio-profiles/gnome-audio-profiles-sv.omf
share/omf/gnome-sound-recorder/gnome-sound-recorder-C.omf
share/omf/gnome-sound-recorder/gnome-sound-recorder-ca.omf
share/omf/gnome-sound-recorder/gnome-sound-recorder-cs.omf
@@ -236,7 +250,6 @@ share/omf/gnome-sound-recorder/gnome-sound-recorder-es.omf
share/omf/gnome-sound-recorder/gnome-sound-recorder-fr.omf
share/omf/gnome-sound-recorder/gnome-sound-recorder-it.omf
share/omf/gnome-sound-recorder/gnome-sound-recorder-oc.omf
-share/omf/gstreamer-properties/gstreamer-properties-pt_BR.omf
share/omf/gnome-sound-recorder/gnome-sound-recorder-ru.omf
share/omf/gnome-sound-recorder/gnome-sound-recorder-sv.omf
share/omf/gnome-sound-recorder/gnome-sound-recorder-uk.omf
@@ -251,6 +264,7 @@ share/omf/gstreamer-properties/gstreamer-properties-es.omf
share/omf/gstreamer-properties/gstreamer-properties-fr.omf
share/omf/gstreamer-properties/gstreamer-properties-it.omf
share/omf/gstreamer-properties/gstreamer-properties-oc.omf
+share/omf/gstreamer-properties/gstreamer-properties-pt_BR.omf
share/omf/gstreamer-properties/gstreamer-properties-ru.omf
share/omf/gstreamer-properties/gstreamer-properties-sv.omf
share/omf/gstreamer-properties/gstreamer-properties-th.omf
@@ -332,8 +346,14 @@ share/sounds/gnome/default/alerts/sonar.ogg
@dirrm share/gnome/help/gnome-sound-recorder/C/figures
@dirrm share/gnome/help/gnome-sound-recorder/C
@dirrm share/gnome/help/gnome-sound-recorder
+@dirrm share/gnome/help/gnome-audio-profiles/sv/figures
+@dirrm share/gnome/help/gnome-audio-profiles/sv
+@dirrm share/gnome/help/gnome-audio-profiles/fr/figures
+@dirrm share/gnome/help/gnome-audio-profiles/fr
@dirrm share/gnome/help/gnome-audio-profiles/es/figures
@dirrm share/gnome/help/gnome-audio-profiles/es
+@dirrm share/gnome/help/gnome-audio-profiles/el/figures
+@dirrm share/gnome/help/gnome-audio-profiles/el
@dirrm share/gnome/help/gnome-audio-profiles/de/figures
@dirrm share/gnome/help/gnome-audio-profiles/de
@dirrm share/gnome/help/gnome-audio-profiles/C/figures
@@ -354,7 +374,6 @@ share/sounds/gnome/default/alerts/sonar.ogg
@dirrm %%DATADIR%%/icons/hicolor/16x16
@dirrm %%DATADIR%%/icons/hicolor
@dirrm %%DATADIR%%/icons
-@dirrm %%DATADIR%%/glade
@dirrm %%DATADIR%%
@dirrmtry share/applications
@dirrm include/gnome-media/profiles
diff --git a/audio/istream/Makefile b/audio/istream/Makefile
index 514697ff952b..df49665b4bac 100644
--- a/audio/istream/Makefile
+++ b/audio/istream/Makefile
@@ -7,7 +7,7 @@
PORTNAME= istream
PORTVERSION= 0.10
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= http://www.jochen-baier.de/istream/
@@ -15,7 +15,7 @@ MAINTAINER= pav@FreeBSD.org
COMMENT= Internet radio player applet for GNOME Panel
USE_GMAKE= yes
-USE_GNOME= gnomepanel
+USE_GNOME= gnomepanel libgnomeui
USE_GSTREAMER= yes
USE_XORG= xtst
GNU_CONFIGURE= yes
diff --git a/audio/libcanberra/Makefile b/audio/libcanberra/Makefile
index 3d0acb9477bc..d3d7fcb8c28c 100644
--- a/audio/libcanberra/Makefile
+++ b/audio/libcanberra/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= libcanberra
-PORTVERSION= 0.22
-PORTREVISION= 3
+PORTVERSION= 0.23
+PORTREVISION= 1
CATEGORIES= audio devel
MASTER_SITES= http://0pointer.de/lennart/projects/libcanberra/
diff --git a/audio/libcanberra/distinfo b/audio/libcanberra/distinfo
index f771edecc145..55a248f02acd 100644
--- a/audio/libcanberra/distinfo
+++ b/audio/libcanberra/distinfo
@@ -1,3 +1,3 @@
-MD5 (libcanberra-0.22.tar.gz) = e24e2f956fedfbcc58edfa40471b18d8
-SHA256 (libcanberra-0.22.tar.gz) = 6a87737c3d045549a4a9c789cfc565a48185a586aa1a59243dea6421e9978581
-SIZE (libcanberra-0.22.tar.gz) = 459404
+MD5 (libcanberra-0.23.tar.gz) = 83fb2fb7608c77f91904e12a867534fd
+SHA256 (libcanberra-0.23.tar.gz) = a7d0cf282a9fc8d1e41c082b72a2bf4cf86a6d599f0262484bac95bab57a0960
+SIZE (libcanberra-0.23.tar.gz) = 460205
diff --git a/audio/libcanberra/files/patch-src_oss.c b/audio/libcanberra/files/patch-src_oss.c
index d4b910a3c0a8..098792d93125 100644
--- a/audio/libcanberra/files/patch-src_oss.c
+++ b/audio/libcanberra/files/patch-src_oss.c
@@ -1,11 +1,11 @@
---- src/oss.c.orig 2009-08-26 21:58:16.000000000 -0400
-+++ src/oss.c 2009-11-25 20:47:07.000000000 -0500
-@@ -260,7 +260,7 @@ static int open_oss(ca_context *c, struc
- val = AFMT_S16_NE;
- break;
+--- src/oss.c.orig 2010-02-19 18:39:40.000000000 -0500
++++ src/oss.c 2010-03-14 15:04:16.000000000 -0400
+@@ -262,7 +262,7 @@ static int open_oss(ca_context *c, struc
+ val = AFMT_S16_NE;
+ break;
case CA_SAMPLE_S16RE:
-#if __BYTE_ORDER == __LITTLE_ENDIAN
+#if _BYTE_ORDER == _LITTLE_ENDIAN
- val = AFMT_S16_BE;
+ val = AFMT_S16_BE;
#else
- val = AFMT_S16_LE;
+ val = AFMT_S16_LE;
diff --git a/audio/rhythmbox/Makefile b/audio/rhythmbox/Makefile
index 8cbd870c106c..9ebe2a037c18 100644
--- a/audio/rhythmbox/Makefile
+++ b/audio/rhythmbox/Makefile
@@ -3,12 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/audio/rhythmbox/Makefile,v 1.103 2009/11/22 22:09:39 marcus Exp $
+# $MCom: ports/audio/rhythmbox/Makefile,v 1.107 2010/04/08 23:16:25 kwm Exp $
#
PORTNAME= rhythmbox
-PORTVERSION= 0.12.7
-PORTREVISION= 2
+PORTVERSION= 0.12.8
CATEGORIES= audio gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -20,7 +19,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev2.h:${PORTSDIR}/multimedia/v4l
LIB_DEPENDS= musicbrainz.4:${PORTSDIR}/audio/libmusicbrainz \
musicbrainz3.6:${PORTSDIR}/audio/libmusicbrainz3 \
id3tag.0:${PORTSDIR}/audio/libid3tag \
- totem-plparser.12:${PORTSDIR}/multimedia/totem-pl-parser \
+ totem-plparser.17:${PORTSDIR}/multimedia/totem-pl-parser \
dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
sexy.2:${PORTSDIR}/x11-toolkits/libsexy \
soup-2.4.1:${PORTSDIR}/devel/libsoup \
diff --git a/audio/rhythmbox/distinfo b/audio/rhythmbox/distinfo
index 15b1590d0500..b5815fc039bc 100644
--- a/audio/rhythmbox/distinfo
+++ b/audio/rhythmbox/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/rhythmbox-0.12.7.tar.bz2) = db53503383a988b1d201d1b4da6a5087
-SHA256 (gnome2/rhythmbox-0.12.7.tar.bz2) = 4ab28b93b2e9d7bc9338194ba6e01549362fdd5b0cf2806da091fbfb2c2a8362
-SIZE (gnome2/rhythmbox-0.12.7.tar.bz2) = 5224160
+MD5 (gnome2/rhythmbox-0.12.8.tar.bz2) = 3e24108119264a0cbd8b4ccbd7732173
+SHA256 (gnome2/rhythmbox-0.12.8.tar.bz2) = 1752fab135808aa78a9afde78448e992020c58c07701f43c989fbabfc6352213
+SIZE (gnome2/rhythmbox-0.12.8.tar.bz2) = 5358950
diff --git a/audio/rhythmbox/pkg-plist b/audio/rhythmbox/pkg-plist
index 0b57d1ee7c51..142d513e4910 100644
--- a/audio/rhythmbox/pkg-plist
+++ b/audio/rhythmbox/pkg-plist
@@ -12,6 +12,9 @@ lib/librhythmbox-core.so.0
%%PYTHON%%lib/rhythmbox/plugins/artdisplay/EmbeddedCoverArtSearch.py
%%PYTHON%%lib/rhythmbox/plugins/artdisplay/EmbeddedCoverArtSearch.pyc
%%PYTHON%%lib/rhythmbox/plugins/artdisplay/EmbeddedCoverArtSearch.pyo
+%%PYTHON%%lib/rhythmbox/plugins/artdisplay/LastFMCoverArtSearch.py
+%%PYTHON%%lib/rhythmbox/plugins/artdisplay/LastFMCoverArtSearch.pyc
+%%PYTHON%%lib/rhythmbox/plugins/artdisplay/LastFMCoverArtSearch.pyo
%%PYTHON%%lib/rhythmbox/plugins/artdisplay/LocalCoverArtSearch.py
%%PYTHON%%lib/rhythmbox/plugins/artdisplay/LocalCoverArtSearch.pyc
%%PYTHON%%lib/rhythmbox/plugins/artdisplay/LocalCoverArtSearch.pyo
@@ -25,6 +28,7 @@ lib/librhythmbox-core.so.0
%%PYTHON%%lib/rhythmbox/plugins/artdisplay/__init__.pyc
%%PYTHON%%lib/rhythmbox/plugins/artdisplay/__init__.pyo
%%PYTHON%%lib/rhythmbox/plugins/artdisplay/artdisplay.rb-plugin
+%%PYTHON%%lib/rhythmbox/plugins/artdisplay/lastfm_red_small.png
%%PYTHON%%lib/rhythmbox/plugins/artdisplay/rhythmbox-missing-artwork.svg
lib/rhythmbox/plugins/audiocd/album-info.ui
lib/rhythmbox/plugins/audiocd/audiocd-ui.xml
@@ -260,12 +264,15 @@ share/dbus-1/services/org.gnome.Rhythmbox.service
%%DOCSDIR%%/RBPlayerGstTee.html
%%DOCSDIR%%/RBPlaylistManager.html
%%DOCSDIR%%/RBPlaylistSource.html
+%%DOCSDIR%%/RBPlugin.html
%%DOCSDIR%%/RBPropertyView.html
%%DOCSDIR%%/RBQueryCreator.html
%%DOCSDIR%%/RBRandomPlayOrder.html
%%DOCSDIR%%/RBRating.html
%%DOCSDIR%%/RBRemovableMediaManager.html
+%%DOCSDIR%%/RBRemovableMediaSource.html
%%DOCSDIR%%/RBSearchEntry.html
+%%DOCSDIR%%/RBShell.html
%%DOCSDIR%%/RBShellClipboard.html
%%DOCSDIR%%/RBShellPlayer.html
%%DOCSDIR%%/RBShellPreferences.html
@@ -274,12 +281,17 @@ share/dbus-1/services/org.gnome.Rhythmbox.service
%%DOCSDIR%%/RBSourceHeader.html
%%DOCSDIR%%/RBSourceList.html
%%DOCSDIR%%/RBSourceListModel.html
+%%DOCSDIR%%/RBSourceSearch.html
+%%DOCSDIR%%/RBSourceSearchBasic.html
+%%DOCSDIR%%/RBStaticPlaylistSource.html
%%DOCSDIR%%/RBStatusbar.html
+%%DOCSDIR%%/RBStreamingSource.html
%%DOCSDIR%%/RBStringValueMap.html
%%DOCSDIR%%/RBURIDialog.html
%%DOCSDIR%%/RhythmDB.html
%%DOCSDIR%%/RhythmDBImportJob.html
%%DOCSDIR%%/RhythmDBPropertyModel.html
+%%DOCSDIR%%/RhythmDBQueryModel.html
%%DOCSDIR%%/RhythmDBQueryResults.html
%%DOCSDIR%%/ch01.html
%%DOCSDIR%%/ch02.html
@@ -292,9 +304,7 @@ share/dbus-1/services/org.gnome.Rhythmbox.service
%%DOCSDIR%%/index.html
%%DOCSDIR%%/index.sgml
%%DOCSDIR%%/left.png
-%%DOCSDIR%%/rhythmbox-RBPodcastSource.html
%%DOCSDIR%%/rhythmbox-RBSourceGroup.html
-%%DOCSDIR%%/rhythmbox-eel-gconf-extensions.html
%%DOCSDIR%%/rhythmbox-rb-async-queue-watch.html
%%DOCSDIR%%/rhythmbox-rb-builder-helpers.html
%%DOCSDIR%%/rhythmbox-rb-debug.html
@@ -302,14 +312,9 @@ share/dbus-1/services/org.gnome.Rhythmbox.service
%%DOCSDIR%%/rhythmbox-rb-file-helpers.html
%%DOCSDIR%%/rhythmbox-rb-header.html
%%DOCSDIR%%/rhythmbox-rb-rating-helper.html
-%%DOCSDIR%%/rhythmbox-rb-removable-media-source.html
-%%DOCSDIR%%/rhythmbox-rb-shell.html
-%%DOCSDIR%%/rhythmbox-rb-static-playlist-source.html
-%%DOCSDIR%%/rhythmbox-rb-streaming-source.html
+%%DOCSDIR%%/rhythmbox-rb-text-helpers.html
%%DOCSDIR%%/rhythmbox-rb-tree-dnd.html
%%DOCSDIR%%/rhythmbox-rb-util.html
-%%DOCSDIR%%/rhythmbox-rhythmdb-query-model.html
-%%DOCSDIR%%/rhythmbox-rhythmdb-tree.html
%%DOCSDIR%%/rhythmbox.devhelp
%%DOCSDIR%%/rhythmbox.devhelp2
%%DOCSDIR%%/right.png
@@ -443,6 +448,20 @@ share/gnome/help/rhythmbox/oc/figures/rb-volume-changer.png
share/gnome/help/rhythmbox/oc/figures/rb-window-small.png
share/gnome/help/rhythmbox/oc/figures/rb-window.png
share/gnome/help/rhythmbox/oc/rhythmbox.xml
+share/gnome/help/rhythmbox/pt/figures/rb-iradio-main.png
+share/gnome/help/rhythmbox/pt/figures/rb-notification-area-menu.png
+share/gnome/help/rhythmbox/pt/figures/rb-notification-window.png
+share/gnome/help/rhythmbox/pt/figures/rb-notification-zone.png
+share/gnome/help/rhythmbox/pt/figures/rb-podcast-main.png
+share/gnome/help/rhythmbox/pt/figures/rb-statusbar.png
+share/gnome/help/rhythmbox/pt/figures/rb-toolbar-prevplaynext.png
+share/gnome/help/rhythmbox/pt/figures/rb-toolbar-repeat.png
+share/gnome/help/rhythmbox/pt/figures/rb-toolbar-shuffle.png
+share/gnome/help/rhythmbox/pt/figures/rb-toolbar.png
+share/gnome/help/rhythmbox/pt/figures/rb-volume-changer.png
+share/gnome/help/rhythmbox/pt/figures/rb-window-small.png
+share/gnome/help/rhythmbox/pt/figures/rb-window.png
+share/gnome/help/rhythmbox/pt/rhythmbox.xml
share/gnome/help/rhythmbox/ru/figures/rb-iradio-main.png
share/gnome/help/rhythmbox/ru/figures/rb-notification-area-menu.png
share/gnome/help/rhythmbox/ru/figures/rb-notification-window.png
@@ -502,6 +521,7 @@ share/gnome/help/rhythmbox/zh_CN/rhythmbox.xml
share/icons/hicolor/16x16/apps/rhythmbox.png
share/icons/hicolor/22x22/apps/rhythmbox.png
share/icons/hicolor/24x24/apps/rhythmbox.png
+share/icons/hicolor/24x24/places/music-library.png
share/icons/hicolor/32x32/apps/rhythmbox.png
share/icons/hicolor/48x48/apps/rhythmbox.png
share/icons/hicolor/scalable/apps/rhythmbox.svg
@@ -586,6 +606,7 @@ share/omf/rhythmbox/rhythmbox-es.omf
share/omf/rhythmbox/rhythmbox-fr.omf
share/omf/rhythmbox/rhythmbox-it.omf
share/omf/rhythmbox/rhythmbox-oc.omf
+share/omf/rhythmbox/rhythmbox-pt.omf
share/omf/rhythmbox/rhythmbox-ru.omf
share/omf/rhythmbox/rhythmbox-sv.omf
share/omf/rhythmbox/rhythmbox-uk.omf
@@ -603,6 +624,7 @@ share/rhythmbox/icons/hicolor/16x16/actions/playlist-new.png
share/rhythmbox/icons/hicolor/16x16/actions/podcast-new.png
share/rhythmbox/icons/hicolor/16x16/places/library-internet-radio.png
share/rhythmbox/icons/hicolor/16x16/places/library-podcast.png
+share/rhythmbox/icons/hicolor/16x16/places/music-library.png
share/rhythmbox/icons/hicolor/16x16/places/playlist-automatic.png
share/rhythmbox/icons/hicolor/16x16/places/playlist.png
share/rhythmbox/icons/hicolor/16x16/status/rhythmbox-no-star.png
@@ -688,6 +710,8 @@ share/rhythmbox/uri-new.ui
@dirrm share/gnome/help/rhythmbox/sv
@dirrm share/gnome/help/rhythmbox/ru/figures
@dirrm share/gnome/help/rhythmbox/ru
+@dirrm share/gnome/help/rhythmbox/pt/figures
+@dirrm share/gnome/help/rhythmbox/pt
@dirrm share/gnome/help/rhythmbox/oc/figures
@dirrm share/gnome/help/rhythmbox/oc
@dirrm share/gnome/help/rhythmbox/it/figures
diff --git a/audio/sound-juicer/Makefile b/audio/sound-juicer/Makefile
index acf84df22ca5..eb1383a5cd4d 100644
--- a/audio/sound-juicer/Makefile
+++ b/audio/sound-juicer/Makefile
@@ -3,12 +3,11 @@
# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/audio/sound-juicer/Makefile,v 1.96 2009/11/26 08:20:43 marcus Exp $
+# $MCom: ports/audio/sound-juicer/Makefile,v 1.98 2010/04/01 12:47:54 kwm Exp $
#
PORTNAME= sound-juicer
-PORTVERSION= 2.28.1
-PORTREVISION= 3
+PORTVERSION= 2.28.2
CATEGORIES= audio gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/audio/sound-juicer/distinfo b/audio/sound-juicer/distinfo
index 6433beb16e83..5490698b19a9 100644
--- a/audio/sound-juicer/distinfo
+++ b/audio/sound-juicer/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/sound-juicer-2.28.1.tar.bz2) = 680c036ca9b062fe198fada30edbf534
-SHA256 (gnome2/sound-juicer-2.28.1.tar.bz2) = 3142cce899812c6fb8c7145d52323f07d6ecfd6ca0503f4c7a32a12c00b8910c
-SIZE (gnome2/sound-juicer-2.28.1.tar.bz2) = 2159961
+MD5 (gnome2/sound-juicer-2.28.2.tar.bz2) = b40da7b2888d0c658fcfdff104ac8bbb
+SHA256 (gnome2/sound-juicer-2.28.2.tar.bz2) = f4dde2db5bfbae023ff5042257600f9acdb42626f878a079c271cc838eefae30
+SIZE (gnome2/sound-juicer-2.28.2.tar.bz2) = 2193659
diff --git a/audio/sound-juicer/pkg-plist b/audio/sound-juicer/pkg-plist
index db0061e36e6c..8237c6f3a029 100644
--- a/audio/sound-juicer/pkg-plist
+++ b/audio/sound-juicer/pkg-plist
@@ -76,6 +76,7 @@ share/icons/hicolor/48x48/apps/sound-juicer.png
share/icons/hicolor/scalable/apps/sound-juicer.svg
share/locale/ar/LC_MESSAGES/sound-juicer.mo
share/locale/as/LC_MESSAGES/sound-juicer.mo
+share/locale/ast/LC_MESSAGES/sound-juicer.mo
share/locale/az/LC_MESSAGES/sound-juicer.mo
share/locale/be/LC_MESSAGES/sound-juicer.mo
share/locale/be@latin/LC_MESSAGES/sound-juicer.mo
@@ -243,5 +244,7 @@ share/omf/sound-juicer/sound-juicer-uk.omf
@dirrmtry share/locale/bn_IN
@dirrmtry share/locale/be@latin/LC_MESSAGES
@dirrmtry share/locale/be@latin
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast
@dirrmtry share/locale/as/LC_MESSAGES
@dirrmtry share/locale/as