aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-03-31 02:20:39 +0800
committergarga <garga@FreeBSD.org>2006-03-31 02:20:39 +0800
commit7b3d67117a27b7f3d6c992389ef1e566e83b28ec (patch)
tree9b81d8b32743bfb0fba561228599d98f93a77067 /audio
parent347bcae58365e4607bc326aa67a6817ec97a1f7a (diff)
downloadfreebsd-ports-gnome-7b3d67117a27b7f3d6c992389ef1e566e83b28ec.tar.gz
freebsd-ports-gnome-7b3d67117a27b7f3d6c992389ef1e566e83b28ec.tar.zst
freebsd-ports-gnome-7b3d67117a27b7f3d6c992389ef1e566e83b28ec.zip
Fix build on amd64 and ia64 adding -fPIC and -DPIC
Reported by: krismail
Diffstat (limited to 'audio')
-rw-r--r--audio/hawkvoice/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/audio/hawkvoice/Makefile b/audio/hawkvoice/Makefile
index 98f5ac4bf9d3..bc7323e68666 100644
--- a/audio/hawkvoice/Makefile
+++ b/audio/hawkvoice/Makefile
@@ -32,6 +32,10 @@ OPTIONS= OPTIMIZATION "Enable optimization" off
.include <bsd.port.pre.mk>
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+CFLAGS+= -fPIC -DPIC
+.endif
+
.if defined(WITH_OPTIMIZATION)
CFLAGS+= -funroll-all-loops -ffast-math -fomit-frame-pointer -D_GNU_SOURCE -D_REENTRANT
.endif