aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorlx <lx@FreeBSD.org>2007-07-08 08:04:59 +0800
committerlx <lx@FreeBSD.org>2007-07-08 08:04:59 +0800
commit803317b447ae88593c035a27cbeef1fada7ced73 (patch)
tree7ef299d27f649e38c7ddf1624dfb3fb5d208934f /audio
parent15af86c15d6271ccf3a96806de8d5a1df22bdbe3 (diff)
downloadfreebsd-ports-gnome-803317b447ae88593c035a27cbeef1fada7ced73.tar.gz
freebsd-ports-gnome-803317b447ae88593c035a27cbeef1fada7ced73.tar.zst
freebsd-ports-gnome-803317b447ae88593c035a27cbeef1fada7ced73.zip
Adding tagger, a command line tagger for ogg-vorbis and ID3 tags.
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/tagger/Makefile26
-rw-r--r--audio/tagger/distinfo3
-rw-r--r--audio/tagger/files/patch-configure11
-rw-r--r--audio/tagger/pkg-descr3
5 files changed, 44 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 1ce9c8303839..723b609cda90 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -588,6 +588,7 @@
SUBDIR += swami
SUBDIR += sweep
SUBDIR += swhplugins
+ SUBDIR += tagger
SUBDIR += taglib
SUBDIR += tagtool
SUBDIR += tap-plugins
diff --git a/audio/tagger/Makefile b/audio/tagger/Makefile
new file mode 100644
index 000000000000..60a0ade1a0dc
--- /dev/null
+++ b/audio/tagger/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: tagger
+# Date created: 2007-07-07
+# Whom: David Thiel <lx@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tagger
+PORTVERSION= 0.2.7
+CATEGORIES= audio
+MASTER_SITES= http://onion.dynserv.net/~timo/files/ \
+ http://redundancy.redundancy.org/mirror/
+
+MAINTAINER= lx@FreeBSD.org
+COMMENT= CLI Ogg/Vorbis and MP3 ID3v1/ID3v1.1 tag editor
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS+=prefix=${TARGETDIR} mandir=${TARGETDIR}/man
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+PLIST_FILES= bin/tagger
+
+.include <bsd.port.mk>
diff --git a/audio/tagger/distinfo b/audio/tagger/distinfo
new file mode 100644
index 000000000000..d54f530dbe85
--- /dev/null
+++ b/audio/tagger/distinfo
@@ -0,0 +1,3 @@
+MD5 (tagger-0.2.7.tar.bz2) = b5535b3f22a899ceb1728617b190f13f
+SHA256 (tagger-0.2.7.tar.bz2) = 5d75526f3d421790ecfca78f333a9811a1e11e7f9794114d8b1a26b3bb1b05a7
+SIZE (tagger-0.2.7.tar.bz2) = 33200
diff --git a/audio/tagger/files/patch-configure b/audio/tagger/files/patch-configure
new file mode 100644
index 000000000000..658f56506a8c
--- /dev/null
+++ b/audio/tagger/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Sat Jul 7 16:57:39 2007
++++ configure Sat Jul 7 16:57:47 2007
+@@ -11,7 +11,7 @@
+ check_cc_flag -std=gnu99 -pipe -Wall -Wshadow -Wcast-align -Wpointer-arith \
+ -Wwrite-strings -Wundef -Wmissing-prototypes -Wredundant-decls
+
+- for i in -Wdeclaration-after-statement -Wold-style-definition -Wno-pointer-sign
++ for i in -Wdeclaration-after-statement -Wold-style-definition
+ do
+ check_cc_flag $i
+ done
diff --git a/audio/tagger/pkg-descr b/audio/tagger/pkg-descr
new file mode 100644
index 000000000000..4a95382b7762
--- /dev/null
+++ b/audio/tagger/pkg-descr
@@ -0,0 +1,3 @@
+[description of the port]
+
+WWW: http://port.home.page/