aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorgreid <greid@FreeBSD.org>2001-06-09 05:53:06 +0800
committergreid <greid@FreeBSD.org>2001-06-09 05:53:06 +0800
commit851556919e948777764a901bd850eb401c735a8d (patch)
treea8024bb7068bb32624558c5e645252dc94c048ce /audio
parente3b9439662ff27a975284129848c47f9e71c8a3f (diff)
downloadfreebsd-ports-gnome-851556919e948777764a901bd850eb401c735a8d.tar.gz
freebsd-ports-gnome-851556919e948777764a901bd850eb401c735a8d.tar.zst
freebsd-ports-gnome-851556919e948777764a901bd850eb401c735a8d.zip
Ooops...add a quick hack to make the example scripts work.
Diffstat (limited to 'audio')
-rw-r--r--audio/sbagen/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/audio/sbagen/Makefile b/audio/sbagen/Makefile
index d8a2189e04ee..d80907cd319e 100644
--- a/audio/sbagen/Makefile
+++ b/audio/sbagen/Makefile
@@ -27,6 +27,11 @@ DOCFILES= sbagen.txt theory.txt theory2.txt
do-build:
(cd ${WRKSRC} && ${CC} ${CFLAGS} sbagen.c -o sbagen -lm)
+post-patch:
+.for F in ${SHAREFILES}
+ @${PERL} -pi -e 's,/bin/bash,/bin/sh,g' ${WRKSRC}/$F
+.endfor
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sbagen ${PREFIX}/bin
${MKDIR} ${PREFIX}/share/sbagen