aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2009-01-10 10:45:46 +0800
committermezz <mezz@FreeBSD.org>2009-01-10 10:45:46 +0800
commit867a335b88f91d457005fa0c7b3bb7c85c5fca14 (patch)
tree68af898c9a11dd756c516c49a6715cee75888e70 /audio
parent6f64cd00171c29c1c7cdfb1e40393e23fc35151d (diff)
downloadfreebsd-ports-gnome-867a335b88f91d457005fa0c7b3bb7c85c5fca14.tar.gz
freebsd-ports-gnome-867a335b88f91d457005fa0c7b3bb7c85c5fca14.tar.zst
freebsd-ports-gnome-867a335b88f91d457005fa0c7b3bb7c85c5fca14.zip
Add a new framework for browser plugins, USE_WEBPLUGINS. It is for which foo
plugins support one of web browsers and can take care of plist (depend on how you use it) at the same time. I have written a complete document and even show how it works in the www/firefox/Makefile.webplugins so be sure to read in there. If there is anything that isn't clear in the document, please feel free to ask and I will try my best to improvement it. FYI: GNOME 2.24 depends on this, so it's coming. BTW: It's based on www/linux-mplayer-plugin/Makefile.npapi with heavy modified. Approved by: portmgr
Diffstat (limited to 'audio')
-rw-r--r--audio/rhythmbox-devel/Makefile11
-rw-r--r--audio/rhythmbox-devel/pkg-plist7
2 files changed, 12 insertions, 6 deletions
diff --git a/audio/rhythmbox-devel/Makefile b/audio/rhythmbox-devel/Makefile
index feb49b37da4f..118be6773970 100644
--- a/audio/rhythmbox-devel/Makefile
+++ b/audio/rhythmbox-devel/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/audio/rhythmbox-devel/Makefile,v 1.90 2008/03/17 04:31:25 marcus Exp $
+# $MCom: ports-stable/audio/rhythmbox-devel/Makefile,v 1.2 2009/01/09 23:41:21 mezz Exp $
#
PORTNAME= rhythmbox
PORTVERSION= 0.11.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.11
@@ -127,9 +127,14 @@ PLIST_SUB+= IPOD="@comment "
.if !defined(WITHOUT_GECKO_PLUGIN)
USE_GECKO= firefox mozilla seamonkey xulrunner<->firefox firefox-devel<->firefox
.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
+
+USE_WEBPLUGINS= gecko18
+WEBPLUGINS_FILES=librhythmbox-itms-detection-plugin.so
+.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
+
CONFIGURE_ARGS+=--enable-browser-plugin \
--with-gecko=${GECKO}
-CONFIGURE_ENV+= MOZILLA_PLUGINDIR=${BROWSER_PLUGINS_DIR}
+CONFIGURE_ENV+= MOZILLA_PLUGINDIR=${WEBPLUGINS_DIR}
PLIST_SUB+= GECKO_PLUGIN=""
.else
CONFIGURE_ARGS+=--disable-browser-plugin
diff --git a/audio/rhythmbox-devel/pkg-plist b/audio/rhythmbox-devel/pkg-plist
index f4d22b9ff2d4..d7d13860228d 100644
--- a/audio/rhythmbox-devel/pkg-plist
+++ b/audio/rhythmbox-devel/pkg-plist
@@ -1,8 +1,8 @@
bin/rhythmbox
bin/rhythmbox-client
-%%GECKO_PLUGIN%%lib/browser_plugins/librhythmbox-itms-detection-plugin.a
-%%GECKO_PLUGIN%%lib/browser_plugins/librhythmbox-itms-detection-plugin.la
-%%GECKO_PLUGIN%%lib/browser_plugins/librhythmbox-itms-detection-plugin.so
+%%GECKO_PLUGIN%%%%WEBPLUGINS_DIR%%/librhythmbox-itms-detection-plugin.a
+%%GECKO_PLUGIN%%%%WEBPLUGINS_DIR%%/librhythmbox-itms-detection-plugin.la
+%%GECKO_PLUGIN%%%%WEBPLUGINS_DIR%%/librhythmbox-itms-detection-plugin.so
lib/librhythmbox-core.a
lib/librhythmbox-core.la
lib/librhythmbox-core.so
@@ -609,6 +609,7 @@ share/rhythmbox/rhythmbox-ui.xml
%%PYTHON%%@dirrm lib/rhythmbox/plugins/artdisplay
@dirrm lib/rhythmbox/plugins
@dirrm lib/rhythmbox
+%%GECKO_PLUGIN%%@dirrmtry %%WEBPLUGINS_DIR%%
@dirrmtry share/applications
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK