aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-06-25 19:14:38 +0800
committeritetcu <itetcu@FreeBSD.org>2006-06-25 19:14:38 +0800
commit87b8e2a1ba7178d400a096fdee11a2fb10b4534d (patch)
tree6856d3675de0bd14f9926ae0d227ac5247a2f61a /audio
parentd3443fbb4247f645baa55f658734fd64ece1413c (diff)
downloadfreebsd-ports-gnome-87b8e2a1ba7178d400a096fdee11a2fb10b4534d.tar.gz
freebsd-ports-gnome-87b8e2a1ba7178d400a096fdee11a2fb10b4534d.tar.zst
freebsd-ports-gnome-87b8e2a1ba7178d400a096fdee11a2fb10b4534d.zip
Ruby ecore mainloop bindings for XMMS2.
PR: ports/99390 Submitted by: Alexander Botero-Lowry <alex@foxybanana.com>
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/ruby-xmms2-ecore/Makefile38
-rw-r--r--audio/ruby-xmms2-ecore/pkg-plist2
3 files changed, 41 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 51f8f3a45bc6..cccb7b996d22 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -482,6 +482,7 @@
SUBDIR += ruby-vorbisfile
SUBDIR += ruby-xmms
SUBDIR += ruby-xmms2
+ SUBDIR += ruby-xmms2-ecore
SUBDIR += rubygem-mp3info
SUBDIR += s3mod
SUBDIR += sbagen
diff --git a/audio/ruby-xmms2-ecore/Makefile b/audio/ruby-xmms2-ecore/Makefile
new file mode 100644
index 000000000000..1785fcb71aff
--- /dev/null
+++ b/audio/ruby-xmms2-ecore/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: ruby-xmms2-ecore
+# Date created: 23 Jun 2006
+# Whom: Alexander Botero-Lowry <alex@foxybanana.com>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= audio ruby
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+PKGNAMESUFFIX= -ecore
+
+MAINTAINER= alex@foxybanana.com
+COMMENT= Ruby ecore mainloop bindings for XMMS2
+
+BUILD_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/xmmsclient.so:${PORTSDIR}/audio/ruby-xmms2
+RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/xmmsclient.so:${PORTSDIR}/audio/ruby-xmms2
+
+MASTERDIR= ${.CURDIR}/../xmms2
+
+USE_RUBY= yes
+USE_GNOME= glib20
+USE_LDCONFIG= yes
+
+PLIST= ${.CURDIR}/pkg-plist
+
+SCONS_TARGET= src/clients/lib/xmmsclient-ecore/libxmmsclient-ecore.so \
+ src/clients/lib/ruby/xmmsclient_ecore.so
+XMMS2_SLAVE= ruby-ecore
+
+do-install:
+ @cd ${WRKSRC} && ${INSTALL_PROGRAM} \
+ src/clients/lib/ruby/xmmsclient_ecore.so \
+ ${RUBY_SITEARCHLIBDIR}/xmmsclient_ecore.so
+ @cd ${WRKSRC} && ${INSTALL_PROGRAM} \
+ src/clients/lib/xmmsclient-ecore/libxmmsclient-ecore.so \
+ ${LOCALBASE}/lib/libxmmsclient-ecore.so
+
+.include "${MASTERDIR}/Makefile"
diff --git a/audio/ruby-xmms2-ecore/pkg-plist b/audio/ruby-xmms2-ecore/pkg-plist
new file mode 100644
index 000000000000..149ac357ecf0
--- /dev/null
+++ b/audio/ruby-xmms2-ecore/pkg-plist
@@ -0,0 +1,2 @@
+%%RUBY_SITEARCHLIBDIR%%/xmmsclient_ecore.so
+lib/libxmmsclient-ecore.so