aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-12-26 13:52:15 +0800
committerwill <will@FreeBSD.org>2000-12-26 13:52:15 +0800
commit941e0473d6638ba935e3f168ab0c4ed2dba622db (patch)
tree3408d5b073346502ec53b17a5999167ffe4c8b07 /audio
parent17851423f639a37f17f9af779c464b859de22d45 (diff)
downloadfreebsd-ports-gnome-941e0473d6638ba935e3f168ab0c4ed2dba622db.tar.gz
freebsd-ports-gnome-941e0473d6638ba935e3f168ab0c4ed2dba622db.tar.zst
freebsd-ports-gnome-941e0473d6638ba935e3f168ab0c4ed2dba622db.zip
Add ecasound 1.8.5d15, a software package designed for multitrack audio
processing. PR: 23778 Submitted by: The Anarcat <beaupran@iro.umontreal.ca>
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/ecasound/Makefile38
-rw-r--r--audio/ecasound/distinfo1
-rw-r--r--audio/ecasound/files/patch-aa12
-rw-r--r--audio/ecasound/files/patch-ab51
-rw-r--r--audio/ecasound/files/patch-ac16
-rw-r--r--audio/ecasound/files/patch-ad10
-rw-r--r--audio/ecasound/files/patch-ae22
-rw-r--r--audio/ecasound/files/patch-af16
-rw-r--r--audio/ecasound/files/patch-ag14
-rw-r--r--audio/ecasound/pkg-comment1
-rw-r--r--audio/ecasound/pkg-descr22
-rw-r--r--audio/ecasound/pkg-plist151
13 files changed, 355 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 8cf4f6bd2107..92ce85829f71 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -22,6 +22,7 @@
SUBDIR += csound-manual
SUBDIR += dagrab
SUBDIR += dap
+ SUBDIR += ecasound
SUBDIR += esound
SUBDIR += extace
SUBDIR += fcplay
diff --git a/audio/ecasound/Makefile b/audio/ecasound/Makefile
new file mode 100644
index 000000000000..0405cf5037b0
--- /dev/null
+++ b/audio/ecasound/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: ecasound
+# Date created: 22 dec 2000
+# Whom: The Anarcat <anarcat@tao.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ecasound
+PORTVERSION= 1.8.5d15
+CATEGORIES= audio
+MASTER_SITES= http://ecasound.seul.org/download/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ecawave
+
+MAINTAINER= anarcat@tao.ca
+
+# RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123 \
+# lame:${PORTSDIR}/audio/lame \
+# mikmod:${PORTSDIR}/audio/mikmod
+
+# LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_AUTOMAKE= yes
+
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+
+MAN1= ecasound-iam.1 ecasound.1 ecatools.1
+MAN5= ecasoundrc.5
+
+#post-install:
+# strip ${PREFIX}/bin/ecaconvert ${PREFIX}/bin/ecafixdc \
+#${PREFIX}/bin/ecanormalize ${PREFIX}/bin/ecaplay ${PREFIX}/bin/ecasignalview \
+#${PREFIX}/bin/ecasound ${PREFIX}/bin/ecasound-config ${PREFIX}/bin/ecasoundc-config
+
+.include <bsd.port.mk>
diff --git a/audio/ecasound/distinfo b/audio/ecasound/distinfo
new file mode 100644
index 000000000000..c73d1bf4dc50
--- /dev/null
+++ b/audio/ecasound/distinfo
@@ -0,0 +1 @@
+MD5 (ecasound-1.8.5d15.tar.gz) = 9e9f1480b026c37e95efdeab16e0dec7
diff --git a/audio/ecasound/files/patch-aa b/audio/ecasound/files/patch-aa
new file mode 100644
index 000000000000..f5bcdb372829
--- /dev/null
+++ b/audio/ecasound/files/patch-aa
@@ -0,0 +1,12 @@
+--- config.h.in.orig Wed Nov 22 12:41:03 2000
++++ config.h.in Fri Dec 22 13:45:14 2000
+@@ -52,6 +52,9 @@
+ /* Define if you have the getpagesize function. */
+ #undef HAVE_GETPAGESIZE
+
++/* Define if you have the mlockall function. */
++#undef HAVE_MLOCKALL
++
+ /* Define if you have the <asm/atomic.h> header file. */
+ #undef HAVE_ASM_ATOMIC_H
+
diff --git a/audio/ecasound/files/patch-ab b/audio/ecasound/files/patch-ab
new file mode 100644
index 000000000000..a4e71b63d077
--- /dev/null
+++ b/audio/ecasound/files/patch-ab
@@ -0,0 +1,51 @@
+--- configure.in.orig Thu Dec 7 00:50:49 2000
++++ configure.in Fri Dec 22 13:45:14 2000
+@@ -38,6 +38,7 @@
+
+ dnl --
+ dnl Libtool
++AM_PROG_LIBTOOL
+ AC_PATH_PROG(LIBTOOL,libtool,none)
+ if test x$LIBTOOL = xnone; then
+ AC_MSG_ERROR([** Libtool package not installed! **])
+@@ -46,7 +47,6 @@
+ if test x$GNUM4 = xnone; then
+ AC_MSG_ERROR([** GNU m4 not installed! **])
+ fi
+-AM_PROG_LIBTOOL
+
+ ACLOCAL=aclocal
+ AUTOMAKE=automake
+@@ -106,7 +106,7 @@
+ include_debug=yes)
+ AM_CONDITIONAL(INCLUDE_DEBUG, test x$include_debug = xyes)
+ if test x$include_debug = xyes; then
+-CXXFLAGS="-D_REENTRANT -DENABLE_DBC -g -Wall -Wstrict-prototypes -ffast-math"
++CXXFLAGS="$CXXFLAGS -D_REENTRANT -DENABLE_DBC -g -Wall -Wstrict-prototypes -ffast-math"
+ dnl LDFLAGS="-pg -pedantic -funroll-loops"
+ fi
+
+@@ -123,6 +123,7 @@
+ dnl Checks for functions.
+ dnl ---
+ AC_FUNC_MMAP
++AC_CHECK_FUNCS(mlockall)
+
+ dnl ---
+ dnl Checks for libraries.
+@@ -152,15 +153,6 @@
+ )
+ AC_DEFINE(USE_NCURSES)
+ fi
+-
+-dnl ------------------------------------------------------------------
+-
+-dnl ---
+-dnl POSIX.4 threads
+-dnl ---
+-AC_CHECK_LIB(pthread,pthread_create, [],
+- AC_CHECK_LIB(c_r,pthread_create, [],
+- AC_MSG_ERROR([** POSIX.4 threads not installed or broken **])))
+
+ dnl ------------------------------------------------------------------
+
diff --git a/audio/ecasound/files/patch-ac b/audio/ecasound/files/patch-ac
new file mode 100644
index 000000000000..20f936e65a29
--- /dev/null
+++ b/audio/ecasound/files/patch-ac
@@ -0,0 +1,16 @@
+--- libecasound/eca-chainsetup-position.cpp.orig Fri Oct 6 18:08:00 2000
++++ libecasound/eca-chainsetup-position.cpp Wed Dec 20 00:42:14 2000
+@@ -43,11 +43,11 @@
+ }
+
+ long int ECA_CHAINSETUP_POSITION::length_in_seconds(void) const {
+- return(static_cast<double>(length_rep) / srate_rep);
++ return(static_cast<long int>(length_rep) / srate_rep);
+ }
+
+ long int ECA_CHAINSETUP_POSITION::position_in_seconds(void) const {
+- return(static_cast<double>(curpos_rep) / srate_rep);
++ return(static_cast<long int>(curpos_rep) / srate_rep);
+ }
+
+ double ECA_CHAINSETUP_POSITION::length_in_seconds_exact(void) const {
diff --git a/audio/ecasound/files/patch-ad b/audio/ecasound/files/patch-ad
new file mode 100644
index 000000000000..2cecb5330839
--- /dev/null
+++ b/audio/ecasound/files/patch-ad
@@ -0,0 +1,10 @@
+--- libecasound/eca-object-map.cpp/orig Thu Nov 16 20:03:48 2000
++++ libecasound/eca-object-map.cpp Mon Dec 18 19:04:48 2000
+@@ -20,6 +20,7 @@
+ #include <vector>
+ #include <string>
+ #include <map>
++#include <sys/types.h>
+ #include <regex.h>
+
+ #include "eca-object-map.h"
diff --git a/audio/ecasound/files/patch-ae b/audio/ecasound/files/patch-ae
new file mode 100644
index 000000000000..8ca16e10a591
--- /dev/null
+++ b/audio/ecasound/files/patch-ae
@@ -0,0 +1,22 @@
+--- libecasound/eca-session.cpp.orig Mon Dec 4 22:22:22 2000
++++ libecasound/eca-session.cpp Wed Dec 20 01:21:51 2000
+@@ -389,14 +389,18 @@
+ int prio = ::atoi(get_argument_number(1, argu).c_str());
+ if (prio != 0)
+ schedpriority_rep = prio;
+- ecadebug->msg("(eca-session) Raised-priority mode enabled. Locking memory. (prio:" +
++ ecadebug->msg("(eca-session) Raised-priority mode enabled (prio:" +
+ kvu_numtostr(schedpriority_rep) + ")");
+ raisepriority_rep = true;
++#ifdef HAVE_MLOCKALL
+ if (::mlockall (MCL_CURRENT|MCL_FUTURE)) {
+ ecadebug->msg("(eca-session) Warning! Couldn't lock all memory!");
+ }
+ else
+ ecadebug->msg(ECA_DEBUG::system_objects, "(eca-session) Memory locked!");
++#else
++ ecadebug->msg("(eca-session) Memory locking not available.");
++#endif
+ break;
+ }
+
diff --git a/audio/ecasound/files/patch-af b/audio/ecasound/files/patch-af
new file mode 100644
index 000000000000..a63cab2e3432
--- /dev/null
+++ b/audio/ecasound/files/patch-af
@@ -0,0 +1,16 @@
+--- libecasoundc/Makefile.am.orig Sun Nov 26 22:13:33 2000
++++ libecasoundc/Makefile.am Fri Dec 22 02:51:28 2000
+@@ -9,10 +9,10 @@
+ # remember to update eca-version.cpp
+ if INCLUDE_DEBUG
+ eca_ldflags = -version-info 0:0:0
+-ecasound_libs = -lecasound_debug
++ecasound_libs = -L$(top_builddir)/libecasound/.libs -lecasound_debug
+ else
+ eca_ldflags = -s -version-info 0:0:0
+-ecasound_libs = -lecasound
++ecasound_libs = -L$(top_builddir)/libecasound/.libs -lecasound
+ endif
+
+ if KVUTILS_INSTALLED
+
diff --git a/audio/ecasound/files/patch-ag b/audio/ecasound/files/patch-ag
new file mode 100644
index 000000000000..c8f83d280182
--- /dev/null
+++ b/audio/ecasound/files/patch-ag
@@ -0,0 +1,14 @@
+--- pyecasound/Makefile.am.orig Tue Dec 5 20:46:42 2000
++++ pyecasound/Makefile.am Fri Dec 22 02:53:02 2000
+@@ -6,9 +6,9 @@
+ # ----------------------------------------------------------------------
+
+ if INCLUDE_DEBUG
+-ecasound_libs = -lecasound_debug
++ecasound_libs = -L$(top_builddir)/libecasound/.libs -lecasound_debug
+ else
+-ecasound_libs = -lecasound
++ecasound_libs = -L$(top_builddir)/libecasound/.libs -lecasound
+ endif
+
+ if KVUTILS_INSTALLED
diff --git a/audio/ecasound/pkg-comment b/audio/ecasound/pkg-comment
new file mode 100644
index 000000000000..a6597719849f
--- /dev/null
+++ b/audio/ecasound/pkg-comment
@@ -0,0 +1 @@
+Software package designed for multitrack audio processing.
diff --git a/audio/ecasound/pkg-descr b/audio/ecasound/pkg-descr
new file mode 100644
index 000000000000..5c7dbc801a6a
--- /dev/null
+++ b/audio/ecasound/pkg-descr
@@ -0,0 +1,22 @@
+=======================================================================
+*** [Extract from] Ecasound - README ***
+=======================================================================
+-----------------------------------------------------------------------
+ What is it?
+-----------------------------------------------------------------------
+
+Ecasound is a software package designed for multitrack audio
+processing. It can be used for simple tasks like audio playback,
+recording and format conversions, as well as for multitrack effect
+processing, mixing, recording and signal recycling. Ecasound supports
+a wide range of audio inputs, outputs and effect algorithms.
+Effects and audio objects can be combined in various ways, and their
+parameters can be controlled by operator objects like oscillators
+and MIDI-CCs. As most functionality is located in shared libraries,
+creating alternative user-interfaces is easy. A versatile console mode
+interface is included in the package.
+
+Ecasound home site
+WWW: http://www.eca.cx/ecasound
+
+- The Anarcat <anarcat@tao.ca>
diff --git a/audio/ecasound/pkg-plist b/audio/ecasound/pkg-plist
new file mode 100644
index 000000000000..6bdbc4034693
--- /dev/null
+++ b/audio/ecasound/pkg-plist
@@ -0,0 +1,151 @@
+@name ecasound-1.8.5d15
+bin/ecaconvert
+bin/ecafixdc
+bin/ecanormalize
+bin/ecaplay
+bin/ecasignalview
+bin/ecasound
+bin/ecasound-config
+bin/ecasoundc-config
+include/ecasound/audiofx.h
+include/ecasound/audiofx_amplitude.h
+include/ecasound/audiofx_analysis.h
+include/ecasound/audiofx_compressor.h
+include/ecasound/audiofx_envelope_modulation.h
+include/ecasound/audiofx_filter.h
+include/ecasound/audiofx_impl.h
+include/ecasound/audiofx_ladspa.h
+include/ecasound/audiofx_mixing.h
+include/ecasound/audiofx_rcfilter.h
+include/ecasound/audiofx_reverb.h
+include/ecasound/audiofx_timebased.h
+include/ecasound/audiofx_vst.h
+include/ecasound/audiogate.h
+include/ecasound/audioio-buffered-proxy.h
+include/ecasound/audioio-cdr.h
+include/ecasound/audioio-cdr_impl.h
+include/ecasound/audioio-ewf.h
+include/ecasound/audioio-forked-stream.h
+include/ecasound/audioio-loop.h
+include/ecasound/audioio-mikmod.h
+include/ecasound/audioio-mp3.h
+include/ecasound/audioio-mp3_impl.h
+include/ecasound/audioio-null.h
+include/ecasound/audioio-ogg.h
+include/ecasound/audioio-oss.h
+include/ecasound/audioio-oss_impl.h
+include/ecasound/audioio-plugin.h
+include/ecasound/audioio-proxy-buffer.h
+include/ecasound/audioio-proxy-server.h
+include/ecasound/audioio-raw.h
+include/ecasound/audioio-rtnull.h
+include/ecasound/audioio-timidity.h
+include/ecasound/audioio-types.h
+include/ecasound/audioio-wave.h
+include/ecasound/audioio.h
+include/ecasound/ctrl-source.h
+include/ecasound/dynamic-object.h
+include/ecasound/dynamic-parameters.h
+include/ecasound/eca-audio-format.h
+include/ecasound/eca-audio-object-map.h
+include/ecasound/eca-audio-objects.h
+include/ecasound/eca-audio-position.h
+include/ecasound/eca-audio-time.h
+include/ecasound/eca-chain.h
+include/ecasound/eca-chainop-map.h
+include/ecasound/eca-chainop.h
+include/ecasound/eca-chainsetup-position.h
+include/ecasound/eca-chainsetup.h
+include/ecasound/eca-comhelp.h
+include/ecasound/eca-control-base.h
+include/ecasound/eca-control-dump.h
+include/ecasound/eca-control-interface.h
+include/ecasound/eca-control-objects.h
+include/ecasound/eca-control.h
+include/ecasound/eca-controller-map.h
+include/ecasound/eca-debug.h
+include/ecasound/eca-error.h
+include/ecasound/eca-fileio-mmap.h
+include/ecasound/eca-fileio-stream.h
+include/ecasound/eca-fileio.h
+include/ecasound/eca-iamode-parser.h
+include/ecasound/eca-ladspa-plugin-map.h
+include/ecasound/eca-main.h
+include/ecasound/eca-midi.h
+include/ecasound/eca-object-factory.h
+include/ecasound/eca-object-map.h
+include/ecasound/eca-object.h
+include/ecasound/eca-operator.h
+include/ecasound/eca-preset-map.h
+include/ecasound/eca-resources.h
+include/ecasound/eca-session.h
+include/ecasound/eca-static-object-maps.h
+include/ecasound/eca-version.h
+include/ecasound/eca-vst-plugin-map.h
+include/ecasound/ecasoundc.h
+include/ecasound/file-preset.h
+include/ecasound/finite-envelope.h
+include/ecasound/generic-controller.h
+include/ecasound/global-preset.h
+include/ecasound/ladspa.h
+include/ecasound/layer.h
+include/ecasound/linear-envelope.h
+include/ecasound/midi-cc.h
+include/ecasound/osc-gen.h
+include/ecasound/osc-sine.h
+include/ecasound/oscillator.h
+include/ecasound/plugin-paths.h
+include/ecasound/preset.h
+include/ecasound/resource-file.h
+include/ecasound/sample-specs.h
+include/ecasound/samplebuffer.h
+include/ecasound/samplebuffer_functions.h
+include/ecasound/samplebuffer_impl.h
+include/ecasound/samplebuffer_iterators.h
+include/ecasound/two-stage-linear-envelope.h
+include/kvutils/com_line.h
+include/kvutils/definition_by_contract.h
+include/kvutils/kvu_numtostr.h
+include/kvutils/kvutils.h
+include/kvutils/locks.h
+include/kvutils/message_item.h
+include/kvutils/object_queue.h
+include/kvutils/procedure_timer.h
+include/kvutils/value_queue.h
+lib/libecasound.a
+lib/libecasound.la
+lib/libecasound.so
+lib/libecasound.so.7
+lib/libecasoundc.a
+lib/libecasoundc.la
+lib/libecasoundc.so
+lib/libecasoundc.so.0
+lib/libkvutils.a
+lib/libkvutils.la
+lib/libkvutils.so
+lib/libkvutils.so.2
+lib/ecasound-plugins/libaudioio_af.la
+lib/ecasound-plugins/libaudioio_af.so
+lib/ecasound-plugins/libaudioio_alsa.la
+lib/ecasound-plugins/libaudioio_alsa.so
+lib/ecasound-plugins/libaudioio_alsa2.la
+lib/ecasound-plugins/libaudioio_alsa2.so
+lib/ecasound-plugins/libaudioio_alsa2_plugin.la
+lib/ecasound-plugins/libaudioio_alsa2_plugin.so
+lib/ecasound-plugins/libaudioio_alsa3.la
+lib/ecasound-plugins/libaudioio_alsa3.so
+lib/ecasound-plugins/libaudioio_alsalb.la
+lib/ecasound-plugins/libaudioio_alsalb.so
+lib/ecasound-plugins/libaudioio_arts.la
+lib/ecasound-plugins/libaudioio_arts.so
+share/ecasound/effect_presets
+share/ecasound/generic_oscillators
+lib/python1.5/site-packages/pyeca.py
+lib/python1.5/site-packages/libpyecasound.la
+lib/python1.5/site-packages/libpyecasound.so
+@dirrm share/ecasound
+@dirrm include/ecasound
+@dirrm lib/ecasound-plugins
+@unexec rmdir %D/lib/python1.5/site-packages 2>/dev/null || true
+@exec /sbin/ldconfig -m %D/lib
+@unexec /sbin/ldconfig -R