aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2016-11-04 22:55:05 +0800
committerjhale <jhale@FreeBSD.org>2016-11-04 22:55:05 +0800
commit949b41b79e4c7225198695119c699685dbdf2777 (patch)
treeaead23c5ac198927859b68210c8a8f95c8e96df9 /audio
parenta27e578894cf8db926d3ea905f160c9a9c12d529 (diff)
downloadfreebsd-ports-gnome-949b41b79e4c7225198695119c699685dbdf2777.tar.gz
freebsd-ports-gnome-949b41b79e4c7225198695119c699685dbdf2777.tar.zst
freebsd-ports-gnome-949b41b79e4c7225198695119c699685dbdf2777.zip
- Sync with Github 632e879 to allow building with upcoming ffmpeg 3.x [1]
- This includes several changes that were already made by local patches - Changes since release: - Fix taglib detection - Fix build with ffmpeg 3.x - Fix build with gcc 6 - Add dependency on desktop-file-utils to satisfy stage-qa - Bump PORTREVISION PR: 214183 [1] Submitted by: jbeich [1]
Diffstat (limited to 'audio')
-rw-r--r--audio/acoustid-fingerprinter/Makefile13
-rw-r--r--audio/acoustid-fingerprinter/distinfo5
-rw-r--r--audio/acoustid-fingerprinter/files/patch-decoder.h13
-rw-r--r--audio/acoustid-fingerprinter/files/patch-git_68ef0541
4 files changed, 8 insertions, 64 deletions
diff --git a/audio/acoustid-fingerprinter/Makefile b/audio/acoustid-fingerprinter/Makefile
index 73bbbeec0458..a01148508773 100644
--- a/audio/acoustid-fingerprinter/Makefile
+++ b/audio/acoustid-fingerprinter/Makefile
@@ -2,10 +2,8 @@
PORTNAME= acoustid-fingerprinter
PORTVERSION= 0.6
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
-MASTER_SITES= http://bitbucket.org/acoustid/${PORTNAME}/downloads/ \
- GHC
MAINTAINER= jhale@FreeBSD.org
COMMENT= AcoustID audio fingerprint submission tool
@@ -16,19 +14,18 @@ LIB_DEPENDS= libchromaprint.so:audio/chromaprint \
libtag.so:audio/taglib \
libavcodec.so:multimedia/ffmpeg
-USES= cmake
-USE_QT4= gui network \
+USES= cmake desktop-file-utils
+USE_QT4= corelib gui network \
qmake_build moc_build rcc_build uic_build
USE_GITHUB= yes
-GH_ACCOUNT= lalinsky
+GH_ACCOUNT= acoustid
+GH_TAGNAME= 632e879
INSTALLS_ICONS= yes
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/cmake/modules/*.cmake
- @${REINPLACE_CMD} -e 's,CodecID,AVCodecID,g' \
- ${WRKSRC}/ffmpeg/audioconvert.h
post-install:
.for i in 16 24 32 48 128 256
diff --git a/audio/acoustid-fingerprinter/distinfo b/audio/acoustid-fingerprinter/distinfo
index 864dfde98414..7c4572916c91 100644
--- a/audio/acoustid-fingerprinter/distinfo
+++ b/audio/acoustid-fingerprinter/distinfo
@@ -1,2 +1,3 @@
-SHA256 (acoustid-fingerprinter-0.6.tar.gz) = c0165d4210a181b2baa5e72159bf3f1a9b76398da8794305ddf8e1923ca76f32
-SIZE (acoustid-fingerprinter-0.6.tar.gz) = 93897
+TIMESTAMP = 1478268997
+SHA256 (acoustid-acoustid-fingerprinter-0.6-632e879_GH0.tar.gz) = 2f08b53c9cedcabb6c6cbd21801a1dfacf82405a1d9ede9a4968cf5d0e43172d
+SIZE (acoustid-acoustid-fingerprinter-0.6-632e879_GH0.tar.gz) = 135963
diff --git a/audio/acoustid-fingerprinter/files/patch-decoder.h b/audio/acoustid-fingerprinter/files/patch-decoder.h
deleted file mode 100644
index 6c3df3f3285b..000000000000
--- a/audio/acoustid-fingerprinter/files/patch-decoder.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- decoder.h.orig 2012-09-05 18:43:51 UTC
-+++ decoder.h
-@@ -35,6 +35,10 @@ extern "C" {
- }
- #include "fingerprintcalculator.h"
-
-+#ifndef AVCODEC_MAX_AUDIO_FRAME_SIZE
-+#define AVCODEC_MAX_AUDIO_FRAME_SIZE 192000 // 1 second of 48khz 32bit audio
-+#endif
-+
- #if LIBAVCODEC_VERSION_INT < AV_VERSION_INT(52, 64, 0)
- #define AV_SAMPLE_FMT_S16 SAMPLE_FMT_S16
- #endif
diff --git a/audio/acoustid-fingerprinter/files/patch-git_68ef05 b/audio/acoustid-fingerprinter/files/patch-git_68ef05
deleted file mode 100644
index 0e61e694cdcf..000000000000
--- a/audio/acoustid-fingerprinter/files/patch-git_68ef05
+++ /dev/null
@@ -1,41 +0,0 @@
-From 681ef059e4bdb0a9b1a073d6cbb9bb54e993fef9 Mon Sep 17 00:00:00 2001
-From: Johannes Dewender <bitbucket@JonnyJD.net>
-Date: Tue, 8 Dec 2015 17:48:33 +0100
-Subject: [PATCH] fix cmake for taglib 1.10
-
-We have to use VERSION_LESS, rather than STRLESS.
-Otherwise we get this error message:
-- TagLib version too old: version searched :1.6, found 1.10
----
- cmake/modules/FindTaglib.cmake | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/cmake/modules/FindTaglib.cmake b/cmake/modules/FindTaglib.cmake
-index 76b83ac..5a985f9 100644
---- cmake/modules/FindTaglib.cmake
-+++ cmake/modules/FindTaglib.cmake
-@@ -29,10 +29,10 @@ if(TAGLIBCONFIG_EXECUTABLE)
-
- exec_program(${TAGLIBCONFIG_EXECUTABLE} ARGS --version RETURN_VALUE _return_VALUE OUTPUT_VARIABLE TAGLIB_VERSION)
-
-- if(TAGLIB_VERSION STRLESS "${TAGLIB_MIN_VERSION}")
-+ if(TAGLIB_VERSION VERSION_LESS "${TAGLIB_MIN_VERSION}")
- message(STATUS "TagLib version too old: version searched :${TAGLIB_MIN_VERSION}, found ${TAGLIB_VERSION}")
- set(TAGLIB_FOUND FALSE)
-- else(TAGLIB_VERSION STRLESS "${TAGLIB_MIN_VERSION}")
-+ else(TAGLIB_VERSION VERSION_LESS "${TAGLIB_MIN_VERSION}")
-
- exec_program(${TAGLIBCONFIG_EXECUTABLE} ARGS --libs RETURN_VALUE _return_VALUE OUTPUT_VARIABLE TAGLIB_LIBRARIES)
-
-@@ -42,7 +42,7 @@ if(TAGLIBCONFIG_EXECUTABLE)
- set(TAGLIB_FOUND TRUE)
- endif(TAGLIB_LIBRARIES AND TAGLIB_CFLAGS)
- string(REGEX REPLACE " *-I" ";" TAGLIB_INCLUDES "${TAGLIB_CFLAGS}")
-- endif(TAGLIB_VERSION STRLESS "${TAGLIB_MIN_VERSION}")
-+ endif(TAGLIB_VERSION VERSION_LESS "${TAGLIB_MIN_VERSION}")
- mark_as_advanced(TAGLIB_CFLAGS TAGLIB_LIBRARIES TAGLIB_INCLUDES)
-
- else(TAGLIBCONFIG_EXECUTABLE)
---
-2.1.1.1.g1fb337f
-