aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2015-11-29 00:51:41 +0800
committerrakuco <rakuco@FreeBSD.org>2015-11-29 00:51:41 +0800
commita4a6f5b793eaa38771bd82ca463c16cf23895b7d (patch)
treeb63018a0ce492adfbe93fe919019c8a474d6e7c4 /audio
parent5c0a917f18e34818cc1379d1a4c3c2a3ae759f7a (diff)
downloadfreebsd-ports-gnome-a4a6f5b793eaa38771bd82ca463c16cf23895b7d.tar.gz
freebsd-ports-gnome-a4a6f5b793eaa38771bd82ca463c16cf23895b7d.tar.zst
freebsd-ports-gnome-a4a6f5b793eaa38771bd82ca463c16cf23895b7d.zip
Fix the ALSA=OFF build after r402530.
Both extrapatch-no_alsa and patch-git_d6927712 touch the same region of CMakeLists.txt, and the latter was failing to apply when the ALSA option was disabled. Fix it by keeping patch-git_d6927712 (which fixes the CFLAGS values regardless of the value of the ALSA option) and replacing extrapatch-no_alsa with some post-patch/post-configure changes that achieve the same end result. PR: 204858 MFH: 2015Q4
Diffstat (limited to 'audio')
-rw-r--r--audio/libkcompactdisc/Makefile8
-rw-r--r--audio/libkcompactdisc/files/extrapatch-no_alsa16
2 files changed, 7 insertions, 17 deletions
diff --git a/audio/libkcompactdisc/Makefile b/audio/libkcompactdisc/Makefile
index e31147b972e3..36262458c767 100644
--- a/audio/libkcompactdisc/Makefile
+++ b/audio/libkcompactdisc/Makefile
@@ -19,6 +19,12 @@ USE_LDCONFIG= yes
OPTIONS_DEFINE= ALSA
ALSA_LIB_DEPENDS= libasound.so:${PORTSDIR}/audio/alsa-lib
-ALSA_EXTRA_PATCHES_OFF= ${FILESDIR}/extrapatch-no_alsa
+
+post-patch-ALSA-off:
+ ${REINPLACE_CMD} -e '/find_package(Alsa)/d' \
+ -e '/alsa_configure_file/d' ${WRKSRC}/CMakeLists.txt
+
+post-configure-ALSA-off:
+ ${TOUCH} ${CONFIGURE_WRKSRC}/config-alsa.h
.include <bsd.port.mk>
diff --git a/audio/libkcompactdisc/files/extrapatch-no_alsa b/audio/libkcompactdisc/files/extrapatch-no_alsa
deleted file mode 100644
index 2f83175e4738..000000000000
--- a/audio/libkcompactdisc/files/extrapatch-no_alsa
+++ /dev/null
@@ -1,16 +0,0 @@
---- CMakeLists.txt.orig 2013-07-09 23:19:54.000000000 +0000
-+++ CMakeLists.txt 2013-08-12 23:11:31.141329406 +0000
-@@ -8,10 +8,10 @@
-
- ## Compiler flags
- if(CMAKE_COMPILER_IS_GNUCXX)
-- set(CMAKE_C_FLAGS "-std=c99") ## ALSA no longer compiles with -std=c90, see https://bugzilla.novell.com/show_bug.cgi?id=817077
-+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c99") ## ALSA no longer compiles with -std=c90, see https://bugzilla.novell.com/show_bug.cgi?id=817077
- endif()
--find_package(Alsa)
--alsa_configure_file(${CMAKE_CURRENT_BINARY_DIR}/config-alsa.h)
-+find_file(CONFIG_ALSA_H_CMAKE config-alsa.h.cmake ${CMAKE_MODULE_PATH})
-+configure_file(${CONFIG_ALSA_H_CMAKE} ${CMAKE_BINARY_DIR}/config-alsa.h)
-
- include_directories(${KDE4_INCLUDES})
- include_directories(${CMAKE_CURRENT_BINARY_DIR} ${CMAKE_CURRENT_SOURCE_DIR})