aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorjadawin <jadawin@FreeBSD.org>2009-02-05 18:47:09 +0800
committerjadawin <jadawin@FreeBSD.org>2009-02-05 18:47:09 +0800
commitc5bc5016bdad22da69be587b7b527996363c1ab6 (patch)
tree89520fb777e5dce3ad06e4dd9ca19aa95774a31f /audio
parentb6f6624e36fd8d85f396f6ad20b149262fdf8935 (diff)
downloadfreebsd-ports-gnome-c5bc5016bdad22da69be587b7b527996363c1ab6.tar.gz
freebsd-ports-gnome-c5bc5016bdad22da69be587b7b527996363c1ab6.tar.zst
freebsd-ports-gnome-c5bc5016bdad22da69be587b7b527996363c1ab6.zip
- Add patch to correct lame --genre-list
- Bump PORTREVISION PR: ports/131307 Submitted by: Tobias Rehbein <tobias.rehbein at web.de>
Diffstat (limited to 'audio')
-rw-r--r--audio/ogg2mp3/Makefile2
-rw-r--r--audio/ogg2mp3/files/patch-ogg2mp311
2 files changed, 12 insertions, 1 deletions
diff --git a/audio/ogg2mp3/Makefile b/audio/ogg2mp3/Makefile
index d5cbd4c99c59..c241a146f54a 100644
--- a/audio/ogg2mp3/Makefile
+++ b/audio/ogg2mp3/Makefile
@@ -6,7 +6,7 @@
PORTNAME= ogg2mp3
PORTVERSION= 0.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://amor.cms.hu-berlin.de/~h0444y2j/pub/
diff --git a/audio/ogg2mp3/files/patch-ogg2mp3 b/audio/ogg2mp3/files/patch-ogg2mp3
new file mode 100644
index 000000000000..b65976fa567f
--- /dev/null
+++ b/audio/ogg2mp3/files/patch-ogg2mp3
@@ -0,0 +1,11 @@
+--- ./ogg2mp3.orig 2009-02-02 20:13:18.000000000 +0000
++++ ./ogg2mp3 2009-02-02 20:13:44.000000000 +0000
+@@ -68,7 +68,7 @@
+
+ # build genre hash
+ my %genres;
+-open(GENRES, "$MP3ENC --genre-list|") or die "Couldn't get genre list with $MP3ENC --genre-list\n";
++open(GENRES, "$MP3ENC --genre-list 2>&1 |") or die "Couldn't get genre list with $MP3ENC --genre-list\n";
+ while(<GENRES>) {
+ chomp;
+ next if /^\s*$/;