aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2013-03-13 23:31:03 +0800
committerpawel <pawel@FreeBSD.org>2013-03-13 23:31:03 +0800
commitc9a032e50e1430711f762f588177e4c8ef1b40ce (patch)
tree2fec038cc60e340127eec242d676e1f34d4ac082 /audio
parent36561eda472a42f0ee68546e061a242f3688cdff (diff)
downloadfreebsd-ports-gnome-c9a032e50e1430711f762f588177e4c8ef1b40ce.tar.gz
freebsd-ports-gnome-c9a032e50e1430711f762f588177e4c8ef1b40ce.tar.zst
freebsd-ports-gnome-c9a032e50e1430711f762f588177e4c8ef1b40ce.zip
- Respect CFLAGS
- Fix build with clang - Convert to OptionsNG - Trim Makefile header PR: ports/176766 Submitted by: myself Approved by: Martin Dieringer <martin.dieringer@gmx.de> (maintainer)
Diffstat (limited to 'audio')
-rw-r--r--audio/dvda-author/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/audio/dvda-author/Makefile b/audio/dvda-author/Makefile
index 5319680f0f0d..a50f1aa18e4f 100644
--- a/audio/dvda-author/Makefile
+++ b/audio/dvda-author/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: dvda-author
-# Date created: 9 October 2007
-# Whom: dieringe@zedat.fu-berlin.de
-#
+# Created by: dieringe@zedat.fu-berlin.de
# $FreeBSD$
-#
PORTNAME= dvda-author
PORTVERSION= 09.05
@@ -34,8 +30,19 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-flac=${LOCALBASE}/lib/libFLAC.so \
--with-ogg=${LOCALBASE}/lib/libogg.so \
--enable-glibc
-.if defined(NOPORTDOCS)
+USE_CSTD= gnu89
+
+.include <bsd.port.options.mk>
+
+.if ! ${PORT_OPTIONS:MDOCS}
CONFIGURE_ARGS+= --docdir=${WRKDIR}/doc
.endif
+post-patch:
+ @${REINPLACE_CMD} 's|-std=c99||g' \
+ ${WRKSRC}/configure \
+ ${WRKSRC}/libats2wav/Makefile.in
+ @${REINPLACE_CMD} 's|-std=c99 -O3||' \
+ ${WRKSRC}/fixwav/src/Makefile.in
+
.include <bsd.port.mk>