aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2009-09-01 19:38:49 +0800
committerbsam <bsam@FreeBSD.org>2009-09-01 19:38:49 +0800
commitd19609a348edea37c1a94781afe356592f91a0e5 (patch)
treed621803462fb0047787175d2f9cbf04386813eef /audio
parentc34d93e092a2bf50068278d82d1544edc84f2b83 (diff)
downloadfreebsd-ports-gnome-d19609a348edea37c1a94781afe356592f91a0e5.tar.gz
freebsd-ports-gnome-d19609a348edea37c1a94781afe356592f91a0e5.tar.zst
freebsd-ports-gnome-d19609a348edea37c1a94781afe356592f91a0e5.zip
Add linux-nas-libs 1.8, runtime libraries for NAS (Linux Fedora Core 4).
Requested by: mezz (at freebsd-emulation)
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/linux-nas-libs/Makefile40
-rw-r--r--audio/linux-nas-libs/distinfo.i3866
3 files changed, 47 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 0f06cc62d788..8423991aada4 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -410,6 +410,7 @@
SUBDIR += linux-libvorbis
SUBDIR += linux-mbrola
SUBDIR += linux-mikmod
+ SUBDIR += linux-nas-libs
SUBDIR += linux-nerodigitalaudio
SUBDIR += linux-openal
SUBDIR += linux-sdl_mixer
diff --git a/audio/linux-nas-libs/Makefile b/audio/linux-nas-libs/Makefile
new file mode 100644
index 000000000000..d1be99edb26e
--- /dev/null
+++ b/audio/linux-nas-libs/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: audio/linux-nas-libs
+# Date created: 2009-09-01
+# Whom: bsam
+#
+# $FreeBSD$
+#
+
+PORTNAME= nas
+PORTVERSION= 1.8
+CATEGORIES= audio linux
+MASTER_SITE_SUBDIR= ../extras/${LINUX_DIST_VER}/${LINUX_RPM_ARCH}/ \
+ ../extras/${LINUX_DIST_VER}/SRPMS/
+PKGNAMEPREFIX= linux-
+PKGNAMESUFFIX= -libs
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${RPMVERSION}
+
+MAINTAINER= freebsd-emulation@FreeBSD.org
+COMMENT= Runtime libraries for NAS (Linux Fedora Core 4)
+
+USE_LINUX_RPM= yes
+USE_LINUX_APPS= xorglibs
+LINUX_DIST_VER= 4
+RPMVERSION= 10.fc4
+USE_LDCONFIG= yes
+
+PLIST_FILES= usr/lib/libaudio.so.2 usr/lib/libaudio.so.2.4
+DOCSDIR= ${PREFIX}/usr/share/doc/${PORTNAME}-${PORTVERSION}
+PORTDOCS= BUGS FAQ HISTORY README TODO
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+
+REMOVE_DIRS= etc usr/X11R6 usr/bin usr/share/man
+
+# we need libraries only (Fedora 10 already has a separate RPM file
+# for libraries)
+pre-install:
+ @for D in ${REMOVE_DIRS}; do \
+ ${RM} -rf ${WRKSRC}/$$D; \
+ done
+
+.include <bsd.port.mk>
diff --git a/audio/linux-nas-libs/distinfo.i386 b/audio/linux-nas-libs/distinfo.i386
new file mode 100644
index 000000000000..58ac6da8f8b4
--- /dev/null
+++ b/audio/linux-nas-libs/distinfo.i386
@@ -0,0 +1,6 @@
+MD5 (rpm/i386/fedora/4/nas-1.8-10.fc4.i386.rpm) = 30fb97730ba53baafefd3918ee709352
+SHA256 (rpm/i386/fedora/4/nas-1.8-10.fc4.i386.rpm) = 243a56fa8481ce5aaa5e1fdd4d272514f098ed447b75acf588bc21bec21b47f6
+SIZE (rpm/i386/fedora/4/nas-1.8-10.fc4.i386.rpm) = 624000
+MD5 (rpm/i386/fedora/4/nas-1.8-10.fc4.src.rpm) = 5d8b642b2c2059e01bd06153f9376d91
+SHA256 (rpm/i386/fedora/4/nas-1.8-10.fc4.src.rpm) = bbdf1bdbd2b7a00c3d1e621bd20e3bb0c3bbb73ebef60f6ef7cb8c65989fad50
+SIZE (rpm/i386/fedora/4/nas-1.8-10.fc4.src.rpm) = 1288941