aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2012-06-25 00:23:49 +0800
committercrees <crees@FreeBSD.org>2012-06-25 00:23:49 +0800
commite1a66eeddaf6493bbb84e1582ef1cf9e4a82bd24 (patch)
tree4ef6387f74b036a01d9859e26d1540015cb2ef4e /audio
parentb8a6971a239ad9ff4f796b5db5b930c36141167a (diff)
downloadfreebsd-ports-gnome-e1a66eeddaf6493bbb84e1582ef1cf9e4a82bd24.tar.gz
freebsd-ports-gnome-e1a66eeddaf6493bbb84e1582ef1cf9e4a82bd24.tar.zst
freebsd-ports-gnome-e1a66eeddaf6493bbb84e1582ef1cf9e4a82bd24.zip
Remove unnecessary dependency on freeswitch-core
(While here, use ECHO_CMD) Approved by: Richard Neese (maintainer)
Diffstat (limited to 'audio')
-rw-r--r--audio/freeswitch-sounds/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/audio/freeswitch-sounds/Makefile b/audio/freeswitch-sounds/Makefile
index 6f43d6c6231a..a3e3201598cf 100644
--- a/audio/freeswitch-sounds/Makefile
+++ b/audio/freeswitch-sounds/Makefile
@@ -16,13 +16,14 @@ DIST_SUBDIR= freeswitch-sounds
MAINTAINER= r.neese@gmail.com
COMMENT= FreeSwitch Sounds (All Bitrates)
-RUN_DEPENDS= freeswitch:${PORTSDIR}/net/freeswitch-core
-
PLIST= ${WRKDIR}/plist
NO_WRKSUBDIR= yes
SHAREOWN= ${PORTNAME}
SHAREGRP= ${SHAREOWN}
+USERS= ${PORTNAME}
+GROUPS= ${USERS}
+
OPTIONS= DOWNLOAD "Don't resample, download all." off \
8K "Compile sounds for 8K" on \
16K "Compile sounds for 16K" on \
@@ -176,12 +177,15 @@ do-build:
pre-install:
@${RM} ${PLIST}
@cd ${WRKDIR}/tmp && ${FIND} * ! -type d | ${SORT} >> ${PLIST}; \
- ${ECHO} .${PORTNAME}${PKGNAMESUFFIX} >> ${PLIST}; \
+ ${ECHO_CMD} .${PORTNAME}${PKGNAMESUFFIX} >> ${PLIST}; \
${REINPLACE_CMD} -e "s:^:${DATADIR_REL}/sounds/:" ${PLIST}; \
${FIND} * -type d ! -empty | ${SORT} -r | ${SED} -e "s:^:@dirrm ${DATADIR_REL}/sounds/:" | ${GREP} / >> ${PLIST}
+ @${ECHO_CMD} "@dirrmtry ${DATADIR_REL}/sounds" >> ${PLIST}
+ @${ECHO_CMD} "@dirrmtry ${DATADIR_REL}" >> ${PLIST}
do-install:
@${ECHO_MSG} "Installing files..."
+ ${MKDIR} ${DATADIR}/sounds
${TOUCH} ${DATADIR}/sounds/.freeswitch-sounds
(cd ${WRKDIR}/tmp/ && ${COPYTREE_SHARE} \* ${DATADIR}/sounds/)