aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-05-25 06:07:58 +0800
committeritetcu <itetcu@FreeBSD.org>2006-05-25 06:07:58 +0800
commite8e0a8e1e53b44518e6feaaed72347b1f9bb81c7 (patch)
treeb7243816099e8d710518ffc7745365c5a73ae659 /audio
parentd49f3127a6fc18d228db33009527f0969e9943ee (diff)
downloadfreebsd-ports-gnome-e8e0a8e1e53b44518e6feaaed72347b1f9bb81c7.tar.gz
freebsd-ports-gnome-e8e0a8e1e53b44518e6feaaed72347b1f9bb81c7.tar.zst
freebsd-ports-gnome-e8e0a8e1e53b44518e6feaaed72347b1f9bb81c7.zip
- Backport a word around from xmms2-devel.git to make the python bindings
work with pyrex 0.9.4 (which is currently in ports) - Bumb PORTREVISION to make sure it gets rebuilt Added file(s): - files/patch-src_clients_lib_python_xmmsclient.pyx PR: ports/97675 Submitted by: maintainer Approved by: tmclaugh (mentor)
Diffstat (limited to 'audio')
-rw-r--r--audio/xmms2/Makefile2
-rw-r--r--audio/xmms2/files/patch-src_clients_lib_python_xmmsclient.pyx12
2 files changed, 13 insertions, 1 deletions
diff --git a/audio/xmms2/Makefile b/audio/xmms2/Makefile
index d0566aca4299..b701d10e8de0 100644
--- a/audio/xmms2/Makefile
+++ b/audio/xmms2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xmms2
PORTVERSION= 0.2.d.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/audio/xmms2/files/patch-src_clients_lib_python_xmmsclient.pyx b/audio/xmms2/files/patch-src_clients_lib_python_xmmsclient.pyx
new file mode 100644
index 000000000000..30fc647a8ad7
--- /dev/null
+++ b/audio/xmms2/files/patch-src_clients_lib_python_xmmsclient.pyx
@@ -0,0 +1,12 @@
+--- src/clients/lib/python/xmmsclient.pyx.orig Tue May 23 01:02:46 2006
++++ src/clients/lib/python/xmmsclient.pyx Tue May 23 01:03:14 2006
+@@ -273,7 +273,8 @@
+ if k[1] == item:
+ return v
+ try:
+- return dict.__getitem__(self, (src, item))
++ x = dict.__getitem__(self, (src, item))
++ return x
+ except KeyError:
+ pass
+ raise KeyError, item